WordPress.org

Ready to get started?Download WordPress

Forums

Lightbox Gallery
[resolved] Change Language (11 posts)

  1. nigelnix
    Member
    Posted 2 years ago #

    Hi Guys,

    I have installed lightbox-gallery and see all the language files in the main folder but I don't know how to activate them...what do I need to do to get the German text and images to work...I'm sure it must be easy but I can't find the solution here... :o(

    http://wordpress.org/extend/plugins/lightbox-gallery/

  2. nigelnix
    Member
    Posted 2 years ago #

    I mean....a little note under localization in the "readme" about how to change language and in which file it is contained would really help ;o)

  3. AJenbo
    Member
    Posted 2 years ago #

    This should work automatically, are you sure you configured WP to your language?

  4. doeme
    Member
    Posted 2 years ago #

    Hi there

    I installed WordPress in german and my gallery sais "Image x of x" instead of "Bild x von x".

    If you figure out how to change this, I'm interested too :)

    Cheers

    Dominik

  5. nigelnix
    Member
    Posted 2 years ago #

    I got mine working by using info here which says to change the language in config.php

    http://codex.wordpress.org/Installing_WordPress_in_Your_Language

    All the German image files are already included in:

    ../lightbox-gallery/images/de_DE

    albeit badly made :o(

  6. doeme
    Member
    Posted 2 years ago #

    There already was de_De:

    define('WPLANG', 'de_DE');

    But it shows as "Image ...."

  7. Mexx
    Member
    Posted 1 year ago #

    There already was de_De:

    define('WPLANG', 'de_DE');

    But it shows as "Image ...."

    same for me. My language is correctly set to 'de_DE'
    but I keep seeing "Image x of x". Also I can't find the place where this phrase is in the englisch .po file..?!

    Any one solved it?

  8. formicula
    Member
    Posted 1 year ago #

    hello und hallo :-)

    ich habe das selbe Problem, konnte es schon jemand lösen?

    i'm having the same problem, was anyone able to solve it yet?

  9. drbrahm
    Member
    Posted 1 year ago #

    I am facing the same problem. My WP language is pt_BR

  10. janwin
    Member
    Posted 1 year ago #

    Solutions:

    PREV/NEXT/CLOSE-Labels/Graphics:
    You have to actively replace the standard-images in /wp-content/plugins/lightbox-gallery/images/ with the ones e.g. supplied in the subfolder "de_DE" or your own images.

    "Image x of x"-Phrase:
    It seems as if this is not covered by the standard-language-files.
    Instead, go here:
    /wp-content/plugins/lightbox-gallery/js/jquery.lightbox.js
    Line 38 ("Configuration related to texts in caption") and alter it the way you want it to appear:
    // Configuration related to texts in caption. For example: Image 2 of 8. You can alter either "Image" and "of" texts.
    txtImage: 'Bild', // (string) Specify text "Image"
    txtOf: 'von', // (string) Specify text "of"

    Hope this helps.

  11. edupinho
    Member
    Posted 1 year ago #

    Nice solution, janwin.

    It worked for me, my problem was changing "image" and "of" to "Imagem" and "de" - language pt_BR. Thank you very much!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic