WordPress.org

Ready to get started?Download WordPress

Forums

leenk.me
Pictures do not transfer (19 posts)

  1. AZmom4Him
    Member
    Posted 2 years ago #

    I am very non-techy so I may be doing something wrong, but everything transfers smoothly except the photos. They don't show up at all. What am I doing wrong? By the way, I LOVE this plugin so far...I have tried others and they were so confusing and complicated that I gave up on them. Your plugin is so easy even a newbie like me had no problem setting it up! Thanks! :)

    http://wordpress.org/extend/plugins/leenkme/

  2. leenkme
    Member
    Plugin Author

    Posted 2 years ago #

    Hey AZmom4Him,

    I'm glad you're liking the plugin... I tried to make it as simple as possible (though sometimes things aren't as simple as I like!).

    Anyway, regarding your photos, the way the plugin determines which picture to use, is as follows:

    Check to see if you have custom post meta "facebook_image" set, if so, use that URL
    If not, check to see if you have a "featured image" set, if so, use that URL
    If not, check to see if there are any images "attached" to the post, if so, use that URL
    If not, check to see if there is a "Default Image" set in the plugin's Facebook settings, if so, use that URL
    If not, use a default blank image hosted at leenk.me.

    How are you setting the image in the post?

  3. audiferd
    Member
    Posted 2 years ago #

    I'm having the same problem when trying to use leenk.me with Facebook. No image shows up even though I have images in the post, set a featured image and set a default image.

  4. leenkme
    Member
    Plugin Author

    Posted 2 years ago #

    Does the image you're setting show up in the leenk.me preview box? Are your images uploaded through the post or through a image gallery plugin like NextGEN Gallery?

  5. audiferd
    Member
    Posted 2 years ago #

    Yes, the image shows up in the preview box. The images are uploaded through the post.

    Thanks for the fast response.

  6. leenkme
    Member
    Plugin Author

    Posted 2 years ago #

    That's odd... can you email me temporary admin credentials to your site so I can take a look? http://leenk.me/contact/

  7. audiferd
    Member
    Posted 2 years ago #

    I just did some additional testing. I set up two brand new wordpress sites - one online using my normal hosting service and one on my local server using WAMP where I do most of my development work. The images showed up fine when using the online site but did not show up when using the site on my local server. My previous posts above were based on my initial tests using a different site on my local server.

    Hopefully that helps a bit. Is there some odd php extension that needs to be activated to make this work using WAMP? Lot's of plug-ins need cURL which I had to activate.

    Thanks again for your help.

  8. leenkme
    Member
    Plugin Author

    Posted 2 years ago #

    What is the URL to one of your images? If you're just developing on your local machine and your image is something like http://localhost/wp-content/uploads/2012/08/image.jpg

    Then Facebook will reject it (since it isn't a valid domain). The image doesn't actually get sent to Facebook, just the URL to the image.

    Does that make sense?

    Lew

  9. AZmom4Him
    Member
    Posted 2 years ago #

    I am using the Easy Gallery for my images - maybe that has something to do with it? I am not sure what you mean by "is it showing up in the preview?" - what preview do you mean? (sorry, like I said this is my first blog and I am very much in the learning phase!)

  10. leenkme
    Member
    Plugin Author

    Posted 2 years ago #

    Hi AZmom4Him,

    Easy Gallery probably has something to do with it.

    When you're adding/editing a new post, you can scroll down to see a little box for leenk.me with a preview of what your content will look like in your social networks. If you click the Facebook tab on this window it should show you the image.

    Try uploading an image with the regular WordPress gallery when you add your next post, see if that works... if it does, then we know it is probably the Easy Gallery. Let me know and I'll try to find a way to get it to work with Easy Gallery :).

    Lew

  11. AZmom4Him
    Member
    Posted 2 years ago #

    Ok, I tried uploading an image without Easy Gallery, and it did the same thing. The image didn't show up on the preview section either (I didn't even notice that before - thank you!). I guess I am doing something wrong... :(

  12. leenkme
    Member
    Plugin Author

    Posted 2 years ago #

    AZmom4Him, Can you email me temporary admin credentials to your site so I can take a look? http://leenk.me/contact/

  13. audiferd
    Member
    Posted 2 years ago #

    Thanks for the explanation, Lew. That totally makes sense and covers why it won't upload.

    On a slightly different but related subject, Is it possible to upload larger images? Like if you were in Facebook and entered a post and photo to the timeline which scales them to 403px.

    Thanks again for your assistance and a great plugin.

  14. leenkme
    Member
    Plugin Author

    Posted 2 years ago #

    auidferd,

    Facebook does have an API for uploading image, but it's not built into leenk.me, leenk.me is all about sharing posts. The API for uploading images would just be uploading an image to your account, it wouldn't be sharing a "post" like leenk.me does.

    Lew

  15. audiferd
    Member
    Posted 2 years ago #

    Understood. Thanks again.

  16. AZmom4Him
    Member
    Posted 2 years ago #

    Did you get my info? Not sure if I did it right... :)

  17. leenkme
    Member
    Plugin Author

    Posted 2 years ago #

    Hi AZmom4Him,

    Yep, I just logged in. I had to set the image as a featured image for it to work -- which I did with the "Vintage lunchbox tutorial is available now!" post (you can see it if you edit it now).

    These are the steps I took. Logged into WordPress, Posts -> All Posts, click the post to edit it (you can also do this when you add a new post). Click the "Add Media" button (between the post title and the post content). If you upload an image from here you can click the link "use as featured image" or if you go to the Media Library tab you can "Show" an image and then click the "use as featured image" link from there as well.

    Let me know if you need further instructions. It doesn't look like the Easy Gallery plugin has the right options to make it work with leenk.me, unfortunately.

    Lew

  18. AZmom4Him
    Member
    Posted 1 year ago #

    Do you know the name of a gallery plugin that is simple enough for a non-techie that works with your program? Thanks again for all your help!

    Tammy

  19. leenkme
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Tammy,

    None work with leenk.me out of the box, but I have some code for NextGEN Gallery that will work. You'll still have to set one of the images as a "featured image" though.

    Lew

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags