WordPress.org

Ready to get started?Download WordPress

Forums

Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps)
[resolved] [Plugin: Leaflet Maps Marker] Insert Map button in TinyMCE not working... (8 posts)

  1. lucabarbetti
    Member
    Posted 2 years ago #

    ...or the other possibility is that I do not understand how it works.
    When I click on Insert Map button in a new post/page, I get an http 404 error and the popup window says that it is not possible to open the page. I wonder what 'page' it is looking for, because if I use shortcodes the map is displayed correctly but if I try to insert the map through the button I get that error.
    At present I am testing LMM plugin with Instant WordPress and only a couple of other plugins are installed, namely Polylang and WP-Native Dashboard (plus the ones included in WordPress 3.3.1).
    Last but not least, kudos and congratulations to the author for this great plugin and for keeping it free.
    Thanks a lot!!!

    http://wordpress.org/extend/plugins/leaflet-maps-marker/

  2. RobertHarm
    Member
    Plugin Author

    Posted 2 years ago #

    Mhhh - didnt notice this bug on my sites. Could you give me temporary admin access to your site so that I can take a look into the issue? (send login data to info(a)mapsmarker.com if ok for you)

    BTW: this support would be free as it helps making my plugin more compatible with more different webhosts - nethertheless I'd be glad if you could vote for the plugin on wordpress.org ;-)

  3. RobertHarm
    Member
    Plugin Author

    Posted 2 years ago #

    The tinymce function will be optimized in v2.1. I guess I also found the problem which could cause the error on your installation.

    I will try to release v2.1 this weekend. I´d advise you to update to this version afterwards and only if the error still exists, I would have to take a look on your installation to find out more.

    Regards,
    Robert

  4. lucabarbetti
    Member
    Posted 2 years ago #

    Hi Robert,
    unfortunately I have been testing Leaflet Maps Marker locally on my PC with InstantPress. Since you said that you have not experienced anything similar, I gave LMM a try in different environments and there the button worked. I guess that it is a problem related to the combo InstantPress+LMM and not a bug in Leaflet Maps Marker. In fact using either XAMPP or WebMatrix the button worked as expected.
    I will try the new release as soon as it becomes downloadable! :)
    On a side note, I have translated your plugin in italian because I need that language too and, even if I translated all the strings in the .pot file, there are strings that still appear untranslated either in the backend or in the frontend. Being a first draft there are still some adjustments that I have to do in the translation, if you want it I could email you the .po and .mo files when they are ready. Just let me know.
    Thanks again for your support and for your great plugin.
    Have a nice day

  5. RobertHarm
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Luca,
    Yes - a local install could cause those problems - we will see if this gets fixed with v2.1

    Ad Italian translation: yes, please send me the file so that I can include them in the release which is planed for saturday or sunday - please also tell me the credits and link I should use.

    Actually all important text strings should be included - I only left out company names, words like ID... Please check if your po file is based on v2.0 - you can do so easily by opening the file with poedit and choosing refresh from pot file from the menu and select the file lmm.pot from the latest release

    Many thanks,
    Robert

  6. lucabarbetti
    Member
    Posted 2 years ago #

    Hi Robert,
    I have just emailed you the .po .mo files.
    No problem, I am just glad to help.
    Luca

  7. lucabarbetti
    Member
    Posted 2 years ago #

    By the way, Robert, is it possible to deactivate the zooming effect with the mouse scrolling wheel? Maybe it is just me but I do not like this feature combined with maps, I think it is user "unfriendly" because most of the times I end up zooming when I just want to scroll the page instead.
    Thanks a lot,
    Luca

  8. RobertHarm
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Luca,

    Thanks for the Italian translation!

    Ad disabling zoom: I think there is an option for that in the leaflet library. I will check that and see if I can add this feature in one of the next releases.
    Regards,

    Robert

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic