WordPress.org

Ready to get started?Download WordPress

Forums

Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps)
[resolved] [Plugin: Leaflet Maps Marker] Icon-path in multisite-use (9 posts)

  1. mats_
    Member
    Posted 1 year ago #

    Hi Robert,

    I like Leaflet Maps Marker, and I like to combine different marker-icons. Now I want to use the plugin in a WordPress Multisite. Most things work fine, but I can't choose the marker-icons. The plugin looks for subdirectories /de/... resp. /en/... that doesn't exist - they are generated on the fly.

    Is there a way to change the icon-directory?

    Thanx, Matthias

    http://wordpress.org/extend/plugins/leaflet-maps-marker/

  2. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    I guess this is a problem with a redirection/language plugin. If you use one, try if it works without. Icon-dir is retrieved from wp_uploads_dir-function (leaflet-maps-marker.php line 42) & normally also works for multisite. you can try to enter a hardcoded url there but I wouldnt advise this as it gets overwritten on plugin updates

  3. mats_
    Member
    Posted 1 year ago #

    Well, I deactivated all plugins, but it was still the same. But in leaflet-maps-marker.php there's reverence to the standard upload-directory, and so I found the empty leaflet-maps-marker-icons directory under blogs.dir. This is the directory I need, not the path shown next to the icon-section of the marker edit page. Now it works.
    Thank you, Matthias

  4. acrogenesis
    Member
    Posted 1 year ago #

    i'm having this problem mats_ what did you change? in leaflet-maps-marker.php

    here is the location of the files:
    http://www.redso.mx/wp-content/blogs.dir/5/files/leaflet-maps-marker-icons/planecrash.png

    but the image being pointed here
    http://www.redso.mx/delicias/files/leaflet-maps-marker-icons/planecrash.png

  5. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    Hi acrogenesis,
    could you grant me temporary admin access to your site so that I can take a look? Acutally there shouldnt be any problems with icons directories anymore :-/
    regards,
    Robert

  6. acrogenesis
    Member
    Posted 1 year ago #

    i added a user with admin for you, (check spam) i used your email robert@harm.co.at

    Thank you :)

  7. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    no email received yet with a password - please resend manually too

  8. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I checked your installation and could find any bugs within my plugin. I also compared with my multisite test instance and found no abnormalities.

    I guess the problem has to do with your apache webserver. I´d advise you to contact your hoster to take a look into the apache configuration and look for "508 unused" errors. According to http://www.askapache.com/htaccess/apache-status-code-headers-errordocument.html#508_unused
    the error means that

    "The server encountered an internal error or misconfigurationand was unable to complete your request. More information about this error may be available in the server error log."
    Hope this help you solving the issue!
    regards,

    Robert

    PS: as I give support for free, I´d appreciate a donation and/or a vote for the plugin on wordpress.org ;-)

  9. acrogenesis
    Member
    Posted 1 year ago #

    I just found the problem! i had added security on my .htaccess
    i just removed this, and it worked

    # Block the include-only files.
    RewriteEngine On
    RewriteBase /
    RewriteRule ^wp-admin/includes/ - [F,L]
    RewriteRule !^wp-includes/ - [S=3]
    RewriteRule ^wp-includes/[^/]+\.php$ - [F,L]
    RewriteRule ^wp-includes/js/tinymce/langs/.+\.php - [F,L]
    RewriteRule ^wp-includes/theme-compat/ - [F,L]

    Thanks :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic