WordPress.org

Ready to get started?Download WordPress

Forums

  1. munrobr
    Member
    Posted 1 year ago #

    I can't seem to get the map to fully load. It loads a portion, so I'd like to run the v3 resize event bind, but I'm not sure exactly how to do that with this plugin. Can I go it within the page as a separate <script> or does it have to be done within the plugin's javascript file? New to WordPress and I know script orders are tricky...

    If I can get this figured out I will most likely use it with all sites requiring Google maps.

    Current site I'm on is http://www.grapememories.com

    http://wordpress.org/extend/plugins/leaflet-maps-marker/

  2. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    you should have to use resize event binds - I am currently seeing your site on my ipad so I cant debug with firebug, but it seems to me, that your templates css is somehow overwriting the maps css. Try switching to another template like twentyeleven for example to test this. If the map gets displayed correctly, then this was the reason and your templates css has to be adapted.
    regards,
    Robert

    PS: as I give support for free, I'd appreciate your vote for my plugin on wordpress.org ;-)

  3. munrobr
    Member
    Posted 1 year ago #

    I'm just unsure how to put the map object in the resize. I tried doing google.maps.event.trigger(map, "resize"); but I honestly don't know what the object name is to put into that first parameter. I think the CSS should be fine. It's just cause the silly sidebar pops in with javascript, which messes with the page size when your plugin loads. That's what it feels like anyway.

  4. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    I debug you css with firebug and couldnt find anything. Have you tried switching to the default theme, just to be sure that the templates css is not the reason?
    Another strange thing: when I opened your map with Chrome, opened console by F12 and changing the size of the console afterwards, the map change to be correctly shown. Perhaps it has to do with the slider - try disabling for test purposes to see if this helps.
    Another idea: you are calling google maps js many times in <head> - I have seen a similar issue on another site when google maps js was called twice - perhaps you could also remove the not needed code in order to see if that makes a difference...

  5. munrobr
    Member
    Posted 1 year ago #

    Yeah when I open console or minimize sometimes it pops in properly, which makes me think it's a frame resize issue. The css appears to be fine and it works on a standard template... As you can see it loads within a jQuery popout box on the site, which you can minimize.

    I only see 1 google maps call, where are you seeing multiple calls? Maybe the cache? I had it running 2 plugins at once before, but now it's just running your leaflets plugin.

    Do you know how I could attach that resize function to your map outside of that javascript file? I think if we can somehow get that object into that resize function in like the footer section after everything loads, we might be okay. I just have no idea how to do that.

  6. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    strange strange strange.

    Ad multiple Google maps calls: now they are gone from the code - I am sure they were there yesterday which made me think you were testing other mapping plugins too simultanesly.

    ad resize: I dont think that adding a resize function would help - my guess is still that there is a conflict with the slider. Try disabling it to see if it works if possible.

    Another way to find a fix I can recommend: post your problem at wpquestions.com - I often got to solution to nasty problems very quickly there...I could also connect you to a developer whose company already did some work on my plugin and could help you with your problem.

  7. munrobr
    Member
    Posted 1 year ago #

    Yeah I was testing other plugins.

    I disabled the slider and I'm still having the issue, unfortunately.

    I'll take a look over there for help. If it comes down to it I may request their services. Thanks a lot!

  8. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    you're welcome!
    let me know if you could fix it - I am always interested in how I can make my plugin more compatible (if possible)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic