WordPress.org

Ready to get started?Download WordPress

Forums

Lazyest Gallery
[resolved] Not valid image file (25 posts)

  1. FranklynJones
    Member
    Posted 2 years ago #

    Hi there,

    When I try to upload any form of image, png, jpeg etc. on the Gallery Folder Screen I get the following message : 'example.jpg is not a valid image file'

    Does anybody know how to resolve this?

    Thanks alot!
    -FJ

    http://wordpress.org/extend/plugins/lazyest-gallery/

  2. lazyest
    Member
    Posted 2 years ago #

    Could be a bug in image validation. What server do you use?

  3. FranklynJones
    Member
    Posted 2 years ago #

    I'm using MAMP 1.9.6 on my mac:
    Apache/2.0.64 (Unix) PHP/5.3.5 DAV/2

    Thanks for your quick response!

    Regards,
    Dan

  4. lazyest
    Member
    Posted 2 years ago #

    somehow php getimagesize() does not work.
    What error message do you get when you remove the @ from @getimagesize in frontend.php line #805?

  5. FranklynJones
    Member
    Posted 2 years ago #

    I don't seem to have any issues with uploading images to the WP media gallery.

    Thanks,
    Dan

  6. lazyest
    Member
    Posted 2 years ago #

    The WP media gallery doesn't actually test files if they are real images.
    LG 1.1.9 has an extra security feature to check if you are not uploading malicious files e.g. renamed scripts.
    It uses the getimagesize() function. Apparantly this function fails on your server.

  7. FranklynJones
    Member
    Posted 2 years ago #

    in my /inc/frontend.php @getimagesize is on line #573 @getimagesize( $img_location )

    Anyway I removed it and there appears to be no error messages, I can navigate to my photos page, and I receive the same error message when trying to upload the jpg

    Thanks

  8. lazyest
    Member
    Posted 2 years ago #

    my error, should have been /inc/manager.php line #807

  9. lazyest
    Member
    Posted 2 years ago #

    Do you get same error in flash and browser uploader?

  10. FranklynJones
    Member
    Posted 2 years ago #

    Ok so some updates for you.

    I was originally using the Browser Uploader as I hadn't installed Flash and that was not working, I removed the @ from manager.php and the browser upload still gives me the invalid file error

    Using the Flash uploader the % uploaded does not run, i.e. doesn't change from 0%, but if I navigate off the upload dialog box the image has been uploaded and appears in the gallery folder.

    However when I go to my gallery page, the images are not displaying, there are no thumbnails and no original version of the image...however they do exist(physically) in the designated gallery folders.

    The href generated by the plugin for the large image is: http://localhost/egi/wp-content/uploads/egi-gallery/19501970/testuy.jpg

    This will not work as I'm running on port 8888

    Hope that makes some sense.

    Thanks very much for your time, I really appreciate it.

  11. lazyest
    Member
    Posted 2 years ago #

    what's the image size in pixels and what is your php memory settings?

  12. lazyest
    Member
    Posted 2 years ago #

    Could you please share an image that doesn't upload?

  13. FranklynJones
    Member
    Posted 2 years ago #

    The image was 800x652, i tried other sizes larger and small. The original image i tried was here: http://www.zoo.ox.ac.uk/egi/people/groupimage/1950.jpg - this didn't work, then I resized and resaved in photoshop. I also tried a screendump image (1920x1200), png file, this didn't work.

    My memory_limit is 32

    Thanks,
    Dan

  14. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 2 years ago #

    It looks like php cannot access the uploaded file to get the image size while the file is still in the temp directory.
    I can't find any solution to this error and I cannot reproduce it either.

    If it keeps failing, just delete line #807-811 from manager.php

  15. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 2 years ago #

    I've found a problem for some installs where the fulkl path of the uploaded file is not available after upload.
    I'll make some changes. Please wait for 1.1.9.1

  16. FranklynJones
    Member
    Posted 2 years ago #

    Thanks for all your help..when do you think 1.1.9.1 will be released?

    Dan

  17. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 2 years ago #

    It has been released, download from here:
    http://wordpress.org/extend/plugins/lazyest-gallery/

  18. FranklynJones
    Member
    Posted 2 years ago #

    Hi there, thanks for that. I've installed this release, and unfortunately the url for the src, is still omitting the port number.

    Thanks,
    Dan

  19. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 2 years ago #

    true, Lazyest Gallery does not check ports

  20. jpmizell
    Member
    Posted 1 year ago #

    Franklyn,
    Did you ever resolve this issue?
    I'm also finding that my MAMP install on port 8888 blocks LG 1.1.14 from accessing and resizing my images.

  21. jpmizell
    Member
    Posted 1 year ago #

    I set MAMP>Preferences>Ports to default Apache & MySQL Ports, shifting Apache from 8888 to 80 and MySQL from 8889 to 3306 and reset my WP site install from localhost:8888/wordpress to localhost/wordpress - this got rid of the port error when accessing the original image, but LG 1.1.14 is still not creating thumbnails or slides.

    LG 1.1.14
    MAMP 1.9.4
    with 32 MB PHP memory

  22. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 1 year ago #

    what is your images resolution?

  23. jpmizell
    Member
    Posted 1 year ago #

    180 - 300 p/in
    Sized ~3000p X 2000p

  24. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 1 year ago #

    32MB PHP memory could be too low to serve WordPress + Lazyest Gallery + Resizing 3000x2000px images.

    please read http://brimosoft.nl/lazyest/gallery/frequently-asked-questions/

  25. lazyest_developer
    Member
    Posted 1 year ago #

    please try lazyest-gallery 1.1.15-beta if you have problems serving http over other ports than 80

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic