WordPress.org

Ready to get started?Download WordPress

Forums

Lazy Social Buttons
[resolved] unwanted buttons showing on CPT excerpt widget (5 posts)

  1. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 1 year ago #

    with the v1.0.6 update, the buttons are now appearing on a widget which displays excerpts of a custom post type, which is not appropriate to the content of the CPT. I don't see an obvious way to prevent this from happening (apart from using a less than ideal display: none in the stylesheet)— any ideas?

    Perhaps it would be useful for option to be added to select which CPTs will display the buttons and/or whether excerpts (or excerpts within widgets) will display the buttons

    http://wordpress.org/extend/plugins/lazy-social-buttons/

  2. scuderiadank
    Member
    Posted 1 year ago #

    Just came on here to say the same thing.

    Can't believe someone thought it would be a good idea to foist this upon everyone without an option to deactivate it from appearing on excerpts.

    Back to the previous version I go...

  3. davekoopman
    Member
    Posted 1 year ago #

    Sorry all, I added v1.0.6 to satisfy a feature request that came in on the inside.godaddy.com article, which requested that lazy social buttons be added to the_excerpt. It also suggested it be an option. I wrongfully implemented it without making it an option. I didn't realize it would cause a problem.

    To remedy the situation fast, I published version 1.0.7 today, making the_excerpt an option, and defaulted to manual (or off). This way, for those of you that have plugins or themes or CPTs that use the_excerpt and/or you don't want lazy social buttons on the_excerpt, you can toggle it to manual. In fact, I made "Manual" (or "off") the default, so you don't have to do anything but upgrade to v1.0.7.

    This is a really good suggestion: "Perhaps it would be useful for option to be added to select which CPTs will display the buttons and/or whether excerpts (or excerpts within widgets) will display the buttons". I'll take this into consideration. I wanted to get v1.0.7 out fast to stop the bleeding first.

  4. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 1 year ago #

    Cheers Dave - its looking great now.

  5. scuderiadank
    Member
    Posted 1 year ago #

    Yup. Working fine now.

    Thanks for the quick fix.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.