WordPress.org

Ready to get started?Download WordPress

Forums

Last.Fm Records
[resolved] Shortcode no longer working (1.7) (5 posts)

  1. Matt Brett
    Member
    Posted 2 years ago #

    Just updated to version 1.7 and the shortcode stopped working. I had it embedded in my sidebar template like so...

    <?php echo do_shortcode('[lastfmrecords|lovedtracks|6]'); ?>

    Has been working for months, but just stopped. Seeing default covers that link to the current page. I've tried removing the criteria (lovedtracks,6) and letting it pull from the settings, but that didn't change anything. Also tried different settings (other than loved tracks), but nothing works.

    http://wordpress.org/extend/plugins/lastfm-records/

  2. jeroensmeets
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Matt, the shortcode syntax has changed to make better use of the options available, if you change the shortcode to

    [lastfmrecords period="lovedtracks" count="6"]

    it should work again.

  3. Matt Brett
    Member
    Posted 2 years ago #

    Thanks for the quick reply, but still no dice. Anything I can do to help debug?

  4. Matt Brett
    Member
    Posted 2 years ago #

    @jeroensmeets helped me out on Twitter.

    Turns out, you need to use the new user parameter as well as the others. So my shortcode now looks like this...

    [lastfmrecords user="MattBrett" period="lovedtracks" count="6"]

  5. jeroensmeets
    Member
    Plugin Author

    Posted 2 years ago #

    Good to see it's working now. I'll update the documentation in the next version.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.