WordPress.org

Ready to get started?Download WordPress

Forums

Last.Fm Records
[resolved] Last.fm Failing to Display Through widget (9 posts)

  1. evilgeniusmr
    Member
    Posted 2 years ago #

    Hi,

    For the last couple of days the widget hasn't been displaying properly on my website via the widget. I am running the current edition of both WP and the widget and have not touched either before or after the disappearance. At present the site is simply showing a gap where the results should be (www.evilgenius.org.uk).

    I realise there have been similar problems from the couple of posts below but without an active knowledge of short-codes (even after Googling!) I'm still a bit confused about what to do.

    Thanks for any help/updates you can give - it's a great app.

    http://wordpress.org/extend/plugins/lastfm-records/

  2. jeroensmeets
    Member
    Plugin Author

    Posted 2 years ago #

    Hi evil genius,

    seems your site has a javascript error in script.js at line 20, not related to my plugin:

    Uncaught TypeError: Object #<Object> has no method 'focusin'

    Let me know if you can fix this.

  3. evilgeniusmr
    Member
    Posted 2 years ago #

    Thanks Jeroen,

    I'm just using a standard template - so not sure what's going on there. Yet to learn JS but will have to do some digging I guess ...

  4. jeroensmeets
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    went through your page source: there's an awful lot of javascript in there, and it seems you have two last.fm plugins? Also, the lastfm-covers plugin includes jQuery (version 1.2.6), and your theme does as well (version 1.4.4).

  5. evilgeniusmr
    Member
    Posted 2 years ago #

    I'm also getting this on line 71:

    "Uncaught TypeError: Object #<Object> has no method 'lastFmRecords' ... http://evilgenius.org.uk/:71"

    The error on line 20 was about "focusin" - Sorry I'm a bit out of my depth here - Let me know if I need to call in a friend with JS experience to sort out the site rather than ask you about the widget!

    Thanks again.

  6. jeroensmeets
    Member
    Plugin Author

    Posted 2 years ago #

    Yeah, I saw the line 71 error as well. Seems to me you have to remove one of the jquery includes. Let me know.

  7. evilgeniusmr
    Member
    Posted 2 years ago #

    Thanks - may take a day or so ... Will enlist friend so far still on HTML/CSS manuals.

    Also just saw your post on the bloat-ware - when I first used the site was lazy and inexperienced and just didn't delete them properly when trying to find one I could make work. Have just deleted a lot of stuff I don't need. Still very much learning.

    Anyway - thanks again and I shall post when I've been able to drag someone round ...

  8. evilgeniusmr
    Member
    Posted 2 years ago #

    Sorry for the multiple posts - but tracking down some un-deleted widgets has resolved the problem (as I think you suspected). I guess one of them must have been upgraded and caused the conflict.

    Thanks for the speedy replies!

  9. jeroensmeets
    Member
    Plugin Author

    Posted 2 years ago #

    Good to hear, and thanks for reporting back!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.