WordPress.org

Ready to get started?Download WordPress

Forums

Knews Multilingual Newsletters
[resolved] [bug] {%name%[Dear user]} {%surname%[]} does not work (12 posts)

  1. IanFox
    Member
    Posted 1 year ago #

    Hi,

    I've tried to use the personalisation. It does not work however.

    I include {%name%[Dear user]} {%surname%[]} into my mail but it does not translate to the usernames in my subscribers list.

    It displays as: %name% %surname%.

    http://bandj.local.c-fresh.be/wp-admin/admin-ajax.php?action=knewsReadEmail&id=29&e=ian.de.vos@cfresh.be

    Could it be a bug in my own email template?

    It does not work with the Casablanca template as well..

    Thanks for the otherwise great plugin!

    Ian

    http://wordpress.org/extend/plugins/knews/

  2. creverter
    Member
    Plugin Author

    Posted 1 year ago #

    Hello!

    I just tested it and fails the website preview/can't read link!!!

    Can do you confirm the emails sent have the name / surname replaced OK?

    I'm sorry!
    Carles.

  3. creverter
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, I just released a new version 1.2.1 to solve this. The newsletters submitted by 1.2.0 doesn't show this fields, because the can't read link needs the email param.

  4. IanFox
    Member
    Posted 1 year ago #

    It also wasn't showing in the mails sent.

    I will test the new version tomorrow!

    Thnx!

  5. creverter
    Member
    Plugin Author

    Posted 1 year ago #

    You welcome! Give us feedback, please!

    Carles.

  6. IanFox
    Member
    Posted 1 year ago #

    Hi,

    It still doesn't work in the test e-mails we have send. (using JS cron)

    https://dl.dropbox.com/u/6059784/mail.jpg

    In the "can't read link" the names get replaced correctly.

    Greets,

    Ian

  7. creverter
    Member
    Plugin Author

    Posted 1 year ago #

    Please, can do you try this patch?

    http://www.knewsplugin.com/tokens_patch.zip

    You must upload the file trough FTP to the wp-content/plugins/knews/direct/ directory.

    Thanks,
    Carles.

  8. creverter
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, this is solved into 1.2.2 version

  9. IanFox
    Member
    Posted 1 year ago #

    Sorry for my late answer. This project had some delays on other issues as well.
    With the new versions the name fields didn't work as well. I've updated but didn't work. I'm hesitant to update in the meanwhile, my client wants to send an email soon and don't want to break stuff. (His emails are set up already) Had way too many delays already so our client wouldn't be happy at all if there was one more hickup.

    I will update after his first sending and try it again.

  10. Ayek
    Member
    Posted 1 year ago #

    still doesn't work :(

  11. Ayek
    Member
    Posted 1 year ago #

    i've tried on other server and it works now

  12. creverter
    Member
    Plugin Author

    Posted 1 year ago #

    @Ian: sorry, I read this now... can do you confirm is solved?

    @Ayek: Should work in all the webservers, there is a way to debug it or fail in a local installation?

    Please, don't install the patch, is so old... every version includes all the previous patchs...

    Regards,
    Carles.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.