WordPress.org

Ready to get started?Download WordPress

Forums

JW Player for Flash & HTML5 Video
[Plugin: JW Player Plugin for WordPress] There are no player in category with custom template (23 posts)

  1. narwen
    Member
    Posted 3 years ago #

    Hello! I have updates plugin to 1.4.0, and "Show players on category and search pages" is on. Player works correct everywhere except category with custom template, for example category-8.php (it shows just shortcode), but work correctly on index page (index.php) and category archive (archive.php).

    Could you help please?

    http://wordpress.org/extend/plugins/jw-player-plugin-for-wordpress/

  2. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Hi narwen,

    Could you give me some more detail about your implementation? Are you dynamically generating the shortcode in this case?

    Also, can you provide a link to an example of where this is happening?

    Thanks.

  3. narwen
    Member
    Posted 3 years ago #

    Now I returned to 1.3.3 and in category which design with file category-{id}.php it show preview image. See last post on the http://7kingdoms.ru/game-of-thrones/ (this is category, but I delete category base from permalink).

    In new version 1.4.1 its show just code:

    [jwplayer config="custom" file="http://www.youtube.com/watch?v=s7L2PVdrb_8" image="http://7kingdoms.ru/prev.jpg"]

    Player work perfectly if post shows on index page (index.php template) or in archive (archive.php template), and of course as single post\page.

  4. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    @narwen,

    When using 1.4 try making sure that the "Show players on category and search pages" option is checked in the JW Player Plugin admin section.

    Thanks.

  5. narwen
    Member
    Posted 3 years ago #

    I absolutely sure that I have checked it.
    I tried recheck it several times and have same result :(

  6. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    It still looks like you're running 1.3.3. The poster image should only be inserted in RSS feeds when using 1.4.

    Try updating to 1.4 again and making sure the option is checked.

    Thanks.

  7. narwen
    Member
    Posted 3 years ago #

    I am upgraded, here the result :( (first post). "Show players on category and search pages" is checked.

  8. youngmicroserf
    Member
    Posted 3 years ago #

    Hi,

    I have a similar problem... first, I think that box should be checked by default rather than the other way around...

    but also - here's the similar problem: I have two videos on a page, one in a blog post and one in a text-widget. Now, on most pages both render fine, but on category pages, even with the box checked, only the shortcode of the post in the content area, not the widget, will be rendered.

    It's really strange... everything's find on the main blog page, but if someone wants to see a category, the video disappears.

    I'd be grateful for any help!

  9. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    @narwen,

    I did some investigation over the weekend and I believe the issue may be related to what part of the post a theme uses to display content in category view. Right now in 1.4.1 the plugin is specifically looking for "the_excerpt" when executing the shortcode in category view. This is what the default theme uses to render category view.

    Apparently, other themes will use "the_content" which the plugin doesn't handle. Do you know how your theme displays post content in category view?

    @youngmicroserf,

    This is actually a bug which I already have a fix for. I will try and get the update out this week.

    Thanks.

  10. narwen
    Member
    Posted 3 years ago #

    In category I use the_content(), in archieve — the_excerpt (and yes in archieve all works correctly).

  11. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Narwen,

    Thanks for confirming that. I'll look into a fix to properly handle "the_content" this week.

    Thanks.

  12. captatio
    Member
    Posted 3 years ago #

    did you got the time to fix this issue ? we would appreciate an update ... is the dev' version available for download somewhere ?

  13. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Hi captatio,

    I've had a chance to look at it, although the fix itself is still underway. (Nothing on dev yet). I apologize for the delay, but I just want to be sure that the fix handles all the possible use cases.

    Thanks for your patience.

  14. captatio
    Member
    Posted 3 years ago #

    I saw you worked on the fix with http://plugins.trac.wordpress.org ... I downloaded the modified files but it still doesn't work with my zbench theme, the archive box is checked and I still see the shortcode in the archives :( I can't wait to use your plugin, it looks really great !

  15. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    @captatio,

    Do you know how the theme displays post content in category view?

    Also, what was the description next to the checkbox just so I can be sure of what version of the plugin you tried?

    Thanks.

  16. captatio
    Member
    Posted 3 years ago #

    @LongTail Video : thanks for the reply. here is what you need ...

    the description of the checkbox is "Show players on category and search pages"

    the theme I use has been modified to show the content like for index pages ... here is the code :

    [Code moderated as per the Forum Rules. Please use the pastebin]

  17. captatio
    Member
    Posted 3 years ago #

    @LongTail Video : I just upgraded the plugin to the 1.4.2 version ... I still have the problem with category/tags/archives page : the shortcode appears instead of the player.

    just in case, is my shortcode correct ? works fine on index pages ...

    [jwplayer config=player file=http://www.mydomain.com/videos/s17301_slideshow.flv image=http://www.mydomain.com/videos/s17301_slideshow.jpg]

  18. narwen
    Member
    Posted 3 years ago #

    Have updated to new version, but have same result (just shortcode for example on this page).

  19. captatio
    Member
    Posted 3 years ago #

    here is the code of the theme : http://pastebin.com/05uA3Nj6

    I tried to modify everything but it doesn't work ... in fact, the problem is not the theme code, I think the matter is the plugin always try to use excerpt on the archives/category page : but it doesn't work if the user doesn't propose excerpt on his blog. In my case, the archives are always the same than the others pages. I don't know how you can code it but that's my thought about this issue ... sorry for my "frenchy" english :)

  20. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Hey guys,

    The 1.4.2 update changed the behavior of the category checkbox on the JW Player config page. It should let you switch between embedding on the_content() or on the_excerpt(). Try toggling to see if that helps.

    Checked: Should use the_excerpt() to embed on archive pages.
    Unchecked: Should use the_content() to embed on archive pages.

    I'm appreciate you guys sticking with me on this. This has been a challenge to debug

    Thanks.

  21. narwen
    Member
    Posted 3 years ago #

    That is works for me! Thank you!

  22. captatio
    Member
    Posted 3 years ago #

    @LongTail Video : congratulations, the thing works perfectly with the box unchecked .. I really appreciate your efforts, thank you !!!

  23. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Glad to hear it's working for you guys!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic