WordPress.org

Ready to get started?Download WordPress

Forums

JW Player for Flash & HTML5 Video
[Plugin: JW Player Plugin for WordPress] FLV Media Links Showing in RSS Feed (8 posts)

  1. Chris M.
    Member
    Posted 3 years ago #

    Hello,

    I would like to prevent the direct links to .FLV media files from showing in the RSS feed when using the JW Player plugin for WordPress...

    These are not supposed to be accessed directly and now the links to the .FLV are exposed to the public... Please help.

    Thank you.

    http://wordpress.org/extend/plugins/jw-player-plugin-for-wordpress/

  2. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Chris,

    How exactly are they showing up? The shortcode does make a check to see if it's being displayed in a feed. If it is, it should only display the poster image.

    Thanks.

  3. Chris M.
    Member
    Posted 3 years ago #

    Hello (and thank you for responding!)...

    This is the shortcode that I am using (I have a custom skin named "Blue"):

    [jwplayer config="Blue" file="http://site.com/wp-content/folder/file.flv"]

    It shows the "file.flv" link in the RSS feed, with the file size listed under the link.

  4. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Chris,

    Actually, could you paste a sample of what's showing up in the feed as well?

    Thanks.

  5. Chris M.
    Member
    Posted 3 years ago #

    The feed is fine. A normal feed, just like all feeds. The problem is the link of the .FLV is revealed, like I said above.

    Not sure what else I can show you.....?

  6. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Chris,

    Oh, it wasn't clear that you meant the shortcode itself was showing up in the feed. In that case it means the shortcode isn't actually being executed. Can you check to make sure that "Show players on category and search pages" option is checked in the JW Player Plugin admin section?

    Thanks.

  7. Chris M.
    Member
    Posted 3 years ago #

    LOL... Sorry for the confusion here.

    No, the shortcode is not showing up in the RSS feed, only the link to the .FLV file itself.

    The shortcode is executing on the site and the player works just fine on the site. I am not referring to what is happening on the site at all. All is fine there.

    My only concern is that the .FLV file link is being shown in the RSS feed and I want it to remain hidden somehow.

    Someone here says it is not possible:

    http://www.longtailvideo.com/support/forums/addons/using-plugins/19526/flv-media-links-showing-in-rss-feed

    Your thoughts?

    I really need this link to be hidden in the RSS feed, otherwise I have to find another solution (any suggestions?)...

  8. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    The only reason I mentioned execution of the shortcode was due to the fact that it sounded like the shortcode was showing up in the RSS feed and by extension revealing the video URL. The shortcode should be inserting the poster image instead of the FLV URL in the RSS feed. There is actually an explicit check for RSS feeds. In fact, I don't see any video URLs when viewing the RSS feed for my local WordPress site.

    I'm not sure what would be causing it. Are you using a custom theme or any special RSS feed settings?

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic