WordPress.org

Ready to get started?Download WordPress

Forums

JW Player for Flash & HTML5 Video
[Plugin: JW Player for WordPress – Flash & HTML5 Video Player] Longtail player w/ wootube them (4 posts)

  1. guttamind
    Member
    Posted 2 years ago #

    Hello everyone. I am having the same problem that this guy had last year http://www.longtailvideo.com/support/forums/jw-player/setup-issues-and-embedding/22155/player-will-n...

    I really wish he would have posted his resolution, but unfortunately, Im in the exact same situation.

    Can anyone help me with using the JW player in this theme? Thanks in advance.

    http://wordpress.org/extend/plugins/jw-player-plugin-for-wordpress/

  2. guttamind
    Member
    Posted 2 years ago #

    Ok so this is the code that calls the embed code from the back end of the WordPress post section to place the video on the homepage:

    <?php woo_get_custom('embed'); ?>

    I replaced it with this code here

    <script type='text/javascript' src='swfobject-2.2.js'></script>

    <div id='mediaplayer'></div>

    <script type="text/javascript">

    var flashvars = {

    'file': '',

    'skin': '/jwplayer/modieus.zip',

    'logo.file': '',

    'logo.position': 'top-left',

    'logo.link': '',

    'logo.linktarget': '_blank',

    'logo.hide': 'false',

    'logo.margin': '5',

    'logo.over': '1',

    'logo.out': '1',

    'adttext.config': 'myconfig.xml'

    };

    var params = {

    'allowfullscreen': 'true',

    'allowscriptaccess': 'always'

    };

    var attributes = {

    'id': 'playerID',

    'name': 'playerID'

    };

    swfobject.embedSWF('/jwplayer/player.swf', 'mediaplayer', '640', '360', '9', 'false',

    flashvars, params, attributes);

    </script>

    Here's what I have tried.....

    'file': '<?php echo woo_get_embed; ?>',
    Then put the youtube url in the section where you would normally place the embed code into the back end of the WordPress post.

    What do I place into the 'file': '', and into the embed area in the back end to get the video to show up? Specifically like a youtube video. Right now all I get is the video player with the Task Queue Failed at step 5: Playlist could not be loaded. HTTP status 404; Not found. Feels like Im so close.....

  3. guttamind
    Member
    Posted 2 years ago #

    I'm glad to announce that I found a solution and here it is......

    Since the area where you would normally paste the embed code in the post back end is just a custom field, set up by the author, I just went up to the custom field area of the post and put in a key, gave it a name and made the value the YouTube url.

    Then I dropped this line of code in here to fetch the url

    'file': '<?php $key="video"; echo get_post_meta($post->ID, $key, true); ?>',

    Now whenever you create a new video post you can just give it that same key, put the link in the value and it will use the JW player to play the videos instead. Just make sure you replace the <?php woo_get_custom('embed'); ?> with the swfobject script into the layout-home.php and single post.php files.

    Kind of a duh.... solution, when you think about it. I'm not a coder at ALL! A designer. I know HTML/CSS at best. Luckily I'm a part time problem solver. I just lucked out with an epiphany of putting two and two together. WHEW!!!

  4. JW Player
    Member
    Plugin Author

    Posted 2 years ago #

    @guttamind,

    Glad to hear you got it working. Thanks for your determination and posting your solution.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic