WordPress.org

Ready to get started?Download WordPress

Forums

JW Player for Flash & HTML5 Video
[Plugin: JW Player for WordPress – Flash & HTML5 Video Player] JWPlayer shortcode not recogniz (11 posts)

  1. LeapFroggie
    Member
    Posted 2 years ago #

    Environment: Multisite with Domain Mapping.

    After a routine and successful in-place upgrade of JWPlayer to 1.5, the shortcode on Post pages is not processed but is instead displayed as inline output. Tested on two different servers (Ubuntu and CentOS) with same results.

    Note: there appears to be some connection to login status; if logged in as super-admin you can "view post" and the shortcode works. However, if not logged in and the site is visited via the site's URL, the shortcode is not processed and instead appears in the output text.

    Rolled back to 1.4.3, shortcode works OK in all circumstances.

    http://wordpress.org/extend/plugins/jw-player-plugin-for-wordpress/

  2. JW Player
    Member
    Plugin Author

    Posted 2 years ago #

    @LeapFroggie,

    Hmm, the upgrade shouldn't have caused an issue like this.

    However, it's worth pointing out that the new version (1.5.0) includes a new settings page where you can configure shortcode behavior on the different types of pages on a WordPress blog. Did you give those a try? If not would be willing to try it?

    Thanks.

  3. LeapFroggie
    Member
    Posted 2 years ago #

    Sure, I'd be happy to give that a shot... let me set up another WP instance so I can isolate 1.5.0 from anything important.... I'll get back to you in a few hours.

  4. LeapFroggie
    Member
    Posted 2 years ago #

    Well, this is interesting.

    On a new WP instance - starting with JWP Plugin 1.4.3 and doing a manual upgrade (NOT using the auto-updater) the JWPlayer Plugin Settings page comes up with "Enable" selected for Category, Search, Tag and Home pages. The player is not displayed and the shortcode appears as text output:

    Home Page (Post)
    Posted on October 19, 2011 by leapfroggie

    [jwplayer config="flv_player" file="http://content.longtailvideo.com/videos/bunny.flv" image="http://content.longtailvideo.com/videos/bunny.jpg"]

    If I select Disable and then re-select Enable for the Home page (post) then the shortcode works correctly and the player is displayed, even if I am not logged in.

    However, on the "production" instance I did an automatic update and in this case the Settings page has NONE of the options selected for the Category, Search, Tag and Home pages. Selecting Disable/Enable or any other option causes the page to refresh but the selected option does not stay set, the page refreshes and all the options are unselected. Turning on debug doesn't produce any error messages.

    Then I uninstalled the plugin in the production instance (using the Uninstall option on the Settings page), deactivated the plugin in Network Admin, reinstalled 1.5.0 manually via FTP, re-activated it, and checked the Plugin Settings page, resulting in:

    "The plugin generated 56968 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin."

    Refreshing the Home page results in the same inline output of the shortcode. However, the Plugin Settings page now shows Content set as the default selection for Category, Search, Tag and Home pages. Selecting Disable, then Enable for the Home page doesn't resolve the problem; the shortcode still displays inline. However, if I log in as super-admin and do a "View Post" the player displays correctly.

    I'll await further instructions.

  5. LeapFroggie
    Member
    Posted 2 years ago #

    Correction to the last paragraph above: "Refreshing the Home page results in the same inline output of the shortcode. However, the Plugin Settings page now shows Content set as the default selection for Category, Search, Tag and Home pages. Selecting Disable, then Enable for the Home page doesn't resolve the problem; the shortcode still displays inline. However, if I log in as super-admin and do a "View Post" the player displays correctly."

    I mis-spoke; I was testing on the wrong site when I wrote this. The behavior is true of the root site but attempting to view / change the plugin setting on the network site on which the page containing the shortcode resides results in the same problem as previously; the Category, Search, Tag and Home pages selection is all blank, and selecting Disable/Enable or any other option results in a page refresh but the selection does not stick.

  6. LeapFroggie
    Member
    Posted 2 years ago #

    More information:

    Deactivating the plugin on the Network Admin page and then re-enabling it on a per-site basis works.

    Each of the sites had the player previously installed and the version of the player has not changed.

  7. JW Player
    Member
    Plugin Author

    Posted 2 years ago #

    @LeapFroggie,

    First, I appreciate you taking the time to do this and reporting your findings.

    Just to make sure I'm clear:

    Fresh 1.4.3 -> 1.5.0:

    • Content is selected for Category, Search, Tag and Home pages.
    • It doesn't display correctly on the homepage unless you disable and then re-enable it.

    Automatic Update:

    • None of the options are selected.
    • None of them will stay set.

    Uninstalling -> FTP:

    • Header warning message.
    • Homepage shows shortcode.

    So it seems somehow related to a Network site setup. The options should be saved to the wordpress database, but don't appear to be. I'm guessing the lack of an option is causing the plugin to think the shortcode is disabled so it doesn't convert it. Although I would have expected it to strip out the shortcode then too.

    From your most recent post, did what you describe solve the issue for you?

    Thanks.

  8. LeapFroggie
    Member
    Posted 2 years ago #

    @LeapFroggie,

    First, I appreciate you taking the time to do this and reporting your findings.

    Just to make sure I'm clear:

    Fresh 1.4.3 -> 1.5.0:

    Content is selected for Category, Search, Tag and Home pages.
    It doesn't display correctly on the homepage unless you disable and then re-enable it.

    Answer: Yes, this is correct on the root site of a network install where the plugin (before and after the upgrade) is enabled Network wide.

    Automatic Update:

    None of the options are selected.
    None of them will stay set.


    Answer: Yes, correct for a non-root site of a network install where the plugin is enabled Network wide, not on a per-site basis.

    Uninstalling -> FTP:

    Header warning message.
    Homepage shows shortcode.

    Answer: Yes, for a non-root site of a network install where the plugin is enabled Network wide, not on a per-site basis.

    So it seems somehow related to a Network site setup. The options should be saved to the wordpress database, but don't appear to be. I'm guessing the lack of an option is causing the plugin to think the shortcode is disabled so it doesn't convert it. Although I would have expected it to strip out the shortcode then too.

    Comment: Agree that the issue is associated with a Network installation (and Network enabling of the plugin).

    From your most recent post, did what you describe solve the issue for you?


    Answer: Enabling on a site-by-site basis after an upgrade of the plugin is a work-around, but I don't think it solves the problem long-term. If we had dozens or hundreds of sites and all we wanted to do was upgrade the plugin code (which is common to all sites) it seems we should be able to do that without having to change the way the plugin is enabled.

    Thanks.


    Thank you!

  9. JW Player
    Member
    Plugin Author

    Posted 2 years ago #

    @LeapFroggie,

    I totally agree that you shouldn't need to enable on a site-by-site basis. Upgrading in one location is clearly ideal. In any case I'm glad you at least have it working now.

    I have ticketed this issue on our end. I plan to set up a network site locally next week so I can reproduce the issue. Hopefully the solution is not too involved and we can get a fix out (1.5.1) quickly.

    Again, your help is much appreciated. There so many possible configurations for WordPress it can make debugging and testing a bit of a challenge.

    Thanks.

  10. delamar
    Member
    Posted 2 years ago #

    I have the same issue here, but no network install.

    Some more facts:
    * Video doesn't show in blog posts
    * Video does show, when I insert a 2nd shortcode before the <!-- MORE --> tag
    * reverting to 1.4.3 doesn't repair the issue
    * videos in old posts are still shown

  11. JW Player
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, this is an issue with the upgrade process of the 1.5.0 release. You'll notice that we've rolled back the release while we work on a fix.

    In the meantime if you still have 1.5.0 installed, visit the new Settings page. In the Shortcode Settings section are a variety of options that control how the player is embedded. These will likely be blank (part of the upgrade bug). Set them to appropriate values (you may need to play with them). This should fix your issue.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic