WordPress.org

Ready to get started?Download WordPress

Forums

JW Player for Flash & HTML5 Video
[resolved] [Plugin: JW Player for WordPress – Flash & HTML5 Video Player] JW Player Plugin for WordPress (3 posts)

  1. joe.woidpress
    Member
    Posted 2 years ago #

    I've recently installed the 1.5.7 version of the JW Player Plugin for WordPress.

    I can't seem to use the "External Media" tab to add videos from a URL. I enter a URL and click "Add Media" and then the URL vanishes from the form field and the area under the "Add Media" button remains blank.

    I've checked my PHP logs and I'm getting this error:

    [12-Mar-2012 16:57:35] WordPress database error Field 'post_content' doesn't have a default value for query INSERT INTO wp_10_posts (post_author,post_date, post_date_gmt,post_content_filtered,post_excerpt,post_status,post_type,comment_status,ping_status,post_password,post_name,to_ping,pinged,post_modified,post_modified_gmt,post_parent,menu_order,post_mime_type,guid`) VALUES ('1','2012-03-12 16:57:35', '2012-03-12 16:57:35','','','inherit','attachment','open','open','','','','','2012-03-12 16:57:35','2012-03-12 16:57:35','1', '0','video/x-flv','http://streaming.osu.edu/mediawww2/ipad_rollout/ipad_rollout.mp4') made by do_action, call_user_func_array, jwplayer_url_render, wp_iframe, call_user_func_array, media_jwplayer_url_insert_form, wp_insert_attachment

    ...any idea what might be going on here?

    http://wordpress.org/extend/plugins/jw-player-plugin-for-wordpress/

  2. joe.woidpress
    Member
    Posted 2 years ago #

    ...ugh...

    It turns out that I needed to add "mp4" to my allowed file types.

    I guess this wasn't at all obvious to me since I was just entering a URL that ended in ".mp4".

    I'm not sure if there's a way to make it clearer that we need to add in the file type of the External Media URL we're trying to add...

    Is there any way you can perhaps add this to some sort of error message?

    Umm, barf.

  3. JW Player
    Member
    Plugin Author

    Posted 2 years ago #

    @joe.woidpress

    Glad you figured it out. Agreed that there should be an error message.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic