WordPress.org

Ready to get started?Download WordPress

Forums

Just Map It!
[resolved] can't get JMI to work (25 posts)

  1. titnuj
    Member
    Posted 1 year ago #

    Hi,
    I can't seem to be able to get JMI to work !
    Installed json api plugin then JMI plugin, activated it… nothing except "Sorry, an error occurred[…]
    can anybody help ?
    thanks in advance,

    Thierry

    http://wordpress.org/extend/plugins/jmi/

  2. socialcomputing
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Thierry,

    Can you please include the url of the website on which you installed the Just Map It! plugin ?

    We are going to make some investigations on your installation.
    Could you please re-enable the JSON-API and JMI plugins on your wordpress blog ?

    Thank you.

  3. traxtray
    Member
    Posted 1 year ago #

    The same here! I already filled in the form and sent it to you. My url is http://thomas-leisner.de

    Thanks! Thomas

  4. socialcomputing
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Thomas,

    Thanks for your feedback.
    We received your form submission and we are investigating on this issue.

  5. socialcomputing
    Member
    Plugin Author

    Posted 1 year ago #

    Thomas,

    The plugin didn't work as expected because it couldn't construct the JSON API root URL properly with your installation. You configured WordPress to have a home URL that is not the same as your main URL (http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory)

    You also added a redirection from http://thomas-leisner.de/ to
    http://thomas-leisner.de/en/ preventing access to JSON API from http://thomas-leisner.de/

    We made a fix to get the JSON API root URL from WordPress site url instead of WordPress home URL which seems more appropriate.

    You can download a JMI plugin version with the fix here : downloads.wordpress.org/plugin/jmi.2.0.2-jsonurl.zip

    Can you please test it and confirm that it works for you, so that we make it available for other plugin users ?

    Thanks

  6. traxtray
    Member
    Posted 1 year ago #

    Thank you for the quick reply.

    I tried the new version, but it still doesn't work for me. Can I leave the API base as is (http://thomas-leisner.de/api) in my case or should I change it?

    Regards, Thomas

  7. socialcomputing
    Member
    Plugin Author

    Posted 1 year ago #

    You can leave the API base default value.

    Can you please open the file named "jmi.php" of Just Map It! plugin through your blog administration section (plugins -> editor menu) and confirm that you have the following value on line 22:

    $this->jsonURL = site_url('/index.php?json=jmi.');

    Regards,
    Jonathan

  8. traxtray
    Member
    Posted 1 year ago #

    Yes, I have got the same on line 22:

    $this->jsonURL = site_url('/index.php?json=jmi.');

    (Copied this from my installation)

    Best, Thomas

  9. socialcomputing
    Member
    Plugin Author

    Posted 1 year ago #

    Ok,

    Then we need more information.
    Can you please paste here the values set for WordPress address and Site address options ? You can find them on the administration section, under Settings -> Global.

    Moreover can you explain how you configured url rewriting for your website ?

    Thanks,
    Jonathan

  10. traxtray
    Member
    Posted 1 year ago #

    Hi Jonathan,

    I have WordPress adress and Site adress at top level, that is: http://thomas-leisner.de. I have chosen the option "day and name" in permalink settings (is that what you mean by url rewriting?), that is: http://thomas-leisner.de/2012/08/24/sample-post/.

    I am using the plugin "Polylang" to split my site into german and english parts. I deactivated it, but that also didn't solve the problem. In case you want to look at it you can find the plugin page here.

    Thanks for checking this,

    Thomas

  11. socialcomputing
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    We made a fresh install of WordPress with the "Polylang" plugin enabled and it worked out of the box with the Just Map It! plugin. We created 2 languages and several pages and posts and the map was successfully generated and displayed at the bottom of blog posts.

    The only difference I see in your case is that calling JSON Api at your blog root URL does not work. you should be able to access it when JSON API and Just Map It! plugins are both enabled : try http://thomas-leisner.de/index.php?json=jmi.last_posts&id=869&max=30 for example.

    Can you please post the content of the .htaccess file ?
    Which version of WordPress and of the JSON API and Just Map It! plugins are you using ?

    Thanks.
    Jonathan

  12. traxtray
    Member
    Posted 1 year ago #

    Hello Jonathan,

    I have 1.07 for JSON API, 2.0.2 for Just Map It! and 3.4.1 for WordPress. This is the content of my .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    # BEGIN Audiobar
    
    <IfModule mod_headers.c>
    <FilesMatch "\.(mp3|ogg|oga|flac|wav)">
    	Header set Content-Disposition attachment
    </FilesMatch>
    </IfModule>
    
    # END Audiobar

    Does it matter that I have several domains on my server, so some kind of "URL rewriting" on the server side (don't understand much of this, just an idea)?

    Best regards, Thomas

  13. socialcomputing
    Member
    Plugin Author

    Posted 1 year ago #

    Hi

    It must be related to URL rewriting somehow.
    http://thomas-leisner.de/index.php?json=jmi.last_posts&id=869&max=30 is redirected to http://thomas-leisner.de/en/ with an HTTP 302 code (temporary redirect)

    Do you have access to the blog configuration server side ? (web server configuration files (apache ?))

    Could please also post all activated plugins on you blog with their version ?

    Regards,
    Jonathan

  14. traxtray
    Member
    Posted 1 year ago #

    Hi Jonathan,

    I don't think I can access the blog configuration server side. The webspace is hosted by a big german telecom company (1und1.de) and I make adjustments via their website. I couldn't find anything looking like access to configuration files there.

    I have activated the following plugins (latest version each):

  15. Artiss YouTube Embed
    Bad Behavior
    CodeMirror for CodeEditor
    Collapsing Categories
    Easy Admin Color Schemes
    Easy FancyBox
    Hide Admin Icons
    JSON API
    Just Map It!
    NextGEN Gallery
    Polylang
    Scroll To Top
    Souncloud is Gold
    Unattach
  16. I use a theme called "The Frances Wright".

    I guess the redirection is done by Polylang, as it organizes URLs into german (/de) and english (/en) (in my case) and automatically directs german users to the german part and others to the english part. I guess that an unknown address will be directed to the homepage instead, but I have no idea how that works. As you tested Polylang on a clean install that shouldn't be the problem.

    Best, Thomas

  • socialcomputing
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Thomas,

    Thanks for all that information, it sure helped.
    I was able to reproduce the issue on a clean install of WordPress 3.4.1 and the latest polylang plugin.
    Playing with the polylang settings lead me to the same situation, experiencing a redirection when calling the JSON API URL.

    A new fix is available for download here: http://downloads.wordpress.org/plugin/jmi.2.0.2-polylang.zip

    Can you please test it and give some feedback ?
    Thank you.

    Regards,
    Jonathan

  • traxtray
    Member
    Posted 1 year ago #

    Hi Jonathan,

    sorry to say that, but it still doesn't work. (Btw., I think I made this thread explode with my list somehow and don't know how to fix it, sorry for that.)

    Thomas

  • socialcomputing
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Thomas,

    You are now experiencing a different issue. The patched version you installed has successfully fixed the polylang problem.

    It isn't working now because of missing checks before a foreach call in the rest service provided by Just Map It!. It happens because the PHP configuration on the server hosting your blog displays all warning and errors to the user. A warning is added at the top of the rest service output which breaks the data formatting.

    I added the required checks before the foreach instruction which will prevent the warning. Please re-download and install the 2.0.2-polylang jmi version with the link provided in my previous post.

    However I strongly encourage you to change the way that PHP reports warnings for you blog. You can easily do this by adding a few lines in you wp-config.php file. See the WordPress documentation on this subject : http://codex.wordpress.org/Editing_wp-config.php#Configure_Error_Log

    PS : no need to apologize for the thread formatting it's a wordpress.org issue :)

    Jonathan

  • traxtray
    Member
    Posted 1 year ago #

    Hi,

    I tried the new version and also added the recommended lines to wp-config.php. , but it still doesn't work. :-(

    Thomas

  • socialcomputing
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Can you please reenable the plugin so I can check the error messages ?

    Jonathan

  • traxtray
    Member
    Posted 1 year ago #

    O.k.,

    it's enabled again.

    Thomas

  • socialcomputing
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Thank you for re-enabling the plugin on you blog.
    We discovered 2 new issues:

    1. Your web server denies requests on your blog that don't came from a valid browser (user-agent). We updated our application to capture the user-agent header provided by the client's browser and to send it when calling WordPress blogs to get the necessary data for the map.
    As you can see, a map is now successfully generated at the bottom of you blog posts :)

    2. The css required by just map it! is not loaded on you blog.
    We suspect there is a permission issue with the jmi client directory on your server's file system. The js file is loaded: http://thomas-leisner.de/wp-content/uploads/jmi/jmi-canvas-1.0/jmi-client.js, but not the css file: http://thomas-leisner.de/wp-content/uploads/jmi/jmi-canvas-1.0/css/jmi-client.css

    Can you please check that the directoy "wp-content/uploads/jmi/jmi-canvas-1.0" and all it's files and subdirectories are readable by your web server ?

    As a side note, as you don't have a lot of content on your blog now, try to switch back to "last posts" for "posts get method" option on the just map it configuration page. It will give more posts to display on your maps.

    Regards,
    Jonathan

  • traxtray
    Member
    Posted 1 year ago #

    Hey, that's so cool!

    It works like a charm now, and you were right: The permissions for the canvas folder itself were right, but not for it's content. It's amazing how you could analyze all those crazy problems from the distance. Thank you very much for this excellent support!

    May I dare to mention some little problems I noticed when trying it for the first time now?

    1. Hovering with the mouse over the "intitial map" entry on top causes the map to flicker. 2. Hovering over an item in the map (in compact mode) often highlights another item some distance away from the mouse, which feels a little awkward (in fullscreen mode it work perfectly). 3. Fullscreen mode could use an "exit fullscreen" button for those who don't think about the Escape-Key. 4. I personally would prefer to have the "Tags" and "Categories" of the post showing at the end of the post, and the map being displayed after that (if it's possible to implement it that way). 5. Although I like the colours a lot it would be cool of course if I could customize them!

    A lot of requests, :-) but what I really wanted to say: It's REALLY COOL, and I like it very much! Thanks a lot,

    Thomas

  • socialcomputing
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I'm happy to see that it works now :)

    Thanks for your feedback on the map. I'll try to answer to the little problems you mention:

    1. I didn't experiment the flickering when hovering the breadcrumb at the top of the map. Which browser (name & version) are you using ?

    2. I had the same issue in compact mode but only when I was connected as an administrator. It happens because of the administrator toolbar. That toolbar is positionned above the html content which causes the mouse position detection algorithm to return a wrong position.
    Can you please confirm that it works when you are disconnected from your blog ?

    3. Sure ! :). Added to the todo list.

    4. It's not an easy one. I will investigate the WordPress api to see if an option could be added to do this.

    5. I'm afraid it's not possible for now. A lot of customisation is done server side and is applied to all our WordPress clients.

    Can I mark this topic as resolved ?
    Please feel free to open other topics if you experience other issues with this plugin.

    Regards,
    Jonathan

  • traxtray
    Member
    Posted 1 year ago #

    Hi Jonathan,

    the flickering is gone and highlighting works as expected when I log out as an administrator. And, yes, this topic definitely is resolved now. :-)

    Thanks again, Thomas

  • jokerboy
    Member
    Posted 11 months ago #

    I'm confused. I have installed just map it, I want it to show up on the Where we are page, I don't see how to do that.

  • Topic Closed

    This topic has been closed to new replies.

    About this Plugin

    About this Topic

    Tags