WordPress.org

Ready to get started?Download WordPress

Forums

JSL3 Facebook Wall Feed
[resolved] Photos / gallery not displaying (7 posts)

  1. gorgoth
    Member
    Posted 2 years ago #

    Hello, just installed your JSL3 Facebook Wall Feed plugin. Works great, except one thing. When I add a photo and/or gallery, the feed does not display the actual image on the website.

    When I add a photo, the feed just displays the text about the photo.

    When I add a photo gallery, the feed just displays a link to the gallery.

    I think this might be something Facebook has changed on their end, cause I remember seeing a screenshot of the plugin (from you I think) where the feed displayed a photo gallery including the first(?) photo from the gallery.

    Hope you can resolve this! Thanks!

    http://wordpress.org/extend/plugins/jsl3-facebook-wall-feed/

  2. Takanudo
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, I noticed that, too. It looks like Facebook removed the picture property from the feed for some stupid reason. I'll have to see if there is an alternative way to show the picture.

  3. gorgoth
    Member
    Posted 2 years ago #

    OK great! Hmm, I also noted that there is supposed to be a link to the post(?), but that is not working. I noticed there is an empty div-tag where the link could/should be: <div class="fb_link_post"> </div>

    I haven't seen the link, I installed the plugin today, but according to the classname of the div it seems reasonable to believe there should be a link there?

  4. Takanudo
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, inside that div tag should be the picture. Usually, the picture also has an associated link so that clicking on the picture takes you to the post on Facebook.

    There are a few bug reports for this issue on Facebook (we aren't the only ones who noticed). Unfortunately, they are listed at medium to low priority. Hopefully, Facebook will correct the issue in the near future.

  5. gorgoth
    Member
    Posted 2 years ago #

    OK, thanks for your quick replies.

    But, I had that empty "fb_link_post" on a post that was feeded to the plugin, that did not have any images in it. Or maybe I'm not following you? Just curious what is supposed to be in there, even when no images are in the post.

    But one can reach the actual post by clicking on the "Comment" link, so it's OK anyway.

    We'll see if/when FB will straighten the image-problem out. I'll be following your plugin / support section.

    I like the plugin though, easy to customize and to integrate.

  6. Takanudo
    Member
    Plugin Author

    Posted 2 years ago #

    It looks like Facebook but pictures back into the feed. Can I mark this thread as resolved?

  7. gorgoth
    Member
    Posted 2 years ago #

    Hi,

    Yes, looks like it's working, great!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic