WordPress.org

Ready to get started?Download WordPress

Forums

jQuery Notify
conflict with other jQuery plugins? (9 posts)

  1. worldlightmedia
    Member
    Posted 1 year ago #

    I have a lot of other plugins and jquery elements on my site. When I install this plugin, there is an issue that conflicts with the other elements. Like carousel and other modal items. Any ideas to resolve?

    http://wordpress.org/extend/plugins/jquery-notify/

  2. Bryce Corkins
    Member
    Plugin Author

    Posted 1 year ago #

    Can you post a link to your site so I could check it out? You can contact me directly at bryce@minsharestudios.com

  3. worldlightmedia
    Member
    Posted 1 year ago #

  4. Bryce Corkins
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks. I think I've fixed it.. the next update should be out within the next few days... I'll include the patch there.

  5. worldlightmedia
    Member
    Posted 1 year ago #

    Wow, great! I am looking forward to it. Thanks!!

  6. worldlightmedia
    Member
    Posted 1 year ago #

    In the mean time, I was wondering what it was you saw, and if perhaps you could give me a helping hand in fixing it on my end. Would appreciate any help you can offer! Thanks!

  7. Bryce Corkins
    Member
    Plugin Author

    Posted 1 year ago #

    It looks like your carousel plugin doesn't enqueue itself properly using wp_register_scripts, so it's having a conflict in custom.js. The code in your custom.js file also isn't ideal.. instead of

    jQuery(document).ready(function() {
        jQuery("#newslist").jcarousel({

    It should be (I believe)

    jQuery(document).ready(function($) {
        $("#newslist").jcarousel({

    But without FTP access to your site, I can't be sure.

    Still working on the update... sorry about the delay. Adding a few new features with this update and I've gotten busy with other stuff.

  8. Bryce Corkins
    Member
    Plugin Author

    Posted 1 year ago #

    Update just went out... give it a try now. I've encased my script in a wrapper.. so it might be less likely to cause conflicts.

  9. worldlightmedia
    Member
    Posted 1 year ago #

    The update didn't resolve the conflicts on mine, (z-index?) but I just saw the previous post. I'll try those fixes next. In any event THANK YOU VERY MUCH!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags