WordPress.org

Ready to get started?Download WordPress

Forums

jQuery Lightbox
Version 0.16 crashed my site (25 posts)

  1. elmalak
    Member
    Posted 3 years ago #

    I've just done the automatic upgrade of the plugin to version 0.16 and it crashed my blog.
    It used to work fine before upgrading to this version.

    Hope you can fix that.

    thanks.

  2. Pedro Lamas
    Member
    Plugin Author

    Posted 3 years ago #

    Seen the problem too, I'll be checking a solution...

    Please check if it did update (think so) and manually activate!

  3. Pedro Lamas
    Member
    Plugin Author

    Posted 3 years ago #

    I'm seeing crashes when updating other plugins... can anybody please confirm if you are having crashes when updating this or other plugin?

  4. dahdi
    Member
    Posted 3 years ago #

    @Pedro Lamas,
    jquery-lightbox-balupton-edition disabled my blog.

    After updating my plugins, this php error message appears on my blog.

    Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/scrit2/public_html/blog/wp-content/plugins/jquery-lightbox-balupton-edition/jquery-lightbox.php on line 13

  5. Pedro Lamas
    Member
    Plugin Author

    Posted 3 years ago #

    @dahdi, some questions: what version of PHP is your blog using? Where you using the 0.15 version before this update?

  6. Pedro Lamas
    Member
    Plugin Author

    Posted 3 years ago #

    @all: it seems that WordPress 3.0.2 update stopped the problems with the plugin, so please update your wordpress version and check back if problems arise! ;)

  7. dahdi
    Member
    Posted 3 years ago #

    Using PHP version 5.2.14
    I believe i was using Lightbox version 0.15 before the update, honestly I do not recall the exact version.

    After upgrading to WP 3.0.2, Lightbox still produces an error

    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/scrit2/public_html/blog/wp-content/plugins/jquery-lightbox-balupton-edition/jquery-lightbox.php on line 13

  8. Pedro Lamas
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry for bothering you with this, but are you truly sure you are using PHP 5? Because that error should not appear in v5, only in v4... :(

    Please check this out and see it this helps:

    http://www.vbulletin.com/forum/showthread.php?331795-Parse-error-syntax-error-unexpected-T_STATIC-expecting-T_OLD_FUNCTION-or-T_FUNCTIO

  9. dahdi
    Member
    Posted 3 years ago #

    Pedro!
    YOU ARE NOT BOTHERING ME AT ALL. I had to write that in ALL CAPS to let you know I really appreciate your replies. I went back into my server and made sure the PHP configuration explicitly handled all PHP scripts with version 5 and that solved the problem.

    So, with that said, THANKS! Problem solved.

  10. Pedro Lamas
    Member
    Plugin Author

    Posted 3 years ago #

    Great news then!!! Hope everything works out ok now! :)

  11. cornfritter182
    Member
    Posted 3 years ago #

    Pedro,

    I'm also having the same problem. I updated to WordPress 3.0.3, and then updated the jquery-lightbox-balupton-edition plugin, and my blog has completely crashed. I'm getting the following error:

    Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/scrit2/public_html/blog/wp-content/plugins/jquery-lightbox-balupton-edition/jquery-lightbox.php on line 13

    My website is http://www.kalaswire.com. Can you help? I downloaded an old version of the plugin and replaced the files on my server, but the error is still happening. I can't login to wordpress either.

    Thanks for your help!

    -Heather

  12. Pedro Lamas
    Member
    Plugin Author

    Posted 3 years ago #

    @cornfritter182, yout problem is the same: just use PHP5 instead of PHP4 and that will do the trick! :)

  13. cornfritter182
    Member
    Posted 3 years ago #

    Pedro-

    Is there any other way to fix this error? I don't have access to the host's web panel and no way of finding out if it's using PHP4 or 5. This is a client's website.

    Thanks!

  14. Pedro Lamas
    Member
    Plugin Author

    Posted 3 years ago #

    @cornfritter182, you can check the PHP version just by creating a new file and adding the phpinfo() function.

    http://php.net/manual/en/function.phpinfo.php

    You can change the assigned PHP version by changing the php.ini file on your site.

    If nothing of this works, you'll have to use version 0.14 or previous!

  15. cornfritter182
    Member
    Posted 3 years ago #

    Pedro- How can I install version 0.14 or previous of the plugin if I can't access my site's backend?

  16. Pedro Lamas
    Member
    Plugin Author

    Posted 3 years ago #

    You can't access WordPress administration? Try deleting the "jquery-lightbox-balupton-edition" folder under the plugins wordpress folder!

  17. cornfritter182
    Member
    Posted 3 years ago #

    I tried that and I'm still getting the same error...

  18. Pedro Lamas
    Member
    Plugin Author

    Posted 3 years ago #

    WordPress disabled any plugin that it can't find the folder, so if you have deleted the plugin folder as I stated above, you shouln't have any problem accessing WordPress Admin...

    If the problem persists, then I have to say that this is due to another plugin! Can you post the error message that you're getting?

  19. shiggi7
    Member
    Posted 3 years ago #

    I am having the same problem - fatal error after running your upgrade. You should test for PHP version in your upgrade script. I'm only using the lightbox effect on a few pages, so I just got rid of the plug instead of figuring out how to fix it.

  20. martin82scott
    Member
    Posted 3 years ago #

    Updated to WP 3.1 and now my jquery lightbox has completely packed in. There isnt any sign of the slider on my homepage.

    Any help is massively appreciated as my bounce rate is getting worse!

    the site is http://www.m-t-i.co.uk

    kind regards and massive thanks

  21. Pedro Lamas
    Member
    Plugin Author

    Posted 3 years ago #

    @martin82scott, what slider??

  22. martin82scott
    Member
    Posted 3 years ago #

    Hi Pedro,

    Thank you for your response.

    It seems that a LOT of people are experiencing issues with the WP 3.1 update - especially with custom themes.
    It appears that wordpress have altered some scripts in places which are used to call functions of some plugins. I am no expert and so have had my designer sort it out for me now. Many people are suffering with the update and different jquery or media plugins.

    Mine is fixed now and can be seen at http://www.m-t-i.co.uk

    Thanks

  23. martin82scott
    Member
    Posted 3 years ago #

    The custom slider at the top of my homepage shows sliding images and is now working - this was the issue in question.

    thanks, martin

  24. Pedro Lamas
    Member
    Plugin Author

    Posted 3 years ago #

    Ok Martin, glad to know you've got your problem fixed! :)

    I'll keep my eye on this problem and see what I can do in the future... thank you for your report!

  25. martin82scott
    Member
    Posted 3 years ago #

    Thanks once again. Many are having issues looking at this forum in general. Sorry I cant be of more assistance right now but hopefully my designer will be along at some point to give an update. All I know is he managed to do it without having to downgrade anything or remove any plugins.

    Kind regards

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic