WordPress.org

Ready to get started?Download WordPress

Forums

jQuery Colorbox
[resolved] Version 4.3 is broken> Uncaught ReferenceError:Colorbox is not defined (28 posts)

  1. Jake Sully
    Member
    Posted 2 years ago #

    I am getting "Uncaught ReferenceError:Colorbox is not defined" after upgrading the plugin from 4.2 to 4.3.

    http://wordpress.org/extend/plugins/jquery-colorbox/

  2. Jake Sully
    Member
    Posted 2 years ago #

    Is there a way to downgrade back to 4.2?

  3. techotronic
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,
    I just updated a few WordPress installations, every time without a problem.

    The errormessage seems to be a JavaScript error. Could you post your blog's URL here?

    Cheers,
    Arne

  4. Ryde Style
    Member
    Posted 2 years ago #

    Hi Arne,

    I also got a problem after updating to 4.3, check:
    http://minicamping-uylkenshof.nl

    Thanks in advance

  5. mlwmlw
    Member
    Posted 2 years ago #

    Hi:
    I update the plugin's settings.
    It has started working again.

  6. captalan
    Member
    Posted 2 years ago #

    I am having an issue too on my site after the upgrade. The first photo hangs in any gallery. However when I click the first one of the directional arrows to go tonextpicture, it then works.
    http://hi-mar.com/photos/flea-market-photos/flea-market-2011/

  7. hobbystash
    Member
    Posted 2 years ago #

    4.3 broken on my site. Would like to go back to 4.2. It does not load image when thumb is clicked.

  8. techotronic
    Member
    Plugin Author

    Posted 2 years ago #

    @captalan:
    Your theme brings along it's own version of the Colorbox library.
    Loading the library twice always leads to problems. You'll have to decide whether to use my plugin or your theme. Or delete the part of your theme's files where the library is loaded.

    I guess it could have worked before because both files contained the same version of the library.

    Cheers,
    Arne

  9. techotronic
    Member
    Plugin Author

    Posted 2 years ago #

    @Ryde Style:
    the plugin is not activated to automatically work on all images, only on galleries. I see no problems otherwise.
    Cheers,
    Arne

  10. techotronic
    Member
    Plugin Author

    Posted 2 years ago #

    @hobbystash:
    can you post the URL to your site where version 4.3 is activated and you are having problems?
    Cheers,
    Arne

  11. Ryde Style
    Member
    Posted 2 years ago #

    @ Arne,

    Thanks for the reply. I set it to all images nog, however none of the pictures is loading. I get to see a black image with only the top and left border of the colorbox...

    BR
    Jeff

  12. captalan
    Member
    Posted 2 years ago #

    Where we I find where the theme is loading the Colorbox? What do I need to look for? Is there a way to reinstall the prior version of the Plug-in, Thanks

  13. techotronic
    Member
    Plugin Author

    Posted 2 years ago #

    @Rude Style:
    no idea what's happening there.
    All the styles are applied correctly to the colorbox.
    Looks like a problem with your theme... probably a CSS/float issue.
    Cheers,
    Arne

  14. techotronic
    Member
    Plugin Author

    Posted 2 years ago #

    @captalan:
    you can download a zip of the older version from the plugin site.
    You'll have to ask the developer of your theme how to remove the Colorbox library link.

  15. Mike Zielonka
    Member
    Posted 2 years ago #

    Hello!

    I am having issues with 4.3 as well. Anything with a white border and rounded corners are not working at all...example theme 4.

    When I downgrade to 4.2 (via ftp)..everything goes back to normal.

    I have screen shots too... mike.zielonka at tunatraffic.com

    Mike

  16. Ryde Style
    Member
    Posted 2 years ago #

    @ Arne, it happened after updating to 4.3. Is there a way I can go back to 4.2?

    BR
    Jeff

  17. techotronic
    Member
    Plugin Author

    Posted 2 years ago #

    all,
    the plugin itself is working fine, I tested it on several WordPress installations with different themes.

    If the Colorbox does not open or looks broken, it's probably a JavaScript or CSS conflict with your theme or another plugin you are using.

    Since both JavaScript and CSS files change in every version, it's for example necessary to delete the cache if you use plugins like W3TC or other plugins or WP Super Cache or a CSS/JavaScript minifier or something like that.

    Also make sure that you deleted your browser cache and test with different browsers.
    Preferrably also test on different WordPress installations, with a different theme or different plugin combinations. The TwentyEleven theme that comes with WordPress 3.3 is a pretty good example for a well implemented theme.

    Cheers,
    Arne

  18. techotronic
    Member
    Plugin Author

    Posted 2 years ago #

    also, make sure that you are not including an old version of the jQuery library.

    For some reason it's pretty popular to include jquery from the goople servers:
    <script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js?ver=1.4.2'></script>

    This is how the broken colorbox looks like in this case:
    screenshot

    WordPress brings along a pretty recent version of jQuery which is needed for the plugin to work.

  19. techotronic
    Member
    Plugin Author

    Posted 2 years ago #

    @Ryde Style:
    The Colorbox is broken because a very old version of the Colorbox library is included in your site. (see comment above).

    WordPress 3.3.1 includes jQuery 1.7.1, and my plugin tries to load it.

    Either your theme, or one of the other plugins override that with said old version.

    Cheers,
    Arne

  20. Ryde Style
    Member
    Posted 2 years ago #

    @Arne.
    Thanks for all the help. Somebody else created this website, and I only did some small things.
    I'm not familiar with jQeury. So could you please explain to me how to fix it.

    Thanks again

    BR
    Jeff

  21. Mike Zielonka
    Member
    Posted 2 years ago #

    Hi @Arne!

    The fix sure was the jquery version.

    Found another bug while digging though...we use a cdn for our css/js/images/etc....When the JS for colorbox is on the cdn... ie: media.widgets.com... the color box cant load because it cant locate the files.

    Is there something you can change?

    Mike

  22. captalan
    Member
    Posted 2 years ago #

    Arne, Please have a look, I removed the themes loading of it but still no improvement. Can you make sure that I removed everything that needed to be or if there problem lies elsewhere. Thanks, captalan

  23. captalan
    Member
    Posted 2 years ago #

    Arne,

    I am using the themeforest Avenue theme.

    I have not found in the theme where it loads the following statement
    <script type='text/javascript' src='http://hi-mar.com/wp-content/themes/Avenue/js/colorbox/jquery.colorbox-min.js?ver=3.3.1'></script>

    However renaming the directory for now has fixed the problem.

    Any thoughts on what I might look for. Have not found it in content searches yet. i.e. what would bring this in from your plugin

    <script type='text/javascript' src='http://hi-mar.com/wp-content/plugins/jquery-colorbox/js/jquery.colorbox-min.js?ver=1.3.19'></script>

  24. captalan
    Member
    Posted 2 years ago #

    Arne,

    I was able to remove line. After doing so I had to shift / refresh my gallery pages. I eventually just cleared my browser cache. All seems good now. Thanks for your help here.

    Captalan

  25. Ryde Style
    Member
    Posted 2 years ago #

    @ Arne,

    If a disable the jQuery Colorbox plugin, some pictures load again. However, some still have the problem, and I can't see them as a slideshow.

    Could you please tell me what to do.
    Thanks

    BR
    Jeff

  26. nathancbriggs
    Member
    Posted 2 years ago #

    @mlwmlw: thank you, saving the settings worked on my client's site. Thanks to you, fix time was < 2 minutes :)

  27. Ryde Style
    Member
    Posted 2 years ago #

    Anyone an idea how I can fix the jQuery Colorbox problem on this site.....cause I can still not see them as a slidewhow...

  28. PPNSteve
    Member
    Posted 2 years ago #

    also had to downgrade to 4.2 the update broke my (file gallery) gallery page, no images showing and a broken theme when clicking on the thumbnail.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic