WordPress.org

Ready to get started?Download WordPress

Forums

jQuery Colorbox
[resolved] Not linking on Page with Gallery (7 posts)

  1. Andrew Tegenkamp
    Member
    Posted 3 years ago #

    I selected "Automate jQuery Colorbox for all images" and it works great on posts with images, posts with galleries, and pages with images.

    However, on a page with a gallery it does not work? You can see my sample site at http://andrewteg.com/wp3/ if anyone is curious or has any ideas.

    Thanks for any ideas,
    Andrew

    http://wordpress.org/extend/plugins/jquery-colorbox/

  2. techotronic
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,
    you set the wordpress gallery to link to the attachment page.
    If you change that to "link to image", the colorbox will work for the images.
    Cheers,
    Arne

  3. Andrew Tegenkamp
    Member
    Posted 3 years ago #

    Thanks. I should have seen that! I appreciate the help :) It's a great plugin! :)

  4. mukeshwani
    Member
    Posted 3 years ago #

    I'm not sure I follow. I'm using the nextgen gallery and I am seeing the same issue. If I set it to automate on all images, it works. Setting it to only automate on gallery images it doesn't work.

  5. techotronic
    Member
    Plugin Author

    Posted 3 years ago #

    @mukeshwani:
    The "gallery only" setting only applies to WordPress' built-in galleries.
    Also, the problem that andrewteg describes here only applies to the build-in galleries.
    Cheers,
    Arne

  6. mukeshwani
    Member
    Posted 3 years ago #

    but the plugin should work with NextGen gallery out of the box right? what could be the issue with here?

    Thanks
    Mukesh

  7. techotronic
    Member
    Plugin Author

    Posted 3 years ago #

    I am sorry, now I can't follow.

    I thought that my plugin works if you set it to auto for all images?

    It works on my site:
    http://www.techotronic.de/plugins/jquery-colorbox/nextgen-gallery-demo/

    The only thing I did was upload a few pictures to a new gallery, set the effects to “none” and disabled the piclens.

    Cheers,
    Arne

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic