WordPress.org

Ready to get started?Download WordPress

Forums

jQuery Colorbox
[resolved] Colorbox just ain't working, plugin conflict? (6 posts)

  1. yospyn
    Member
    Posted 3 years ago #

    Hi,

    I think they're might be a jQuery conflict with your plugin and my website, for example the gallery at http://www.wornmagazine.com/2010/06/activation-portraits-polaroids/.

    I was previously using jQuery Lightbox For Native Galleries and it worked great. But then one day it stopped working and now the thumbnails just link to images. After some discussion nobody could figure it out, so I deactivated and deleted the plugin and installed yours. Still, I'm having the same problem.

    I honestly don't know if a plugin I installed caused it to malfunction, I rarely use the galleries so I'm not sure when colorbox stopped working.

    Any ideas? Thanks for your help!

    Josh

  2. techotronic
    Member
    Plugin Author

    Posted 3 years ago #

    Hey Josh,

    I can't say for certain, but I think that the sharethis plugin is to blame. It puts an onclick function on the body of your website, rendering all other onlick function non functional.
    Since my plugin and most probably every other *box plugin relies on putting an onclick function on all of your images, none of them will work as long as you have the sharethis plugin activated.

    You could try to disable the plugin and see whether my plugin will work then. Maybe you can find an alternative for the share buttons.

    Cheers,
    Arne

  3. yospyn
    Member
    Posted 3 years ago #

    Thanks Arne - I've deactivated both FB Share and TweetMeme but it didn't have any affect. Also commented out the "ShareThis" Javascript but that didn't matter either.

    I'm leaving them deactivated for now. I wonder if there's a conflict with JS or scripts in the header? Still lost, if you get a moment to peek at the source of http://www.wornmagazine.com/2010/06/activation-portraits-polaroids/ I'd really appreciate it.

    Josh

  4. techotronic
    Member
    Plugin Author

    Posted 3 years ago #

    Hey Josh,

    I think I found what is causing the problem, and it's got nothing to do with other plugins.
    In your site, at the bottom directly after your contact-link, there is an empty link with the CSS class "cboxElement":
    <a href="/contact">Contact</a><a href="#" class="cboxElement"></a>

    If you delete this link, the plugin should work just fine.

    Cheers,
    Arne

  5. yospyn
    Member
    Posted 3 years ago #

    Arne,

    You're awesome. Is this where I make a donation http://www.techotronic.de/donate/?

    I have no idea how that got in there, but I removed it from the footer and the colorbox works great. WHEW.

    Josh

  6. techotronic
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Josh,
    I am glad that you like and use the plugin. :-)
    Yeah, either you can use that button or you can donate from the plugin's settings page.
    Cheers,
    Arne

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic