WordPress.org

Ready to get started?Download WordPress

Forums

jQuery Colorbox
Colorbox for content (6 posts)

  1. alorentz
    Member
    Posted 3 years ago #

    Does this colorbox plugin support IFRAME or AJAX content? I don't need it for images, but would like to use it for popover signup forms. I would create the forms, but wondered if the plug is only designed for images?

    http://wordpress.org/extend/plugins/jquery-colorbox/

  2. techotronic
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,
    you can load anything in the colorbox.
    My plugin bundles the Colorbox jQuery library. For more information see http://colorpowered.com/colorbox/
    Cheers,
    Arne

  3. mskogly
    Member
    Posted 3 years ago #

    But how Arne? I can't figure out how to load inline or ajax content using your plugin. Is there an example somewhere?

  4. techotronic
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,
    I posted an example here, and I saw that you are using it on your site:
    http://wordpress.org/support/topic/plugin-jquery-colorbox-inline-content-not-showing

    As an easy example, this will work.
    But: I just found a bug where having one link loading inline HTML in a colorbox and one link loading an iframe in a colorbox on the same site would cause to the link loading inline HTML also loading the iframe. :-(

    I'll probably fix that link today, but I modified the JavaScript yesterday for jQuery 1.6 compatibility so the Script may be more buggy than before...

    Cheers,
    Arne

  5. mskogly
    Member
    Posted 3 years ago #

    Ah, I felt I had stumbled across a bug there, glad to be of help :)
    I also have a feeling that there might be some sort of issue when upgrading. If i just upgrade, the action on images (opening a larger version etc) dies. But if I upgrade to 4.0 via the auto upgrade, then deactivate and delete files pluss data via wp admin, then reinstalls 4.0 and use the reset settings you provide, colorbox for images kick in again. Kind of a strange thing, gave me a little grief tonight. Hard to fingerpoint exactly what happened, but at least I got inline html under 4.0 to work running wp 3.1.3, so I'm a happy nerd!

    And sorry to take this thread off topic :(

  6. techotronic
    Member
    Plugin Author

    Posted 3 years ago #

    that's weird, I didn't change any existing settings from 3.8 to 4.0...
    I'll have to try to reproduce that somehow.

    Cheers,
    Arne

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic