WordPress.org

Ready to get started?Download WordPress

Forums

Collapse-O-Matic
[resolved] Tooltips cut off by collapse-o-matic? (10 posts)

  1. amr1975
    Member
    Posted 1 year ago #

    Hello,

    I am using collapse-o-matic in conjunction with explanatory dictionary plugin and it seems that collapse-o-matic is causing my tooltips from explanatory dictionary to be cutoff. Here is the website where I have the problem (click the expand all button):

    http://www.broadinstitute.org/software/pilon/usersguide/

    Find the instances of the word 'variant' and hover over them to see what happens.

    I have contacted both the authors of explanatory dictionary and the theme I'm using, and both say their code isn't the problem. This is from the developer of Explanatory Dictionary:

    The problem is there because parent div has "overflow: hidden" style:
    <div id="target-id6304" class="collapseomatic_content " style="overflow: hidden; display: block; ">

    I have also found that the problem occurs in Chrome and Internet Explorer browsers, but not in Firefox. I also created a test page where explanatory dictionary was used but collapseomatic was not, and the tooltips do not get cut off:

    http://www.broadinstitute.org/software/pilon/test-page/

    Any help is greatly appreciated!

    http://wordpress.org/extend/plugins/jquery-collapse-o-matic/

  2. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    We'll set up an example on our demo server and get back to you with a solution. Just a quick note to let you know we are on it.

  3. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, we just setup the Explanatory Dictionary plugin on our test server and it is working as expected: http://spacedonkey.de/289/dictionary-test/ This leaves an issue with your template. We would be happy to help you get this fixed if you can not get it sussed out on your own under our crazy-cheap Premium Support package. Here is a hint to get you started:
    the div style is being manually set to overflow: hidden; this does not come from the plugin's css or jQuery. Can you paste an example of exactly how you are using the shortcode on the page?

  4. amr1975
    Member
    Posted 1 year ago #

    Thank you Baden, I really appreciate the help. Here is an example of the shortcode from the page:

    [expandsub1 title="2.1.1: Creating Variant Output From A Single Library" tag="h6" id="2.1.1"]
    
    To create variant output from a single library, only the reference genome sequence and either a fragment or jumping reads BAM file are required. To create variant output from fragment reads, execute the following command from the prompt (a $ sign is used in these tutorials, but your command prompt symbol may vary):
    
    $ pilon --genome genome.fasta --frags frags.bam
    
    To create variant output from a jumping library, execute the command like so:
    
    $ pilon --genome genome.fasta --jumps jumps.bam
    
    Either command will produce a variant output file called '[pilon vcf file]'. For an explanation of the contents, please see Section 3.2.1: Variant Output.
    
    [/expandsub1]

    I'm not sure what is setting overflow: hidden, but I don't think I did this.

  5. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    Which version of the plugin are you using? Make sure you are using the latest version, you might even try using the latest release available here: http://plugins.twinpictures.de/plugins/collapse-o-matic/

  6. amr1975
    Member
    Posted 1 year ago #

    I'm using 1.4.4 so it looks like I have the latest version installed.

  7. twinpictures
    Member
    Plugin Author

    Posted 1 year ago #

    1.4.7 is available here on WordPress: http://wordpress.org/extend/plugins/jquery-collapse-o-matic/
    1.4.8c is available at our Plugin Oven: http://plugins.twinpictures.de/plugins/collapse-o-matic/

    Update and let us know.

  8. amr1975
    Member
    Posted 1 year ago #

    I updated to 1.4.7 and still have the same problem.

    When I go to the link for 1.4.8c, I only see version 1.4.4

  9. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    It seems this is being caused by either another plugin or your theme. Try one by one toggling off each of your installed plugins. If you find the one that is causing the overflow to be set, let us know so we can test it on our server. If none of your plugins are causing the issue, then switch temporarily to the twenty-ten default theme and test.

    All we can say for sure, is that something specific to your site setup is causing this overflow: hidden to be assigned to the target of root level collapse elements.

  10. amr1975
    Member
    Posted 1 year ago #

    Thanks Baden.

    I did try deactivating plugins one by one, and when I deactivate collapse-o-matic, the problem goes away.

    So it sort of seems like the issue is with collapse-o-matic. I think the issue does not show in the test you did at http://spacedonkey.de/289/dictionary-test/
    because the margins are so wide in the central white section that contains the text. The tooltips do not gets close enough to the edge where the gray background begins to cut them off. But when I tried twenty-ten theme (which has smaller margins), my tooltips still get cutoff.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic