WordPress.org

Ready to get started?Download WordPress

Forums

Collapse-O-Matic
[resolved] After updating the plugin, my drop down menus no longer work. (16 posts)

  1. AllanWoody5871
    Member
    Posted 1 year ago #

    I updated the jquery collapse o matic plugin this past week and ever since my drop down menu at the top of my pages doesn't drop down anymore (link at the bottom). I've confirmed it's collapse o matic by deactivating the plugin and reactivating it. Has anyone else had this problem? Is there a way to fix it?

    This wasn't a problem until I updated the plugin, so if there is no way to fix it is there a way to get an older version of the plugin to reinstall?

    Any help would be hot,
    -Allan.

    http://www.russellecks.com

    http://wordpress.org/extend/plugins/jquery-collapse-o-matic/

  2. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Allan,

    The reason why this is no longer working, is that the jQuery library is being loaded twice on your page. The last time:

    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.3/jquery.min.js"></script>

    is loading up version 1.4.3, an ancient version of jQuery. As of 1.4.8 only jQuery 1.7 or newer is supported. Either fix this jQuery issue, or roll back to 1.4.7 to get things working again.

    Good luck!

  3. scott74
    Member
    Posted 1 year ago #

    Hello Baden I have the same problem can you take a look at my page. How to you fix the 1.4.3 problem is that a file you can just upload and replace ?

    http://campbellairsecurity.com/about/

    Thanks Scott

  4. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Scott,

    Took a look at your site, and at first, the correct version of jQuery is being loaded... but then an ancient version (1.3.2) is being loaded by most likely your theme:

    <!-- Javascript (jQuery) + Superfish Scripts -->
    <script type="text/javascript" src="http://campbellairsecurity.com/wp-content/themes/los_angeles/assets/js/jquery-1.3.2.min.js"></script>

    Check your header.php file and see if the above line can be removed.

  5. scott74
    Member
    Posted 1 year ago #

    Thanks Baden... I looked in that location and I had two files in there. One was 1.3.2 and the other was 1.7.1. I deleted the 1.3.2 and it works
    but it broke my slider on the home page when I removed the 1.3.2 any suggestions on that?

    How do you get your site to call the latest version if the theme developer does not update to often. Is there a way to call from WordPress instead of relying on the theme?

    Thanks Scott

  6. Michel - xiligroup dev
    Member
    Posted 1 year ago #

    Impossible to update from 1.4.7 to 1.4.8 - simple coded h3 and div with target- prefix are freezed with 1.4.8 - I must "rollback" to .7...
    Can you add an option check to disable your jquery if jquery provided in WP is used ?

    M.

  7. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    Scott: it seems that jQuery is stil being loaded twice:

    <!-- Javascript (jQuery) + Superfish Scripts -->
            <script type="text/javascript" src="http://campbellairsecurity.com/wp-content/themes/los_angeles/assets/js/jquery-1.7.1.min.js"></script>

    Try preventing your theme from manually loading in jQuery.

  8. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    Michel: Nice. Without providing a link to your page we can not help you. You might be interested in learning, that the way the plugin is loading jQuery is the recommend method from WordPress: using wp_enqueue_scripts

    This means that the plugin will first check if WordPress has already loaded jQuery, and if not, will load jQuery - the default jQuery that came with WordPress, which is now at 1.7.

    If, however, you are using a plugin, or a theme that forces jQuery to be loaded in your header, without first checking, or even telling WordPress that it's loaded... it will cause many problems.

    So, if you want to use 1.4.8, you might want to first check your page source to see if jQuery is being loaded more than once. Then, if only one version of jQuery is being loaded, check to see that it is at least version 1.7. Finally, check your javascript error console to ensure that other errors are not causing the plugin to break.

    Or, you can just stick with 1.4.7.

  9. scott74
    Member
    Posted 1 year ago #

    Thanks Baden, I ended up editign the header.php to reference 1.7.2 instead of 1.3.2

    How to you just have wordpress handle it and not rely on theme file.. I saw the wp enque script and tried to replace that with the call to the assests folder but that did not work

  10. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    Scott: I think you just need to insert:
    <?php wp_enqueue_script('jquery'); ?>
    BEFORE the <?php wp_head(); ?> line in header.php

  11. scott74
    Member
    Posted 1 year ago #

    thanks for some reason the stupid slider is relying on that old file and wont even work with the enque or pointing to the new version of jquery

    http://campbellairsecurity.com/

    When I remove the 1.3.2 the slider shows double
    http://campbellairsecurity.com/

  12. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    scott. it sounds like the best solution for you is simply roll back to 1.4.7 for now. you will want to look into that slider though... sounds not very future-friendly.

  13. AllanWoody5871
    Member
    Posted 1 year ago #

    Thanks everyone for the posts. I've been looking into trying to re-aquire version 1.4.7 but I've so far been unsuccessful. I've looked on the plugin page on wordpress and on the developer's site but there doesn't seem to be any option to download an old version. Does anyone know where I can get my hands on an older version?

  14. Baden
    Member
    Plugin Author

    Posted 1 year ago #

  15. AllanWoody5871
    Member
    Posted 1 year ago #

    Ah, of course! Thanks Baden, my bad for not checking every single tab. This'll help alot!

    -Allan

  16. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    Update 1.4.9 should fix what ails you as well.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic