WordPress.org

Ready to get started?Download WordPress

Forums

Jigoshop PagSeguro
[resolved] CARRINHO ESTÁ VAZIO (17 posts)

  1. Igor Barros
    Member
    Posted 1 year ago #

    Olá, gostaria de saber como concertar o erro de Carrinho está vazio, eu testo a loja em Localhost, faço a compra confirmo, quando chega em finalizar ele me redireciona para o pagseguro e sempre aparece: CARRINHO VAZIO

    http://wordpress.org/extend/plugins/jigoshop-pagseguro/

  2. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    Que estranho Igor.
    Talvez falte alguma coisa no seu ambiente local.
    Esta ativo o curl?

    O plugin não usa, mas eu não tenho certeza sobre o Jigoshop na hora de enviar os dados.

  3. Igor Barros
    Member
    Posted 1 year ago #

    sim está ativo, é pra deixar ele desativado? ou é pra ativar mais alguma coisa?

    Também achei estranho mas sempre apaece isso

  4. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    Tem que ficar ativo sim.

    Estranho que testei local e deu certo.

    Entretanto uso Ubuntu para testar e ai o ambiente fica igual ao final.

    Provavelmente falta algo no seu ambiente. Por é enviado pro PagSeguro como um formulário.

    Esta ativo o WP_DEBUG? As vezes daria para ver o erro por ele.

  5. Igor Barros
    Member
    Posted 1 year ago #

    Ativei o DEBUG daí ele me mostra erro da wp-includes\functions.php on line 2638 mas acredito que seja do Template ou do proprio WordPress, entao tentei fazer a compra e cliquei em finalizar na hora de redirecionar ele

    diz: {"result":"success","redirect":"http:\/\/localhost\/Local\/?page_id=300&key=order_5073a7e8b38a9&order=373"} e nao redireciona

  6. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    Esse erro de onde esta vindo pode ser causado por algum plugin também.

    A moeda esta configurada como Real certo?
    Eu testei como R$ 00,00.
    Separador de milhar como ".".
    E separador decimal ",".

    Fez a mesma configuração?

  7. Igor Barros
    Member
    Posted 1 year ago #

    Sim a moeda está em Real e coloquei do jeito que você falou, mas ainda sim continua com o erro, será que é por estar em Localhost?

  8. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    Provavelmente esta faltando alguma coisa no ambiente.
    Se esta usando Xampp ou Wamp sempre fica faltando algo que não vem instalado.

    Bom, você podia me enviar um backup do que você instalou, plugins e banco de dados.
    Posso instalar aqui e ver se funciona. Se funcionar com certeza é o ambiente.

    Se quiser entra no meu perfil e vá até meu site, pode me mandar e-mail com o link.

  9. Igor Barros
    Member
    Posted 1 year ago #

    Ok, estarei lhe enviando tudo, só assim resolve tudo de uma vez! Obrigado pela ajuda.

  10. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    De nada.

    Bom que vou saber o que esta causando o erro e se alguém tiver o mesmo problema já sei a solução :P

  11. Igor Barros
    Member
    Posted 1 year ago #

    Rapaz os arquivos são muito grandes para enviar por E-mail, mas acho que ja sei o problema, fui nos outros foruns e o pessoal disse que mudou o separador de milhar e separador decimal nos desenvolvedores magento com outro plugin sem ser o pagseguro da jigoshop, porém pode estar dando o mesmo erro com o jigoshop, mas eu pensei que estava configurado como 00,00 entao como colocar dessa forma? já que o meu está 0,00

  12. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    Tem como subir eles no Dropbox ou algo assim?

    Esta usando o WP E-Commerce instalado junto? Li alguns problemas com ele no fórum do Jigoshop.

    Se você configurou o separador decimal com virgula o plugin precisa funcionar.

    Pode ser seu ambiente, tema, ou outro plugin interferindo.

  13. Igor Barros
    Member
    Posted 1 year ago #

    O WP-Ecommerce está desativado, coloquei ele no servidor, vou te mandar um E-mail com o login e senha dele pra ver se você consegue modificar ele só pelo administrador WordPress.

  14. esmi
    Forum Moderator
    Posted 1 year ago #

    These are English language forums. Please use English.

  15. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    Igor.

    Get in touch with me and let the forum closed here.

  16. Igor Barros
    Member
    Posted 1 year ago #

    OK, já lhe enviei o E-mail

  17. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    The error has been corrected in version 1.0.2.
    Visit the plugin changelog for more information.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.