WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: JH Portfolio] Problems with activation (6 posts)

  1. Bagira
    Member
    Posted 4 years ago #

    I have these warnings after activation:
    Warning: Call-time pass-by-reference has been deprecated; If you would like to pass it by reference, modify the declaration of trim(). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\cwp-framework\cwp.functions.php on line 8

    Notice: Undefined index: cwp_submitted_cwp_manage_add-new in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\cwp-framework\cwp.classes.php on line 421

    Notice: Undefined index: cwp_submitted_cwp_taxonomy_page_tags in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\cwp-framework\cwp.classes.php on line 500

    Notice: Undefined index: cwp_submitted_cwp_taxonomy_page_categories in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\cwp-framework\cwp.classes.php on line 500

    Notice: Undefined property: CWP_Manage_Page::$type in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\cwp-framework\cwp.classes.php on line 71

    Notice: Undefined index: show_in_menu in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\cwp-framework\cwp.classes.php on line 72

    Notice: Undefined property: CWP_Edit_Page::$type in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\cwp-framework\cwp.classes.php on line 71

    Notice: Undefined index: show_in_menu in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\cwp-framework\cwp.classes.php on line 72

    Notice: Undefined property: CWP_Taxonomy_Page::$type in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\cwp-framework\cwp.classes.php on line 71

    Notice: Undefined index: show_in_menu in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\cwp-framework\cwp.classes.php on line 72

    Notice: Undefined property: CWP_Taxonomy_Page::$type in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\cwp-framework\cwp.classes.php on line 71

    Notice: Undefined index: show_in_menu in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\cwp-framework\cwp.classes.php on line 72

    Notice: Undefined property: CWP_Debug_Page::$type in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\cwp-framework\cwp.classes.php on line 71

    Notice: Undefined index: _wp_original_http_referer in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\media-uploader.extensions.php on line 120

    Notice: Undefined index: _wp_http_referer in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\media-uploader.extensions.php on line 125

    Notice: Undefined index: button in D:\localhost\wp\wp-content\plugins\jh-portfolio\helper\media-uploader.extensions.php on line 130

    What must I do with this?

    http://wordpress.org/extend/plugins/jh-portfolio/

  2. Joe Hoyle
    Human Made
    Posted 4 years ago #

    Hi Bagira,

    Could you tell me what version of PHP you are running?

    You are receiving all the notices because you have strict error reporting turned on in your php.ini . A lot of these notices have been fixed in version 0.9.6 (which release is imminent). As a quick fix you could turn off strict error reporting in your php.ini (strict reporting is not recommended for a production site anyhow)

    Thanks!

    Joe

  3. Bagira
    Member
    Posted 4 years ago #

    Hi, joehoyle!

    I use php 5.2.1.

    I make error_reporting = Off and display_errors = Off, but I receive all the notices again.

    I can't use your plugin in general: I can't add new portfolio, add new category or choose existing category (existing category list is empty).

    Thanks!

  4. Bagira
    Member
    Posted 4 years ago #

    I'm sorry, when I add new portfolio, it is saved in datbase, but I can't view its in blog. Add new category or choose existing category (existing category list is empty), Add main image, add Gallery image - doesn't work. I do somthing incorrect, but I don't know what. Help me please.

  5. Bagira
    Member
    Posted 4 years ago #

    Anybody, help me please. I make error_reporting = Off and display_errors = Off. Why do I continue to receive all the notices at the admin panel and at the blog. Why don't work buttons Add main image, add Gallery image?

  6. Joe Hoyle
    Human Made
    Posted 4 years ago #

    Hi Bagira,

    Are you setting the error_reporting option sin your php.ini? Also, I recommend trying the latest Beta here: http://github.com/joehoyle/JH-Portfolio/downloads

    If you continue to have problems, you will receive a response quicker if you file a bug at http://github.com/joehoyle/JH-Portfolio/issues as the WordPress Forums is not very good for bug tracking, I prefer to keep it all over on github

    Thanks!

    Joe

Topic Closed

This topic has been closed to new replies.

About this Topic