WordPress.org

Ready to get started?Download WordPress

Forums

JF3 Maintenance Redirect
Redirect to static page doesn't works (7 posts)

  1. MacItaly
    Member
    Posted 4 years ago #

    Method 1 and 2, message and HTML, works well but the third one, the redirect to static page, doesn't work at all, is shown the home page, instead of static page.
    This happen in wp3 installation, instead in wp 2.9.2 the page cannot be opened at all cause a redirect error.
    I tried with a .html page, a .gif only, a wp page and other links in both the same and other location
    Any idea?

    http://wordpress.org/extend/plugins/jf3-maintenance-mode/

  2. jfinch3
    Member
    Plugin Author

    Posted 4 years ago #

    I haven't been able to recreate this problem (yet).

    Be sure that you're not currently logged into WordPress as an administrator when trying to test, your IP address is not in the list of active Unrestricted IP addresses and that any access keys that you may have used on your computer are not currently activated.

    Please register on my site ( the plugin homepage ) and send me a message with more details about the settings you have entered into the settings panel and I will try to help you resolve the issue.

    Thanks.

  3. PARoss
    Member
    Posted 4 years ago #

    I'm having the same problem. I've disabled everything but 2010, on Localhost. The other options work fine. My redirected page is http://localhost/index.html

    I love the idea of this plugin -- just what the doctor ordered.

    I tried to log into you hooziewhats site, but the login link took me to the WordPress log in. I tried it, but it didn't work.

    When I used the second method, to add my own HTML, I added

    <script type="text/javascript">
    	window.location="http://localhost/index.html"
    </script>

    and it works fine.

  4. striker
    Member
    Posted 3 years ago #

    I had this same issue, probably the way something was configured on my server. I solved by adding 'exit;' after line 186.

    looks like this:
    if( $wpjf3_mr_options['method'] == 'redirect' ){
    // redirect
    header ( 'Location:'.$wpjf3_mr_options['static_page'] );
    exit;
    }else if...

  5. georghi
    Member
    Posted 3 years ago #

    hi there

    the plugin seems to be superb! but could you help me with this problem please.

    I have assigned a PAGE to be my HOME PAGE in WP-Admin -- i have activated your plugin and assigned my IP address to by-pass it in the settings. I have pointed the plugin to a Static Page using an absolute URL path.

    So what happens is if I log into the ADMIN and click on Pages - when I view the HOME page i see the static URL instead of the page I am building. When i view other pages like ABOUT etc i see the new page that I am building [which is fine]

    any ideas how to get the HOME page to show the new page I am building and not the static URL page?

    thanka

    Phil

  6. nowton
    Member
    Posted 3 years ago #

    Thanks Striker, that worked for me as well.

  7. r8r
    Member
    Posted 3 years ago #

    Agreed, same problem (WP 3.0.4); the temporary fix as striker mentioned worked for me as well. However, it seems about time, that this gets fixed, period.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic