WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Jetpack] Mobile theme forced on Desktop (Solved) (1 post)

  1. Altersoundwork
    Member
    Posted 1 year ago #

    Hi Everyone,

    I was doing some changes yesterday according to woorank.com to improve my site (www.zasbaidefeis.com) all I changed was adding 301 redirection within the .htaccess file so if someone didn´t use www. in front, it would automatically.

    Options +FollowSymLinks
    RewriteCond %{HTTP_HOST} !^www\.zasbaidefeis\.com$ [NC]
    RewriteRule ^(.*)$ http://www.zasbaidefeis.com/$1 [R=301,L]

    I didn´t notice any different, I pressume due to cookies? But I´ve had reports from my users saying that the mobile theme was showing on desktops. To double check I tried from another computer and in fact this was true, it was coming up with the mobile theme.

    After looking through forums and not finding an answer, I figured I´d try a few things, obviously first to disable the mobile theme in jetpack to no avail, disabled jetpack again to no avail. Restored the .htaccess again to no avail.

    I later redid the changes to .htacess (since it wasn´t that) and figured the problem out. Disabling the jetpack mobile theme option did work but I did have a cache plugin installed that is set to only redo each page cache when there´s new content, so I did a new test post to force a rebuild of the front page cache and that did it.

    So for those that disabling the jetpack mobile theme doesn´t work, make sure you don´t have a cache plugin installed and if you do, just post some new content to force it´s update.

    That said, I´m sad I couldn´t get the mobile theme to work properly, oh well.

Topic Closed

This topic has been closed to new replies.

About this Topic