WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] your Jetpack has a glitch xml_rpc-32700 (11 posts)

  1. Paul de Wouters
    Human Made
    Posted 2 years ago #

    Hi

    I get this error when I try to connect to WordPress.com

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: xml_rpc-32700
    Try connecting again. Error Details: The Jetpack server could not communicate with your site's XML-RPC URL. Please check to make sure http://example.com/xmlrpc.php is working properly. It should show 'XML‑RPC server accepts POST requests only.' on a line by itself when viewed in a browser and should not have any blank links or extra output anywhere.

    Please advise, thanks

    http://wordpress.org/extend/plugins/jetpack/

  2. Barry Carlyon
    Member
    Posted 2 years ago #

    Did http://example.com/xmlrpc.php echo 'XML‑RPC server accepts POST requests only.' as expected?

  3. Paul de Wouters
    Human Made
    Posted 2 years ago #

    Hi, yes it does.

  4. cogmios
    Member
    Posted 2 years ago #

    disable all plugins and get to standard theme then try again.

    (sounds boring but it helps)

  5. Raul Illana
    Member
    Posted 2 years ago #

    Hi.

    Check for define('WP_DEBUG', true); in wp-config.php. Change the value to false.

    Best! :)

  6. Paul de Wouters
    Human Made
    Posted 2 years ago #

    thanks Raul

    that's probably it

  7. Tim Moore
    Moderator
    Plugin Author

    Posted 1 year ago #

    Also check that the permissions on the Jetpack files are set to allow the web server to read/execute them.

  8. saxisme
    Member
    Posted 1 year ago #

    Hi everybody,

    For me this worked:
    change the theme to Twentyten, connect to Jetpack, activate your theme.

    FYI, I tried before - without success:
    - disabling all plugins
    - install/uninstall latest version
    - change admin pass
    - the xmplrpc file is working properly (rss feeds working, and correct message)

  9. Paul de Wouters
    Human Made
    Posted 1 year ago #

    for me resetting DEBUG to false fixed it

  10. usefulmix
    Member
    Posted 1 year ago #

    For those using self hosted wordpress on nginx and varnish backend, here's a solution to the xml rpc 32700 Jetpack glitch: http://usefulmix.com/wordpress-nginx-varnish-jetpack-xml_rpc-32700-glitch-fix/

  11. Seth Stevenson
    Member
    Posted 1 year ago #

    I already had debug set to false but setting it to true and then back to false worked for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.