WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Your Jetpack has a glitch, This usually means your site is not pu (27 posts)

  1. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    Your Jetpack has a glitch. Connecting this site with WordPress.com is not possible. This usually means your site is not publicly accessible (localhost).

    Tried deactivating quick cache plugin, as I saw problems with other cache plugins. No go.

    Any ideas? Thanks!

    (edit, just tried with all plugins inactive. Still a no go)

  2. janiceandcompany
    Member
    Posted 3 years ago #

    I got the same thing on two of my sites I tried it on.

  3. houldsworth1
    Member
    Posted 3 years ago #

    I get the same error. I fired up a Bitnami WordPress instance in Amazon's EC2. Installed the plugin without problem, but now I get this error.

    The site is definitely visible as I can access it. Does anyone know if specific ports need to be opened for this to work (I know that Amazon locks everything down unless you specifically open it up).

    Thanks!

  4. Hiranthi
    Member
    Posted 3 years ago #

    Same here. The Jetpack support page mentioned W3TC (which I have enabled) and that you'd have to disable Object cache'ing, but I don't have that enabled.

    Been trying for a couple of days now, but still no luck.

  5. houldsworth1
    Member
    Posted 3 years ago #

    There is another post on here with options. One of the replies was as follows:

    It looks like your web server is incapable of sending outgoing requests over HTTPS (as opposed to HTTP). Jetpack should be able to detect this inability and work around it. We'll work on making that check better in the next version of the Jetpack plugin.

    In the meantime, if you are comfortable editing PHP files, you can modify wp-content/plugins/jetpack/jetpack.php.

    On line 1290, change the current:

    if ( $jetpack->use_ssl[$method] ) {

    to the new:

    if ( false && $jetpack->use_ssl[$method] ) {

    I tried that on my Amazon EC2 instance and it worked!

  6. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    Nope, that didn't work for me.... too bad....

  7. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    Just updated the plugin, here's my new error message (still fails):

    Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host.

  8. houldsworth1
    Member
    Posted 3 years ago #

    Do you havea firewall enabled? Perhaps you could disable it temporarily to see if that is the issue and try again?

  9. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    Nope, that's not it. Thanks for the suggestion. Same error remains

  10. esmi
    Forum Moderator
    Posted 3 years ago #

    @Rev: There are system-wide issues on wordpress.com right now that are impacting some Jetpack-enabled sites. It might be worth waiting for a few hours before trying any serious solution-testing.

  11. Cregy
    Member
    Posted 3 years ago #

    This worked a treat. Thanks

  12. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    I gave it a bit. I noticed my wp.com stats had finally cleaned up. So I assume some of the kinks at wp.com are sorted.... anyway, still can't connect...

    Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host.
    
    Connection time-out
  13. bluejpro
    Member
    Posted 3 years ago #

    Hi
    I am having problems with this too - same error message

    The host service I am using is Godaddy and my connection is really slow.

    Which hosting services are you using?

  14. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    I am on godaddy as well. I don't think the timeout error has to do with speed of your site per se....

    My site loads quite quickly, and I get the timeout message instantaneously after clicking connect

    I was in contact with support a few months ago, and they said they were having some issues with godaddy, perhaps you should contact them directly from the jetpack website.....

    I kinda gave up on jetpack since I couldn't get it working.....

  15. Sanitybycoffee
    Member
    Posted 3 years ago #

    no luck getting it to work. Very frustrating. there is no php for me to change anywhere

  16. Sanitybycoffee
    Member
    Posted 3 years ago #

    I replaced the line in the php file as recommended above. Still no go.

  17. Sanitybycoffee
    Member
    Posted 3 years ago #

    I just uploaded Jet Pack 1.1.3 same thing.

  18. ProblemSolved
    Member
    Posted 3 years ago #

    Seems a good number of people are experiencing this issue again including myself on a number of my sites. Sites on another host are fine.

  19. xcannabis
    Member
    Posted 2 years ago #

    Same problem for my site. Personal VPS, CentOS5, Apache 2.2, MySQL 5x.
    Removed all caching plugins.

    Error:

    "Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host.

    Operation timed out after 15050 milliseconds with 0 bytes received"

  20. Rev. Voodoo
    Volunteer Moderator
    Posted 2 years ago #

    OK well, it took about 6 months (mostly due to me slacking)

    But between working with my host, and the wordpress.com folks, I am finally able to connect Jetpack on my sites.

    I'm actually not sure on which end it was fixed. I'd been working with both, sending emails for the past week. I tried this morning, same error. Then again later, same. Then I just tried, and everything works.

    If I get more info from either, I'll report back.

    @xcannibus, that error normally means you need to raise your max_execution_time in php.ini

  21. fluffoid
    Member
    Posted 2 years ago #

    Okay, the issue seems very clear in this situation. Actual hosted server environments will not allow a person to go and modify the php.ini. Many plugins simply fail because they do not take restricted working environments into consideration. For the moment I would like readers of this thread to also check out this link, http://www.plus2net.com/php_tutorial/max-ex.php. Once I get a little bit of time, I will hopefully be able write an internal modification of the script code that gets rid of the annoying timeout.

  22. Rev. Voodoo
    Volunteer Moderator
    Posted 2 years ago #

    Actual hosted server environments will not allow a person to go and modify the php.ini.

    Actually, many allow you to create your own. I'm sure some do not of course. But I'm on shared hosting and can make my own, and I've helped several people on various shared hosting setups, and was able to make a php.ini file which worked effectively. It is definitely something people would need to check out on a host by host basis

  23. jimmytortuga
    Member
    Posted 2 years ago #

    Hi, I was running Jetpack on my site. I disabled it for a little while to check for plugin conflicts and since I reactivated it I canĀ“t get it running again. It asks me to connect to WordPress.com again and when I clic on it to do so, it just directs me back to my own homepage.

    Help?

  24. pgoly
    Member
    Posted 2 years ago #

    Hi,I use jetpack 1.1.3 and have problem with contacting with wordpress.com. I install wp on my own host.
    contacting with hosting support and they say have turned off the cashing system.but this problem still alive!
    I searching in forums for this and find core control plugin for disable cURL. It works but I got an new error like this:
    WordPress.com is currently having problems and is unable to fuel up your Jetpack. Please try again later.
    Error Details: 0
    what happened for me?

  25. PJ Brunet
    Member
    Posted 2 years ago #

    "if ( false && $jetpack->use_ssl[$method] ) {"

    This worked for me as of Jetpack Version: 1.2.2

    Then NginX gave me an authorization error, but seems to be working ;-)

  26. Rev. Voodoo
    Volunteer Moderator
    Posted 2 years ago #

    Just for info, for anyone having jetpack issues

    http://en.support.wordpress.com/contact/?jetpack=needs-service

    Just ask them! It may take a week or so to hear back sometimes, but they've been very helpful in helping me track down any issues.

  27. techispot.com
    Member
    Posted 2 years ago #

    I have nothing changed, but unexpectedly It show error at stats page, then I disable the plugin now when I enable and trying to connect to wordpress.com but it give this error : Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host.

    Failed to connect to 76.74.254.123: Permission denied
    On my website

    TechiSpot.com
    Please any help or suggestion

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags