WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
You have failed to authenticate with the WordPress.com API (50 posts)

  1. xcaballe
    Member
    Posted 3 years ago #

    I'm getting this error when I try to view my stats after installing Jetpack.

    http://wordpress.org/extend/plugins/jetpack/

  2. WraithKenny
    Member
    Posted 3 years ago #

    I had the same, but after checking in my dotcom account's "My Blogs" page and refreshing (and/or waiting a little bit) it cleared up.

  3. bassitone
    Member
    Posted 3 years ago #

    I've done the trick that WraithKenny suggested, but it still has the error. It cleared up the first time, but now it just seems to be stuck...

  4. DouglasVB
    Member
    Posted 3 years ago #

    I'm getting it, too. Perhaps JetPack needs the option of turning off individual components.

  5. bl
    Member
    Posted 3 years ago #

    I'm having the same issue, too. At first I thought it was a Chrome issue (I'm running version 10.0.648.133), but I'm having the same issue with Firefox version 4.0.

    It was working yesterday for me with the same browsers.

  6. brorobw
    Member
    Posted 3 years ago #

    Same problem here as well.

  7. odtaa
    Member
    Posted 3 years ago #

    I had problem in Chrome. I went into, (forgive me), Internet Explorer it still didn't work. Refreshed and I could get into the Jetpack configuration page.

    Disconnected from WordPress.com and then re-connected.

    It now works in Internet Explorer, Firefox and Chrome.

    I'm reckoning Douglas VB is probably on the right track. I'll try turning off the options I can if I have the problem again.

  8. btard
    Member
    Posted 3 years ago #

    ditto with issue.

    happening with stats and clicking on an individual column in the stats graph.

  9. aarondodson
    Member
    Posted 3 years ago #

    Having the same issue here... odtaa, did you re-connect to the same WordPress.com account, or a different one?

  10. MrBill64
    Member
    Posted 3 years ago #

    I am seeing the same thing.

    It's easy enough to fix by disconnecting and reconnecting to WordPress.org (same account), but a) it's irritating, and b) it seems likely that no stats are being logged while it's in this messed-up state.

    I haven't tried de-activating options but I'm willing to if it will help.

  11. jessicabeck
    Member
    Posted 3 years ago #

    Same problem here. I disconnected and reconnected, and the system gave me the green light - but when I clicked on Stats I got the same API error.

  12. brorobw
    Member
    Posted 3 years ago #

    Works a while then quits a while. I don't know if this is related, but I'm getting 501 errors on my sites. Go into my processes and wp-cron has multiple instances. I kill them and my site is back up. Anybody got any feedback from WP coders?

  13. Just run into this one, too.

    Logging in at wordpress.com showed that the stats were being logged, and I could see the current ones there.

    I tried the disconnect/connect thing, but that had no effect.

    I then disabled and re-enabled Jetpack, reconnected to my wordpress.com account, and the error message went away.

  14. bl
    Member
    Posted 3 years ago #

    This is an intermittent issue for me. If I ignore my site for a while and come back, it usually works for a couple of reloads. Then it doesn't.

    In that time I could have done the disconnect/connect thing and it might have worked. (In fact, I did do that, but it didn't work.) I could have disable/re-enabled Jetpack and it might have worked.

    Instead, I do nothing but wait and it sometimes works.

    Is anyone who experienced this now having it work consistently again?

  15. doctorfugazi
    Member
    Posted 3 years ago #

    Ive tried multiple so called solutions. nothing works. even the instructions they gave in regards to switching the api were a complete fail

  16. angrywhiteboy
    Member
    Posted 3 years ago #

    I deactivated Jetpack. The I reactivated it but did not enable WP Stats from Jetpack. Instead I activated WP-Stats as the stand alone plugin. Works fine, even if the interface is not as nice.

    The ShareDaddy seems to be working fine without Jetpack stats.

  17. Samuel Wood (Otto)
    Tech Ninja
    Posted 3 years ago #

    I've been seeing this issue intermittently too. I think the problem lies on the wordpress.com side of things. It's a new plugin that uses some new features. Might take them a while to work out all the kinks.

  18. angrywhiteboy
    Member
    Posted 3 years ago #

    BLEH, I reauthorized Jetpack, now getting the same freakin error message. API not vaild. Crap.

  19. angrywhiteboy
    Member
    Posted 3 years ago #

    Okay, back to plain old WP-Stats.. Screw Jetpack.

  20. angrywhiteboy
    Member
    Posted 3 years ago #

    Now neither works. Anyone know a better plugin, I'm all ears.

  21. edsbali
    Member
    Posted 3 years ago #

    Same issue. Before adding jetpack, WP-Stats was working just fine (chrome 10.0.648.133, firefox 3.6.15, IE 8.0.7601.17514). After adding jetpack, it work for couple of hours. Now it didn't. I have tried to use some called "solution" : disconnect then reconnect jetpack to wordpress.com, uninstall then re-install jetpack, create another wordpress.com account to have new API key then change the API key. None of them work for me. Still "You have failed to authenticate with the WordPress.com API."

  22. BioTecK
    Member
    Posted 3 years ago #

    Ok... So "luckily" there are some other people with the same issue! ;)

    I have the same problem as everyone and have already tried a couple of tricks above. Some worked for a couple of minutes and some didn't however the problem still remains! :(

  23. BioTecK
    Member
    Posted 3 years ago #

    Good news as I got it working!!

    It SEEMS that you need to create a blog at wordpress.com first. Even if you have your own self host WordPress blog.

    Now once you've created the blog, go to your Global Dashboard on WordPress.com -> Site Stats.
    You'll see the stats and you'll see My Blog (Dashboard) [DROPDOWN] + Switch button.
    Now all you need to do is choose your selfhosted WordPress blog from that dropdown menu and click on the Switch button.
    [EDIT: Make sure that Jetpack is connected to WordPress.com]

    As soon as you've done this, you can view the stats again through your OWN dashboard!

    This did the trick for me, so perhaps it might help you as well!

  24. chillmen
    Member
    Posted 3 years ago #

    Did not Work!!
    And now i can't see simple stats i receive the message : *

    Your WordPress.com account, is not authorized to view the stats of this blog.

  25. BioTecK
    Member
    Posted 3 years ago #

    Do you try to view the Site Stats through the link which is place under Jetpack?
    This is strange chilmen as it still works for me.... Even after cleaning my cache etc...

  26. chillmen
    Member
    Posted 3 years ago #

    It work for a while after that i have this message : You have failed to authenticate with the WordPress.com API.
    Aggghhhh!
    The "WordPress.com Stats" plugin gives me this answer "Your WordPress.com account, is not authorized to view the stats of this blog. "
    It's simple i have no more stats in my blog!!!
    What should i do now?

  27. chillmen
    Member
    Posted 3 years ago #

    I will contact wordpress.com i think it's an API problem, let you know!!

  28. BioTecK
    Member
    Posted 3 years ago #

    Do you have one API or more? And did you make a blog at WordPress.com? Not quite sure if that got anything to do with it, but worked for me! :)
    That's a good idea... Good luck with it and sorry if my trick didn't worked for you.

  29. chillmen
    Member
    Posted 3 years ago #

    Well it's back again.
    I don't know what the support team have done, but they did it.
    Thank you WordPress support team if you read this.
    Thanks BioTeck for your help.

  30. odtaa
    Member
    Posted 3 years ago #

    aarondodson Weirdly seems if I re-do the configuration on another blog, but using the same user name it seems to cure the problem.

    Clicking one of the columns of the past week to see more detailed info seems to trigger the problem - sometimes.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags