WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Twitter Sharing uses Wrong Twitter Handle (14 posts)

  1. seandfeeney
    Member
    Posted 1 year ago #

    I just upgraded to 1.6 Jetpack. The new twitter sharing button is adding WWW and COM to the twitter handle. How can I fix this? There is no setting that I can see to alter any of this information.

    http://wordpress.org/extend/plugins/jetpack/

  2. seandfeeney
    Member
    Posted 1 year ago #

    I should also add, clicking on more, scrolls the page to the top.

  3. kernelg
    Member
    Posted 1 year ago #

    I just noticed the same thing, if I'm understanding you correctly. For some reason, it's picking up Home URL, stripping non-alphanumerics from it, and using that as the default 'via' username. This would rarely give a correct result.

    If you're comfortable editing the plugin files, you can fix this in jetpack/modules/sharedaddy/sharing-sources.php. On line 327, I commented out where it's setting this default 'via' and added my site's Twitter handle instead.

    Another fix, while you're in there: On line 373, it's truncating the post title based on the full length of your link. Twitter now shortens links on its own, and no link will ever use more than 19 characters, so this chops far more than necessary. I removed the $post_link variable from inside the strlen and added a straight value of 19 to the calculation.

  4. Matt Mullenweg
    Troublemaker
    Plugin Contributor

    Posted 1 year ago #

    This is a bug -- we're about to release an update to fix it.

  5. kernelg
    Member
    Posted 1 year ago #

    Even better. Thank you, Matt!

  6. Matt Mullenweg
    Troublemaker
    Plugin Contributor

    Posted 1 year ago #

    1.6.1 is out, let me know if it solves your issue.

  7. kernelg
    Member
    Posted 1 year ago #

    1.6.1 has removed the via. That works.

    But it is still chopping the headline short as I noted above. Example, using the Twitter button on this page:

    FXpansion Intros DCAM Dynamics with Freā€¦ http://www.macosxaudio.com/front/2012/07/fxpansion-intros-dcam-dynamics-with-freecomp-on-the-house/

    There are still 79 characters available in that Tweet, yet the code has chopped the headline off, (I believe) because it is taking the full length of the URL into account. Since Twitter automatically shortens all long links, that URL isn't actually more than 19 characters (the t.co version that it becomes).

    I can manually fix it for my sites, and it's not a showstopper. Just incorrect. :)

  8. Barry Carlyon
    Member
    Posted 1 year ago #

    Why would JetPack use the Domain name/homeURL. This is just silly....

    Via is supposed to be a Twitter Username....
    (So is related for that matter)

    After tweeting users where a tweet has data-via/related attached are given the option to follow that users mentioned.
    So using the DomainName seems silly, but luckily my domain name is the same as my twitter username

    Perhaps add a option to the Twitter Button to choose the Username.
    My JetPack extras did that (tho I've taken the twitter button out in the current release as I've not had time to fix/update that, just fix the class conflicts and Pinterest removal since it's in JetPack Code)

  9. seandfeeney
    Member
    Posted 1 year ago #

    1.6.1 "fixes" the via problem but, I hate to be the cynical "that guy" but, using the URL as a means of generating a twitter handle automatically is a terrible solution. The sharing page has plenty of space to allow users to enter their twitter handle they would like to use. I actually like the via option and I am left with this band-aid solution.

    Also, there are many issues with the whole sharing portion of this release. Hovering over "more" doesn't do anything and clicking on it just jumps to the top of the page.

    Speaking as someone with a project management background, you may just want to back out of the recent changes to sharing and go back and make it work right before releasing another fix. Releasing many incremental fixes back to back just doesn't look good for jetpack and I am already researching potential other solutions.

    Sorry for the rant.

  10. Barry Carlyon
    Member
    Posted 1 year ago #

    The More not working sounds like a Javascript Error, check your themes using the Latest jQuery. I had that problem in the 1.5 update.

    You can always pull a older version from the Developers tab

  11. seandfeeney
    Member
    Posted 1 year ago #

    It looks more like a CSS display problem. The code is there via the inspector but, when you hover it doesn't trigger div.sharedaddy .sharing-hidden .inner:hover

    In order to get this to display, I had to force a larger height of 105px to div.sharedaddy .sd-content and click on the :hover check box in chromes inspector.

    This does work in the live preview area however.

  12. seandfeeney
    Member
    Posted 1 year ago #

    I figured out that the more display issue was actually caused by w3 total cache's minify option. Setting it from auto to manual caused many issues I was experiencing to go away (see dynamic to the top display issue here).

    I will have to remain more conscious of this issue. Thanks for your help and support!

  13. shenbagambtech
    Member
    Posted 1 year ago #

    Hi All,

    Im using the latest Jetpack plugin.

    Whenever I share any page it posts wrong-page or some other page to Twitter / LinkedIn and Facebook as well. Sometimes it throws not found error.

    Pls Can anyone help me out?

  14. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @shenbagambtech Could you please start a new thread about your issue?
    http://wordpress.org/support/plugin/jetpack#postform

    Could you also post your site URL in that thread, so I can have a closer look at the problem?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic