WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Social Icons not showing up for Comments (13 posts)

  1. bdollproject
    Member
    Posted 2 years ago #

    I have never been able to get the comments in jetpack to work right, no matter which site, the social media icons do not load. If I look at the CSS, it references the path:

    background: url("../post-flair/sharing/images/icon-wordpress.png") no-repeat scroll center center transparent;

    As far as I can tell, I couldn't find a post-flair folder anywhere in plugins or themes and I am not sure why this is included in the path. The icons do not exist anywhere that I can find. I am at the latest version of WordPress and Jetpack.

    Is this a bug???

    http://wordpress.org/extend/plugins/jetpack/

  2. soyburger
    Member
    Posted 2 years ago #

    I'm having the same issue. I'd much rather use jetpack as my comment system, but I want to allow facebook and twitter people to comment without having to register with wordpress.

  3. José Luís
    Member
    Posted 2 years ago #

    Same here! Both on self-hosted sites and free hosted ones...

  4. DanOfTheDay
    Member
    Posted 2 years ago #

    Same for me, on multiple browsers. The icons do not show up - their background is as you posted, "../post-flair/" etc., which is not a valid path. Looks like someone messed up the url.

    I am turning off Jetpack comments until this is fixed or resolved.

  5. Ikenna1
    Member
    Posted 2 years ago #

    I'm also having the same problem. I think it might be my theme or my under construction plugin. I also tried another social login plugin and it did not work.

  6. Sabcat
    Member
    Posted 2 years ago #

    I'm having the same problem. Checking the style sheet the icons are loaded from http://s0.wp.com/wp-content/mu-plugins/post-flair/sharing/images/icon-facebook.png

    The url is wrong. Any news on a fix for this?

  7. José Luís
    Member
    Posted 2 years ago #

    I think these are good news: the problem is not in our installations nor in the plugin logic (that could be hard to solve), it's a mere wrong URL. That should be very easy to solve once they notice it...

  8. Lutfi Torla
    Member
    Posted 2 years ago #

    Just chiming in here to say that I have the same problem. I just stopped using Simple Facebook Connect because I figured Jetpack would give me a better experience in allowing random people to comment without having to register anything.

    But it seems that the icons for wordpress, facebook, twitter, etc are all missing. Moving my mouse over the supposed area gives me the link. I can even click it. I just can't see it.

    Happy to hear that I'm not alone with this problem. I just did a major site overhaul and was worried that I had broken something in the process.

    I hope the wordpress team can fix this soon? I figure their site is down or something and it should be an easy fix.

    P.S. If anyone has a copy of those particular icons somewhere, I'm sure I could figure out a way to edit the plugin to point to a new address.

  9. Lutfi Torla
    Member
    Posted 2 years ago #

    It looks like even WordPress.com has this problem. I checked out someone's blog there and tried to leave a reply. Their icons for logging in and commenting are gone too.

    WordPress.com link:
    http://dianonethewiser.wordpress.com/2012/07/10/today/#respond

    My own website:
    http://lutfitorla.com/post/to-be-myself-i-had-to-change-myself/#respond

    I assume this means that the icons are being pulled from the same place for both? Perhaps we should also open a ticket at the WordPress.com forums?

    Hope this gets resolved soon.

  10. Lutfi Torla
    Member
    Posted 2 years ago #

    Update: Started work today on using my own icons. 10 minutes later, I found out that the comments page is pulled inside an iframe. So no CSS styling changes. *sigh*

    And yes, I keep coming back because I'm hoping that the devs notice this soon and fix it up. It's not hard, just fix the URLs or re-upload the image files (as mentioned by sabcat above).

    I'll keep coming back and add on I have more on the topic.

  11. Lutfi Torla
    Member
    Posted 2 years ago #

    Update: I checked a few minutes ago and it works now! I think we can consider this closed. Whoever fixed it, thank you!

    @bdollproject: Does it work for you now? It should. Also, you couldn't find the files because the comment system apparently loads a page inside an iframe from somewhere else completely. It also loads the css and images from the same place.

    I'll also change my vote now from "broken" to "works". I hope a mod can close this thread now. Thanks.

  12. bdollproject
    Member
    Posted 2 years ago #

    Yes, the icons are showing up now:
    http://goodattorneysatlaw.com/2012/07/florida-extends-aircraft-maintenance-tax-exemptions/#respond

    Everything looks great now, I will mark as resolved since I opened the thread. Thanks everyone!

    Thanks,
    Suzette

  13. abtech
    Member
    Posted 1 year ago #

    I installed this and it does not show anything except the same old wordpress comment system. There is no other option for people to comment other than with logging in with wordpress. What have I done wrong? It says it's activated and I check the settings but there is nothing different as far as options.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic