WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Sharing buttons showing after excerpts (26 posts)

  1. Thea
    Member
    Posted 1 year ago #

    The sharing buttons are showing on my front page, even though I've double-checked I have unchecked that box in the settings.

    http://tribal.bellydanceoz.com/

    Any ideas what's wrong?

    http://wordpress.org/extend/plugins/jetpack/

  2. selenium79
    Member
    Posted 1 year ago #

    I have a similar problem :
    I uncheck the sharing option in the post settings but it's not being saved in the database :(
    Anyone ?

  3. Thea
    Member
    Posted 1 year ago #

    I have upgraded Jetpack and still have the same problem. Anyone?

  4. Tim Moore
    Moderator
    Plugin Author

    Posted 1 year ago #

    I am looking into this and will let you know when I have more information.

  5. Swell Concepts
    Member
    Posted 1 year ago #

    I have the same problem and wondering if anyone has found a way of solving this?

    I haven't posted a link as I am using a different plugin at the moment to produce share buttons

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @Swell Concepts Do you experience similar issues when switching to a different theme for a few minutes?

  7. Swell Concepts
    Member
    Posted 1 year ago #

    No on another theme it works fine no problems.

    The one that it doesn't work on the front page pulls up pages.

    The one that it works fine on the front page pulls up posts.

    maybe this helps.

  8. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you post a link to that theme so I can download it and run some tests?

  9. Swell Concepts
    Member
    Posted 1 year ago #

    It is a premium theme sorry so I aren't sure if that would work for you?

    Chameleon Theme

    I have enabled the sharing on pages for the moment and will leave it like that for the next 30mins for you to have a look at! Through the sharing setting I have double checked and have deselected the option for Front Page.

    http://www.swellconcepts.be

  10. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you open the "Blog" page in your page editor, and uncheck the "Sharing buttons" option appearing at the bottom of the editor?

  11. Swell Concepts
    Member
    Posted 1 year ago #

    Yep that did the trick. Thanks for your help.

  12. somtam
    Member
    Posted 1 year ago #

    Is there any hook or filter than can control the output of the share button?
    I use many wp_query in my sidebar or somewhere else, so I need it.

    thanks!

  13. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @somtam You can use <?php echo sharing_display(); ?> to insert the sharing buttons anywhere in your loop.

  14. somtam
    Member
    Posted 1 year ago #

    Thanks, but the problem is that I don't want them to show up in my, as an example, sidebar, where I have custom query.
    thanks!

  15. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @somtam You could change your sharing settings under Settings > Sharing to hide buttons on your front page and archive pages.

    You could also hide the buttons with CSS.

    Otherwise, I don't think it will be possible to remove the sharing buttons from a specific custom query on a page where you want the buttons to appear for another one of your loops.

  16. Thea
    Member
    Posted 1 year ago #

    I started this thread and my issue is NOT resolved.

    Because of the problem, I've stopped using the page as my front page, here it is:

    http://tribal.bellydanceoz.com/welcome/

    The "show sharing buttons" box at the bottom of the page is not checked, yet they still show.

  17. waffenss
    Member
    Posted 1 year ago #

    @Thea try using this i do and it still works fine with Jetpack even on new update place the buttons on top or bottom of post, also that theme you use shows those button there like that i used a similiar theme or maybe the same one was a news theme.

    Guys should update this and implement into jetpack

    http://wordpress.org/extend/plugins/jetpack-extras/

  18. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @Thea I tried to access your site, but I was redirected to another URL, bellydance.com, that doesn't use WordPress.

    Could you point me to your WordPress site URL so I can have a look?

  19. Thea
    Member
    Posted 1 year ago #

    Oops, sorry. The blog is geo-targeted because I'm an eBay affiliate and it reduces my income if people from non-eBay countries click on the ads. I see you're in Hungary - I've added Hungary to the list of allowed countries so you should be able to see it now.

  20. Thea
    Member
    Posted 1 year ago #

    @waffenss, thanks but I don't need the functionality of that plugin anywhere else on the blog, so I'm a bit reluctant to add a whole plugin just for this one little problem.

  21. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @Thea I had a look at your site, and I do not see any sharing buttons on your home page; have you managed to solve the issue by yourself?
    http://i.wpne.ws/NycO

    In general, if you set a static Front Page under Settings > Reading in your dashboard, you will want to uncheck the sharing options in the Page editor (Under Pages > All Pages > Edit) if you don't want the buttons to appear on that page.

  22. Thea
    Member
    Posted 1 year ago #

    I have to apologise, I took it off the front page because of the issue (and if you check my original post, I say I double-checked that I had the sharing options unchecked).

    I've just tried resetting it as the front page, and it's now working there - must have been fixed in an upgrade since.

    However, one more question - if I make the page an ordinary page again, the sharing buttons reappear on the excerpts, even though I've got the sharing option unchecked. Is that correct?

    http://tribal.bellydanceoz.com/welcome/

  23. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    I see the sharing buttons on that page, indeed.
    http://i.wpne.ws/O0Rk

    Could you post screenshots of your settings under Settings > Sharing in your dashboard, as well as the sharing options at the bottom of the Page Editor?

    Thanks!

  24. DafiKasia
    Member
    Posted 1 year ago #

    Hello,
    I'm having the same problem. Sharing buttons show under the exerps from the previous/next page. How can I disable that?
    This is an example:
    http://www.katarzynatolwinska.com/kasia-and-living-creatures/

    Thank you for your help!

  25. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @DafiKasia Your theme seems to call the_excerpt() in the navigation links, thus causing the issue.

    You could hide the sharing buttons by adding the following CSS code to your theme stylesheet, or to your custom CSS editor under Appearance > Edit CSS in your dashboard:

    .nav-excerpt .sharedaddy {
        display:none;
    }
  26. craigcac
    Member
    Posted 10 months ago #

    Thanks for this CSS solution. Saved me from rewriting the home.php

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic