WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] register_http_request_failed (8 posts)

  1. krivik
    Member
    Posted 2 years ago #

    Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host.

    http://wordpress.org/extend/plugins/jetpack/

  2. shahilj
    Member
    Posted 1 year ago #

    Seems like this is a common problem. The error I'm getting is:

    Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host. 13: Permission denied

    Help?

  3. Gwyneth Llewelyn
    Member
    Posted 1 year ago #

    I sometimes get that when having hosts either behind a firewall, or with a cache plugin (I usually use W3 Total Cache) turned on.

    In the latter case, the trick is often to temporarily disable the cache, allow JetPack to connect, and enable it again. This often works.

    Sometimes it's just the JetPack webservers that are over demand. Connecting at a different time usually fixes that.

    But more recently I have noticed that the fallback from HTTPS to HTTP (when connecting behind proxies/firewalls) tend to give either that error, or the even more strange "0" error. Logs show that the HTTPS connection failed, but JetPack doesn't seem to fallback to connecting to HTTP any more.

  4. Beau Lebens
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks Gwyneth.

    Indeed, W3 Total Cache is probably the most common cause for this error that we see. Are you (krivik/shahilj) using that plugin? Can you try temporarily disabling it and connecting Jetpack?

  5. shahilj
    Member
    Posted 1 year ago #

    Hey. Thanks for the reply! I've looked through everything with my (limited) knowledge and have a feeling its an issue on the hosts side. I'm not using the W3 plugin that you are talking about nor am I using any other plugin which would do anything similar to what you have mentioned.

    I'm going to try two approaches: Diasble ALL plugins temporarily and try connecting again or if that fails, call my host ;) Will report back!

  6. Gwyneth Llewelyn
    Member
    Posted 1 year ago #

    Some hosts do, indeed, block outgoing HTTP/HTTPS requests. Nevertheless, if your blog auto-updates regularly from WordPress (i.e. if you get notifications for new plugins or themes, or new versions of WP), then it means that at least outgoing HTTP calls must be working fine on your host's configuration.

    If they have to enable outgoing requests one by one, remember that JetPack uses both jetpack.wordpress.com and jetpack.me. Both resolve to a wide range of IP addresses, and it's best if your host can enable outgoing calls to the domain names (which can change over time...).

  7. Tim Moore
    Moderator
    Plugin Author

    Posted 1 year ago #

    With no updates in a week, I'm marking this as resolved. Please reopen as needed or post a new topic for us to work in. Thanks!

  8. shahilj
    Member
    Posted 1 year ago #

    Thanks for the replies! I tried everything and it still refused to work. Then I upgrade to 3.4.2 and it magically worked. I didn't question this and I am now a happy Jetpack user! Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags