WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Problems with russian encoding (19 posts)

  1. sanchower
    Member
    Posted 1 year ago #

    Screenshot below
    http://www.picamatic.com/view/8607966_Screen_Shot_2012-08-18_at_4.32.49_PM/

    Please fix it :(
    I 've tried to use other encoding in browser, no luck :(

    Other components of jetpack work OK

    http://wordpress.org/extend/plugins/jetpack/

  2. martinremy
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, your browser encoding is probably fine (it should be UTF-8). Which encoding you are using in your WordPress installation? Please check the page Dashboard->Settings->Reading for the "Encoding for pages and feeds". That should also be UTF-8.

  3. Andy Skelton
    Member
    Plugin Author

    Posted 1 year ago #

    How long has this been happening? Was it working before? If so, when did you first notice the error?

  4. sanchower
    Member
    Posted 1 year ago #

    An encoding of my blog is UTF8
    An encoding of my browser is automaticaly UTF8, but still no luck with this Statistics :(

    I thought UTF8 succesfully supports russian encoding :(

  5. martinremy
    Member
    Plugin Author

    Posted 1 year ago #

    As a test, I configured the following on my Jetpack-enabled blog:
    - Set WPLANG to ru_RU
    - Set encoding to UTF-8
    - Set interface language to ru here: http://wordpress.com/#!/settings/

    With these settings, I am able to see my Jetpack stats with the correct encoding in Russian (http://cl.ly/image/1Q2y3h2Y3w26). I don't know if the translations are correct, but the encoding seems to be correct.

    Can you verify your settings in those 3 categories above? Thanks.

  6. sanchower
    Member
    Posted 1 year ago #

    - Set interface language to ru here: http://wordpress.com/#!/settings/

    it's OK

    Where can I find these settings?

    As a test, I configured the following on my Jetpack-enabled blog:
    - Set WPLANG to ru_RU
    - Set encoding to UTF-8

  7. martinremy
    Member
    Plugin Author

    Posted 1 year ago #

    WPLANG is set in your wp-config.php file, you can set it to ru_RU following these instructions:
    http://codex.wordpress.org/Installing_WordPress_in_Your_Language#Single-Site_Installations

    WPLANG is probably already correct if you have installed a Russian version of WordPress.

    The encoding of your blog is set in Dashboard->Settings->Reading, look for Encoding for pages and feeds". This should be UTF-8.

  8. sanchower
    Member
    Posted 1 year ago #

    define('DB_CHARSET', 'utf8');
    define('WPLANG', 'ru_RU');

    All is OK :(

  9. sanchower
    Member
    Posted 1 year ago #

    The encoding of your blog is set in Dashboard->Settings->Reading, look for Encoding for pages and feeds". This should be UTF-8.

    it's OK too

  10. martinremy
    Member
    Plugin Author

    Posted 1 year ago #

    With these 3 things set, are you still not getting the correct encoding in your stats page?

    1) Change to define('WPLANG', 'ru_RU'); in wp-config.php

    2) Set the encoding of your blog to UTF-8 in Dashboard->Settings->Reading, look for Encoding for pages and feeds".

    3) Set the interface language on WordPress.com to ru in http://wordpress.com/#!/settings/

  11. sanchower
    Member
    Posted 1 year ago #

    Unfortunately yes :(

  12. sanchower
    Member
    Posted 1 year ago #

  13. martinremy
    Member
    Plugin Author

    Posted 1 year ago #

    When you go to the stats page in Chrome, could you look at the “View” → “Encoding” menu, what is checked?

  14. sanchower
    Member
    Posted 1 year ago #

    It is set to automaticaly - Unicode UTF8

  15. martinremy
    Member
    Plugin Author

    Posted 1 year ago #

    In Chrome's View -> Encoding, please try turning off (uncheck) auto-detect and select UTF-8 manually.

  16. sanchower
    Member
    Posted 1 year ago #

  17. martinremy
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for your patience. Unfortunately I'm out of ideas at this point and I'm able to see the correct Russian encoding in Jetpack Stats with the settings as I've described above, and I haven't seen reports of Jetpack Stats displaying with the wrong encoding from other users.

    Perhaps someone in the Russian WP forum has some additional ideas:
    http://ru.forums.wordpress.org/

  18. sanchower
    Member
    Posted 1 year ago #

  19. sanchower
    Member
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic