WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Jetpack shortlink not working (17 posts)

  1. jenxi
    Member
    Posted 2 years ago #

    All my shortlinks aren't working. When I try to access them, I get the message "Sorry, we could not resolve that url."

    Any solutions for this?

    http://wordpress.org/extend/plugins/jetpack/

  2. Tim Moore
    Moderator
    Plugin Author

    Posted 2 years ago #

    Could you share one of the shortlinks that isn't working? If you want to keep it private, please send us a ticket.

  3. jenxi
    Member
    Posted 2 years ago #

    Hi, this is one of the links http://wp.me/pFRTI-u2

  4. Tim Moore
    Moderator
    Plugin Author

    Posted 2 years ago #

    I should've included this in my above question, sorry: what is the full URL that the shortlink should go to?

  5. jenxi
    Member
    Posted 2 years ago #

  6. Tim Moore
    Moderator
    Plugin Author

    Posted 2 years ago #

    Edit that post and click the Get Shortlink button and try the new shortlink it gives you, please. Does that one work?

  7. jenxi
    Member
    Posted 2 years ago #

    I tried that but it gives me the same shortlink.

  8. jenxi
    Member
    Posted 2 years ago #

    Any updates on this?

  9. Tim Moore
    Moderator
    Plugin Author

    Posted 2 years ago #

    Sorry for the delay. I'm looking into the issue.

    Could you confirm that when you create and publish a new post and then use the Get Shortlink button, that this error is still happening?

    Thanks!

  10. jenxi
    Member
    Posted 2 years ago #

    Yes, it is still happening even for new posts.

  11. Tim Moore
    Moderator
    Plugin Author

    Posted 2 years ago #

    Sorry about the issues. I've updated a few things on my end that should take care of this and allow your shortlinks to work again.

  12. jenxi
    Member
    Posted 2 years ago #

    Hi, thanks a lot. The links are working now. I really appreciate it, Tim.

  13. adiljani
    Member
    Posted 1 year ago #

    hey. i am facing a problem on jetpack link short service, whenever i try to get a short link of any of my post it gaves me short link but that short link always gave me error
    Original Link
    http://empiresandallies.movies-mania.com/2013/01/empires-and-allies-the-warzone-hack/

    short link
    http://wp.me/p2o9CA-12u

    Sorry, we could not resolve that url.

    can you guide me how to fix it ? on my other subdomain on same server its working fine but not working on my other domain

  14. clinch
    Member
    Posted 1 year ago #

    I just had this happen to me as well. This is what happened.

    1) I set up a new wordpress site at a temporary domain.
    2) From the temporary domain, I connected Jetpack to my WordPress account
    3) I published my site to the real production domain and changed the domain name in the settings of WordPress
    4) Whenever Jetpack would generate a short link, it would point to the old temporary domain instead of the correct production domain.

    Luckily I caught this and then created a 301 redirect at the temporary domain for anyone that saw the short link.

    However, here's the fix:

    Simply go into your Jetpack plugin settings, then "Disconnect" from WordPress.com. Then re-connect it again immediately. I think this forces Jetpack to read the proper domain settings again, and will start generating proper Short links to your blog.

    Hope this helps.

  15. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @clinch Could you please start a new thread about your issue, and let us know your site URL so we can investigate further?

    If you don't want to share your site URL on a public forum, you can also contact us via this contact form:
    http://en.support.wordpress.com/contact/?jetpack=needs-service

  16. clinch
    Member
    Posted 1 year ago #

    No need. The problem has already been solved, as I stated above. I was posting this message for other users that were perhaps having the same problem as me. My steps to recreate and solve the issue are all listed above.

  17. EdwardMartinIII
    Member
    Posted 1 year ago #

    Clinch, thank you!

    This issue was driving me bonkers and that was EXACTLY the fix!

    Cheers!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags