WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
Jetpack on Multi-site? (12 posts)

  1. RavanH
    Member
    Posted 3 years ago #

    Hi,

    Could anyone tell me how Jetpack will perform on a multi-site install?

    Should it be Network Activated or better not? Will each site need it's own WordPress.com account?

    Thanks :)

    http://wordpress.org/extend/plugins/jetpack/

  2. Andy Peatling
    Member
    Plugin Author

    Posted 3 years ago #

    If you activate it on a multisite install then it can be set up on each individual site with a separate WordPress.com account for each. It doesn't work globally yet.

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 3 years ago #

    I was able to set it up on a multisite install and connect two of my blogs to it using the same WordPress.com account on both. This seems to work fine for me, but YMMV.

    Note that both of the blogs in question were using the wp.com stats plugin before switching to Jetpack.

  4. RavanH
    Member
    Posted 3 years ago #

    Andy, thanks for the explanation :)

    Otto, I suppose those are subdomain blogs... or are they mapped domains?

  5. diniscorreia
    Member
    Posted 3 years ago #

    Anyone tried Network Activating and using the define('WPCOM_API_KEY','...') in the config file?

    I used this with Akismet and it working for all the blogs on the network. Haven't installed Jetpack yet to test this.

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 3 years ago #

    Otto, I suppose those are subdomain blogs... or are they mapped domains?

    Mapped in my case, but it will work perfectly well on subdomains or subdirectories too.

    Anyone tried Network Activating and using the define('WPCOM_API_KEY','...') in the config file?

    Jetpack doesn't use API keys anymore. It connects to wp.com directly and gets that information via an XML-RPC type of mechanism.

  7. davidryal
    Member
    Posted 3 years ago #

    If you activate it on a multisite install then it can be set up on each individual site with a separate WordPress.com account for each. It doesn't work globally yet.

    @apeatling:
    Is it just me, or does that leave anyone out in the cold who was previously using WP-Stats across multiple domains in a multisite install, managed through a single wordpress.com account (in our case, 'importantmedia' -- 16 different wp.com ID's would be cumbersome).

    Any ideas when that global "yet" might be coming? cheers.

  8. firemom
    Member
    Posted 3 years ago #

    I have it installed on three separate sites with one WordPress.com account. Of course, one of those installs is totally borked and Andy can't tell me what is wrong with it. But the other two work absolutely fine. (The one that doesn't work was the second install. Still showing old stats page despite the old stats being deactivated.) Third install went swimmingly.

  9. pixelyzed
    Member
    Posted 3 years ago #

    I'm now having an issue with JetPack's WordPress.com Stats on a multisite install. This is a pretty large network (main site plus 44 "sub" sites).

    Everything was working OK after the upgrade from plain WP.com Stats to the JetPack version but, I created 2 new sites on the network yesterday and the first of these is now showing the stats from the main site (blog ID 1). The main site is showing stats from I don't know what but not the ones it did before. The last site (second one I created yesterday) seems to be ok but the Top Search terms are weird. First, that site shouldn't be seeing any traffic yet and the terms seem more related to main site as well.

    Is there anything that can be done to fix this?

    Btw, I had network activated JetPack before and after the 2 new site created borked the install, I deactivated and reactivated on a site by site basis. Same problem pertists.

  10. Dunhamzzz
    Member
    Posted 2 years ago #

    I am having the same issue as above, the jetpack stats for sites 2,3 and 4 in my network all reflect site one, even the "top pages" and everything, even though all the sites are on different domains.

    Maybe stats isn't compatible with a multisite setup? Unless... you use different wp.com accounts, which is not something I can do right now.

  11. Erlend Sogge Heggen
    Member
    Posted 2 years ago #

    Yep, I think I am experiencing this issue as well. My sub-domain site shows the exact same statistics as the main site.

    I activated my main site with Jetpack first, then the secondary, sub-domain site.

  12. Erlend Sogge Heggen
    Member
    Posted 2 years ago #

    I tried contacting the Jetpack support team but I've yet to hear back from them. It's been weeks.

    I even brought up the issue with the WP core developers, who rightfully pointed me in the direction of Jetpack Support:
    http://core.trac.wordpress.org/ticket/19943

    I really wish this issue would receive some more attention though. It's making it impossible to use Jetpack effectively on Network installs.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic