WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] JetPack issues after upgrading (6 posts)

  1. justincoetzee
    Member
    Posted 1 year ago #

    Hi.

    I'm having major issues with JetPack after upgrading from the previous version to the latest version. Upon upgrading from the dashboard initially, my whole back-end went blank. I ended up logging in via FTP and deleting the JetPack directory and when I logged back in to my site, I could access the Dashboard once again. I logged a support call and received a response from Chris who suggested that I delete my current version, download the latest version and upload a fresh copy via FTP. Before I did that however, I installed the plugin from my dashboard again and this time it worked. When I looked at the enabled services I noticed some were deactivated. I started activating them again, but right after activating the grammar module, blank pages again. I hit back and disabled the module and now it seems to work again. I considered living without that module but then also noticed that my sharing module doesn't update the changes I make within that module and I had to subsequently disable that too. I'm concerned that there may be other issues as well which I have just not picked up on yet.

    I have since followed the advice and deactivated, deleted and re-uploaded JetPack, but the issues remain.

    I'm desperate to get this working again, and would appreciate any feedback or suggestions.

    My website is http://www.winstuff.co.za

    Thanks,
    Justin.

    http://wordpress.org/extend/plugins/jetpack/

  2. Beau Lebens
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Justin -- do you have access to your server's error logs? If you could look in there just after making some of these changes/triggering these errors, we might be able to get some useful information that would help figure out what's going on.

  3. tdgutierrez
    Member
    Posted 1 year ago #

    I had a related issue installing 1.6 and upgrading to 1.7. After the 1.6 install, access to the dashboard and other back-end pages (like the plugins page and the post page etc.) were blank. To fix the problem, I deleted and reinstalled 1.6, this seemed to work. But this quick fix does not work for the 1.7 upgrade. I simply must delete jetpack by hand at the server to get old functionality. Right after installing jetpack and trying to use my dashboard and other wp pages my error logs read:

    [Thu Aug 23 21:18:30 2012] [error] [client 198.72.141.14]
    [Thu Aug 23 21:18:30 2012] [error] [client 198.72.141.14] Deprecated: Directive 'register_globals' is deprecated in PHP 5.3 and greater in Unknown on line 0

    [Thu Aug 23 21:18:30 2012] [error] [client 198.72.141.14]
    [Thu Aug 23 21:18:30 2012] [error] [client 198.72.141.14] Deprecated: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
    [Thu Aug 23 21:18:33 2012] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
    [Thu Aug 23 21:18:33 2012] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
    [Thu Aug 23 21:18:33 2012] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
    [Thu Aug 23 21:18:33 2012] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
    [Thu Aug 23 21:18:39 2012] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
    [Thu Aug 23 21:18:39 2012] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
    [Thu Aug 23 21:18:41 2012] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
    [Thu Aug 23 21:18:41 2012] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
    [Thu Aug 23 21:18:41 2012] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
    [Thu Aug 23 21:18:42 2012] [error] [client 66.249.72.1] File does not exist: /usr/local/apache/htdocs/robots.txt
    [Thu Aug 23 21:18:45 2012] [error] [client 74.134.116.203]
    [Thu Aug 23 21:18:45 2012] [error] [client 74.134.116.203] Deprecated: Directive 'register_globals' is deprecated in PHP 5.3 and greater in Unknown on line 0
    [Thu Aug 23 21:18:45 2012] [error] [client 74.134.116.203]
    [Thu Aug 23 21:18:45 2012] [error] [client 74.134.116.203] Deprecated: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
    [Thu Aug 23 21:18:46 2012] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
    [Thu Aug 23 21:18:46 2012] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!

  4. Beau Lebens
    Member
    Plugin Author

    Posted 1 year ago #

    It looks like you have a number of misconfigurations in your server config.

    register_globals should not be set,
    magic_quotes_gpc should not be set,
    Your 401 ErrorDocument should reference a local file, not a full URL

    Also, I'm not sure why you're getting 401 errors at all -- those are authentication related. If you have some sort of additional security applied to your admin then that is potentially interfering with Jetpack.

  5. justincoetzee
    Member
    Posted 1 year ago #

    Hi Beau. After seeing your advice to tdgutierrez, I turned off register_globals and magic_quotes_gpc. I also increased my PHP execution time and memory limit. Now everything works.

    THANKS!

  6. Beau Lebens
    Member
    Plugin Author

    Posted 1 year ago #

    Good to hear justincoetzee.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic