WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
Glitch in Jetpack (28 posts)

  1. computerwiz908
    Member
    Posted 3 years ago #

    I cannot seem to connect to WordPress.com using Jetpack. Before even hitting the Connect button, I got the following error message:

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: xml_rpc-32601
    Try connecting again.

    I try clicking connect again and again, but the same message continues to appear.

  2. Andy Peatling
    Member
    Plugin Author

    Posted 3 years ago #

    Do you have the W3 Total Cache plugin installed? If you do then please deactivate it first then try the connection process again. You can reactivate after you are connected.

  3. kamenlee
    Member
    Posted 3 years ago #

    I have tried it on two sites and have gotten that error and this one....

    Your Jetpack has a glitch. Connecting this site with WordPress.com is not possible. This usually means your site is not publicly accessible (localhost).

    Both are on an Ubuntu box and both sites are publicly accessible.

    Any ideas?

  4. TioBOB
    Member
    Posted 3 years ago #

    Mine says:

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just unlucky: site_id_invalid

    I've tried in both of my websites and I get the same error. No cache plugin installed here.

  5. computerwiz908
    Member
    Posted 3 years ago #

    Yep, temporarily deactivating W3 Total Cache worked. Thanks!

  6. TioBOB
    Member
    Posted 3 years ago #

    Just got an answer from the support team. They changed something and now it's working — that was FAST.

  7. atobias
    Member
    Posted 3 years ago #

    Same error as others:

    Your Jetpack has a glitch. Connecting this site with WordPress.com is not possible. This usually means your site is not publicly accessible (localhost).

    The site IS public accessible (http://lekkerhapje.nl) and I currently use other WP.com plugins (Stats and Akismet) without any problems.

  8. dogwonder
    Member
    Posted 3 years ago #

    I have the same issue with my site (dogwonder.co.uk) -

    Your Jetpack has a glitch. Connecting this site with WordPress.com is not possible. This usually means your site is not publicly accessible (localhost).

    No instance of cache installed, also Askimet runs fine. However I am running my install on an apache install on a winOS box.

  9. Philipp15b
    Member
    Posted 3 years ago #

    I have the same problem with my site too (blog.philworld.de).
    Same as error message "dogwonder":

    Your Jetpack has a glitch. Connecting this site with WordPress.com is not possible. This usually means your site is not publicly accessible (localhost).

    I have deactivated W3 Total Cache and Akismet works.

  10. janiceandcompany
    Member
    Posted 3 years ago #

    Same as error message as the others;

    Your Jetpack has a glitch. Connecting this site with WordPress.com is not possible. This usually means your site is not publicly accessible (localhost).

  11. atobias
    Member
    Posted 3 years ago #

    I logged a ticket @ jetpack.me/support and they were able to help me solve this. Below their response:

    It looks like your web server is incapable of sending outgoing requests over HTTPS (as opposed to HTTP). Jetpack should be able to detect this inability and work around it. We'll work on making that check better in the next version of the Jetpack plugin.

    In the meantime, if you are comfortable editing PHP files, you can modify wp-content/plugins/jetpack/jetpack.php.

    On line 1290, change the current:

    if ( $jetpack->use_ssl[$method] ) {

    to the new:

    if ( false && $jetpack->use_ssl[$method] ) {

  12. mafutrct
    Member
    Posted 3 years ago #

    I don't have a cache plugin installed and tried atobias' workaround - still getting an "unknown" glitch.

  13. Mihai
    Member
    Posted 3 years ago #

    Mine says:

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: site_lang_missing

    Any suggestions?

  14. gizeek
    Member
    Posted 3 years ago #

    I got that too:

    Your Jetpack has a glitch. Connecting this site with WordPress.com is not possible. This usually means your site is not publicly accessible (localhost).

    My site is publicly accessible and I have deactivated anything that can cause any problems and I tried atobias' solution but nothing seems to work.

    Any Ideas ?

  15. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    For anyone having similar issues:

    1) Check to ensure that any Proxy services you may be using, such as CloudFlare, are temporarily disabled.

    2) Check for any .htaccess UserAgent or IP address blacklist entries (such as those provided by PerishablePress).

  16. houldsworth1
    Member
    Posted 3 years ago #

    I had this running a Bitnami instance in Amazon EC2. I tried the suggestion listed above by atobias (change line 1290 of the PHP file) and that worked.

    Thanks!

  17. janiceandcompany
    Member
    Posted 3 years ago #

    I used the fix above and it worked! Thanks!

    atobias wrote:

    modify wp-content/plugins/jetpack/jetpack.php.
    On line 1290, change the current:
    if ( $jetpack->use_ssl[$method] ) {
    to the new:
    if ( false && $jetpack->use_ssl[$method] ) {

  18. gizeek
    Member
    Posted 3 years ago #

    I only deactivated Cloudflare ant it worked perfectly!
    Didn't thought about it !
    Thanks

  19. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    Darn... no proxy servers, nothing blacklisted in .htaccess.

    Tried with all plugins inactive, and tried the above code

    I still has glitch....

  20. kaita961
    Member
    Posted 3 years ago #

    editing the jetpack works perfectly and I like it better anyway. open notepad copy your jetpack file from the plugin editor and find if ( $jetpack->use_ssl[$method] ) { then replace with if ( false && $jetpack->use_ssl[$method] ) { the then just paste the whole thing back into the editor and update

  21. fher98
    Member
    Posted 3 years ago #

    I unistalled all plugins, except akismet. Did the editor thingy... and still glitch.

  22. kevitivity
    Member
    Posted 3 years ago #

    Jetpack is broken for me as well. No .htaccess, no cache plugins, site is publicly available and the server can make SSL connections. The error I'm getting is...

    Your Jetpack has a glitch. Connecting this site with WordPress.com is not possible. This usually means your site is not publicly accessible (localhost).

  23. fher98
    Member
    Posted 3 years ago #

    @kevitivity:

    Have you tried the latest version. If so, does your blog dashboard runs under https??

    Try to connect jetpack from your dashboard but with a normal (not secured) http

  24. berkun
    Member
    Posted 3 years ago #

    There is currently a general issue on WordPress.com that is impacting Jetpack Stats and new Jetpack connections.

    Right now best bet is to follow @wordpressdotcom on twitter or @jetpack as we'll keep you posted there.

  25. johnyw
    Member
    Posted 2 years ago #

    Well, I tried just about everything of the above, and nothing works ?
    I got this warning:
    Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host. There are no HTTP transports available which can complete the requested request.

    I contacted my ISP and he says that everything should work??

  26. Miserere
    Member
    Posted 2 years ago #

    I get the same error as johnyw:

    Jetpack could not contact WordPress.com: register_http_request_failed.

    Any solutions available?

  27. jpaston
    Member
    Posted 2 years ago #

    I've just been updating my sites, replacing WP Stats with Jetpack.

    From the sites that are on one of my Hostgator servers, all the .com sites connect perfectly. The .net and .info sites refuse to connect with the error:
    Your website needs to be publicly accessible to use Jetpack:
    Error Details: The Jetpack server was unable to communicate with your site [IXR -32300].

    I've disabled all caches and tried the php fix above, but to no avail. Any other suggestions?

  28. jpaston
    Member
    Posted 2 years ago #

    All resolved, thanks to Jetpack support at WordPress.com

    They found that there was intermittent public access to my sites and suggested I look at the DNS.

    There was a failure on one of the Nameservers on my hosting account which Hostgator resolved.

    All is now working as it should.

    If you see this 'Your website needs to be publicly accessible to use Jetpack' then check your DNS settings are working correctly by contacting your webhosting service.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags