WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
Email subscriptions using old Author profile (26 posts)

  1. dcwebman
    Member
    Posted 2 years ago #

    I am using the Email Subscriptions in Jetpack. I just noticed the author link is pointing to the old location of my blog. I originally had my blog on my own website and then moved it to another website name May 2011. I thought I changed every URL location but obviously this was before the Email Subscriptions became available in Jetpack. Every profile I have looked at shows my new URL so I do not know where Jetpack is pulling my old URL from.

    Any ideas as to where I can correct the URL? Thanks!

    http://wordpress.org/extend/plugins/jetpack/

  2. dcwebman
    Member
    Posted 2 years ago #

    Let me ask again please. In the email which comes from the Jetpack subscription, the author link in addition to the Tag & Category links are all pointing to my wrong URL. How can I correct the URL?

  3. philliposophy
    Member
    Posted 2 years ago #

    I'm having the exact same issue.

  4. JayPatrol
    Member
    Posted 2 years ago #

    I'm also hoping for a solution to this please if anyone can help.

    I moved a client's blog from one host to another:

    http://carlgombrich.org

    and the subscription links that appear in the emails that are sent out are pointing to the temporary URL I set up with my new host in anticipation of the transfer:

    http://carlgombrich.org.gridhosted.co.uk

    I can't see where this information is stored and therefore how to change it.

  5. dcwebman
    Member
    Posted 2 years ago #

    I eventually contacted WordPress.com support. After emails with supplying information, they said Jetpack uses information saved at WordPress.com to create the links. They had to manually update my old link to the new link somewhere on the WordPress.com site and that fixed the author and tag links in the email sent out. The category link was corrected to the new site but it's an invalid link when clicked on.

    I'm waiting for word on how that can get fixed and if what they did is something we can do somewhere ourselves. My WordPress.com account info looked correct everywhere I could find and doesn't look any different now.

    If I get more information, I'll be sure to post it.

  6. JayPatrol
    Member
    Posted 2 years ago #

    Thanks dcwebman. I think Jetpack is getting there bit by bit.

    I have worked around my the problem for the time being by re-configuring the domain alias in my hosting panel but that option obviously isn't a fix for most circumstances.

  7. philliposophy
    Member
    Posted 2 years ago #

    JayPatrol,
    I'm not sure what you mean by 're-configuring the domain alias in my hosting panel'.
    Would you mind elaborating?

    dcwebman,
    I tried contacting wordpress.com, but they haven't gotten back to me yet. Looking forward to solving this problem.

    Thanks for keeping this thread alive everyone!

  8. JayPatrol
    Member
    Posted 2 years ago #

    Hi Philliposophy

    I think I might be in a more fortunate situation than others with this problem.

    It looks like WordPress.com locked in the temporary domain I was using whilst moving host (http://carlgombrich.org.gridhosted.co.uk).

    I had routinely de-activated that domain once the transfer had complete but subsequently realised a solution for me was to re-establish that domain.

    I don't expect that is likely to be option for others with a similar problem as WordPress.com has most likely locked on to a domain to which you no longer have access.

  9. philliposophy
    Member
    Posted 2 years ago #

    Hey guys, I was able to solve my problem by simply disconnecting Jetpack entirely and then reconnecting it.
    This was done through the Dashboard -> Jetpack screen in the top-right corner.

  10. dcwebman
    Member
    Posted 2 years ago #

    That's great you got it working! Were you using the Site Stats before you disconnected and if so, were they still there when you reconnected?

  11. philliposophy
    Member
    Posted 2 years ago #

    I WAS using site stats before I disconnected and they WERE STILL THERE when I reconnected. Giant sigh of relief.

  12. dcwebman
    Member
    Posted 2 years ago #

    Great! I got a "we haven't forgotten you email" from support last Friday so I'll probably wait another week and if no resolution, I'll attempt the disconnect and hold my breath!

  13. philliposophy
    Member
    Posted 2 years ago #

    Cool. Let us know how it turns out!

  14. dcwebman
    Member
    Posted 2 years ago #

    I haven't heard anything from support so just tried the disconnect/reconnect. It didn't solve my problem. They had previously tweaked something so most of the links work in the subscription email except for the Category links. Still don't work. I'm not sure if it was because they had made that previous change or not.

  15. dcwebman
    Member
    Posted 2 years ago #

    Good news. Support has been able to reproduce the Category link problem in the Jetpack subscription emails and it has been forwarded to the developers.

  16. philliposophy
    Member
    Posted 2 years ago #

    work2ride, that's what worked for me. Post again once you try it and let us know how it worked.

  17. work2ride
    Member
    Posted 2 years ago #

    Worked great, man I wished I found this thread before I tried the million of other changes I did :)

    Also all my stats and askimet data was still there, no loss. THANK YOU

  18. dcwebman
    Member
    Posted 2 years ago #

    Figures it didn't work for me before. I might just have to try it again. Still waiting to hear back from support and upgrading every time I see new version of Jetpack come out hoping that fixes it.

  19. douglerner
    Member
    Posted 2 years ago #

    In my case the author links goes to my self-hosted blog, but to a missing page "It seems we can’t find what you’re looking for. Perhaps searching, or one of the links below, can help."

    I tried disconnecting and reconnecting but it doesn't help.

    It's trying to go to http://mydomain.com/?author=1 which gets re-directed to http://mydomain.com/author/DougLerner/ which doesn't exist.

    Is there some URL-related setting I can change to make the link work?

    Thanks,

    doug

  20. concentre
    Member
    Posted 1 year ago #

    I am also having this problem and have a question for those of you who have resolved the issue by disabling the Jetpack plugin. Did you just disable it and then turn it back on? Or did you uninstall it?

    Thanks!

  21. dcwebman
    Member
    Posted 1 year ago #

    FYI, I asked Support again for an update and got a reply on Sept. 4 saying "I've looked into this issue and confirmed there is still a problem with the category links in jetpack notification emails. I'm checking with our team and will let you know as soon as I have more details about a fix."

    If I hear of it being fixed, I will be sure to update this post.

  22. BlogYourEarth
    Member
    Posted 1 year ago #

    @dcwebman I have the same problem with the Email Subscriptions and the missing category in the link I get back from jetpack in the subscribtion e-mail.

    Excample from Jetpack notification e-mail with wrong URL:
    Subscribe to comments on Road Trip Kanada: Seattle (Tag 17 und 18) on ByteYourLife.com!

    The category top-story is missing in the URL.

    The correct URL is:
    http://www.byteyourlife.com/top-story/road-trip-kanada-seattle/4822

    My permalink structure is as follows:
    /%category%/%postname%/%post_id%

    I hope the Jetpack developers will fix the problem. Until they fixed it I will deactevate Jetpack on my blog.

  23. dcwebman
    Member
    Posted 1 year ago #

    It is taking kind of long to get a fix since it has been 9 months already when it was first reported. If I want my readers who subscribe to emails to correctly use the emails, I might have to start looking for another plug-in just for email subscriptions. Anybody know of one that works?

  24. BlogYourEarth
    Member
    Posted 1 year ago #

    Hi dcwebman,

    yeah I do not have time to wait... I found OptinSkin but I am not sure if it work together with the WPML plugin for multilingual blogs like my blog http://www.BlogYourEarth.com.
    I am still searching and I hope to find a working solution for my blogs. If I make a decision I will inform you about the plugin I will use...

  25. dcwebman
    Member
    Posted 1 year ago #

    To anybody who is still having this problem with email links, the problem may be fixed in version 1.9 of Jetpack. I however still have a problem and that's because of a limitation of WordPress.

    First be sure you have the slug for your category or tag unchanged at least for Jetpack subscription emails. For example, if you have a tag of "Road Trip" the slug should be "road-trip", not anything like "roadtrip".

    My problem is I have a tag and category with the same name and as support has told me: "You're correct however that currently it's not possible to use the same slug for a category as for a tag."

    Hence my tag is correct because the slug meets the description above but the link to the category doesn't work since a different slug had to be created since it is the same name.

    Hope that clarifies the issue for people. Just make sure you have unique category/tag slugs.

  26. dkdesigns
    Member
    Posted 1 year ago #

    For all those experiencing this issue, I found the solution today.

    When you install JetPack on your wordpress blog, it asks you to connect your blog to wordpress.com in order to activate it.

    1) Log into wordpress.com with the same login and password you used to activate your JetPack plugin.

    2) In the top right corner you should see your avatar and log in name. Click it.

    3) You should now be at a page with the heading "Account". In the main content pane, find "Primary Blog" (should be 3 items down the list).

    4) Use the drop down to select the appropriate URL for your blog.

    5) SAVE

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic