WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Diagram in Stats not working since updating to WP3.4 (40 posts)

  1. Tony_M
    Member
    Posted 2 years ago #

    Hi there,
    I just updated my three wordpress installations to version 3.4

    Everything is fine, but the Jetpack stats are a bit confused.
    The diagramm (visitors per day, week, month) can't be displayed.
    Summary table is ok. I even can see the actual data of today and yesterday.
    Only the diagram isn't working anymore.

    Jetpack 1.3.4 is installed.

    Thanks in advance!

    Greetings
    Tony

    http://wordpress.org/extend/plugins/jetpack/

  2. Kim
    Member
    Posted 2 years ago #

    I have the same problem, visitor numbers diagram not showing
    I too have Jetpack 1.3.4 and wordpress 3.4

  3. dsyd
    Member
    Posted 2 years ago #

    Glad it's not just me. I'm also using WordPress 3.4 and Jetpack 1.3.4. Everything's working fine except the stats graphs. Stats graphs are showing on the dashboard, just not in the actual stats section.

  4. dsyd
    Member
    Posted 2 years ago #

    The error I get is here:

    jQuery(document).ready( function($) {
    	function select2BlogStatFormat( blog ) {
    		var formatted = blog.text.replace( /([^(]+)/, '<b>$1</b>' );
    		return formatted;
    	}
    ===>	jQuery( '#statsblog' ).select2( {
    		formatResult: select2BlogStatFormat,
    		formatSelection: select2BlogStatFormat
    	} );
    } );
    > jQuery( '#statsblog' )
    []
    
    > jQuery( '#statsblog' ).select2( {
    		formatResult: select2BlogStatFormat,
    		formatSelection: select2BlogStatFormat
    	} );
    
    TypeError: Object [object Object] has no method 'select2'
  5. akdwivedi
    Member
    Posted 2 years ago #

    Same with me too!! The circle for wait just never ends.

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all other plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

  7. troelschristensen
    Member
    Posted 2 years ago #

    Hi.

    My jetpack plugin (1.3.4) is also not working, when it tries to display the diagram. It also did not work, when i had WP 3.3. But it first stopped working today. :(

    I tried:
    - deactivating all plugins but jetpack. Still not working.
    - updating to WP 3.4. Not working.

    Sadly without luck. Not so keen on updating/resetting all files via FTP or PhpAdmin. Think i'll wait.

  8. troelschristensen
    Member
    Posted 2 years ago #

    And it's not a browser issue. Tried it on IE9, Firefox and Chrome. Without luck.

  9. esmi
    Forum Moderator
    Posted 2 years ago #

    Can I ask you all to indicate:
    - the host you're using
    - the type of server (Windows or *nix)
    - browser(s) used
    - whether you have any browser add-ons

    It might help to track this problem down. In the meantime, I'll flag it up as a possible issue.

  10. Kim
    Member
    Posted 2 years ago #

    I'm not keen on messing with files, I don't really know what I'm doing, so I'll wait too

  11. Alex997
    Member
    Posted 2 years ago #

    My site too has started doing this with WP 3.4 and JP 1.3.4.

    The graph on the dashboard screen is appearing though - just an endless spinning progress wheel on the 'site stats' page....

  12. It's very possible it's just traffic :)

    Everyone and their brother are getting 3.4, updating themes, plugins, etc.

  13. BrenR1958
    Member
    Posted 2 years ago #

    Mine is the same graph on dashboard is OK but not on the stats page, never ending spinning progress wheel

  14. Tim Moore
    Moderator
    Plugin Author

    Posted 2 years ago #

    We are taking a look at this now. I'll let you know when we have more information.

  15. kimharding
    Member
    Posted 2 years ago #

    Mine stats were working fine until I updated to 3.4, looks like Jetpack has a problem with the new update.

  16. geturstuf
    Member
    Posted 2 years ago #

    Why Dont you guyzz checked its campatibility with this upcoming version of wordpress. So, carelessnessssssssss.......
    When i open my dashboard Jetpack sitestats is the first link i click and its not working now, u can imagine how bad i m feeling right now.
    Plzz guyzz solve this bugggg.

  17. geturstuf
    Member
    Posted 2 years ago #

    "Clicky Stats" is an alternate plugin which i am using till the developers of jetpack solve the bug. hope the do it soon.

  18. paul_pants
    Member
    Posted 2 years ago #

    Same here, after 3.4 update Jet Pack Site Stats bar graph loader just spins and spins and spins and...

  19. Tim Moore
    Moderator
    Plugin Author

    Posted 2 years ago #

    We've updated our Stats system to fix this problem. Apologies for the inconvenience. Please let us know if you continue to have problems.

  20. zeetha
    Member
    Posted 2 years ago #

    Thanks, the graph is now working again for me :)

  21. Kim
    Member
    Posted 2 years ago #

    Working for me too, thank you!

  22. geturstuf
    Member
    Posted 2 years ago #

    Does I have to reinstall the plugin or what? coz its not working for me yet. Need Help!!!!!!!!

  23. geturstuf
    Member
    Posted 2 years ago #

    I updated the plugin with the latest update provided and still having the same issue, the spinning W icon doesn't wants to stop spinning.
    Help!!!

  24. dsyd
    Member
    Posted 2 years ago #

    Thanks for the fix, it's working again here.

  25. Ahmed Taha
    Member
    Posted 2 years ago #

    I still have the same problem :S

    No Jetpack stats are showing...

  26. Tony_M
    Member
    Posted 2 years ago #

    Thanky you guys. Now the bars are displayed correctly again.
    Well done.

    I think this thread can be set as SOLVED now.

    Greetings and many thanks
    Tony

  27. HillAustinD
    Member
    Posted 2 years ago #

    I updated to jetpack 1.4.1 and site stats still don't work.

  28. geturstuf
    Member
    Posted 2 years ago #

    Updated my plugin with latest Version 1.4.1 and still having the problem
    Kindly fix it please

  29. geturstuf
    Member
    Posted 2 years ago #

    The Recent Version is working fine for me thanks
    The problem was with one of my plugin, i disabled all of them and try activating wordpress jetpack and it works. I will soon post about the conflicting plugin with this error. And thanks for the update once again.

  30. geturstuf
    Member
    Posted 2 years ago #

    I found the bugging plugin its "Google Custom Search by Little Handy Tips"
    I want to use this plugin too help me plz

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic