WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Comment/Subscription logic not working. (7 posts)

  1. markross67
    Member
    Posted 1 year ago #

    Hello,

    I updated the Jetpack plug-in this morning, and was excited to see that there were check boxes built into the Subscriptions module. Under the comment box, I want to keep subscriptions unchecked, so that they will not show, as I am only interested in the subscription widget.

    Even with the check boxes unchecked, both subscription features were still showing up. I am assuming there is a bug in the update; has anyone else encountered this?

    Thank you,
    Mark

    http://wordpress.org/extend/plugins/jetpack/

  2. Tim Moore
    Moderator
    Plugin Author

    Posted 1 year ago #

    You are unchecking the options in Settings -> Discussion labeled "Show a 'follow comments' option in the comment form" and "Show a 'follow blog' option in the comment form"? If so, do you have a cache plugin enabled that might be caching the checkboxes being turned on?

  3. dcleeds
    Member
    Posted 1 year ago #

    I'm having the same problem as Markross67. I have no cache plugin.

  4. Tim Moore
    Moderator
    Plugin Author

    Posted 1 year ago #

    Can you try changing to Twenty Eleven and disabling other plugins to see if there is a conflict?

  5. Grishka
    Member
    Posted 1 year ago #

    Hello

    If you don't need the subscription button, you can edit the subscription.php file in plugin/Jetpack/module/ and delete the line

    add_action( 'comment_form', array( $this, 'comment_subscribe_init' ) );

    The checkboxes are no longer showing.

    I think it should be possible to create a CSS rules to hide them too.

  6. ecabral
    Member
    Posted 1 year ago #

    Hi!

    I'm having the same issue as markross67 and dcleeds.

    Disabled all plugins but Jetpack + WooCommerce (my site won't work without WooCommerce) and changed to Twenty Eleven but the subscription options are still showing. The only way they won't show is if I deactivate Jetpack. I'd like to keep on using Jetpack.

    I'm running Jetpack 1.5 and WP 3.4.1.

    FYI, the reason why I want to disable subscriptions is because I haven't been able to figure out how to localize the automated emails that a user gets once they choose to subscribe to the posts/comments. The text is not in the PO file. Would appreciate someone letting me know where this text can be found.

    Thanks!

    PS: Got the "Mind Rating Jetpack?" email, so looking forward to seeing this thread resolved :)

  7. Tim Moore
    Moderator
    Plugin Author

    Posted 1 year ago #

    This issue should be resolved in the latest versions of Jetpack. Please let us know if there are still any problems.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.