WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Comments Not Working (19 posts)

  1. matthoffman7
    Member
    Posted 1 year ago #

    Hi, I see there are other posts on this issue, but none that I see resolved, and my problem seems different.

    When users try to post a comment in Jetpack comments, they get redirected to this 404 error page (within the frame):

    http://www.pulmccm.org/wp-comments-post.php?for=jetpack

    This happens on any post, but here's an example:

    http://pulmccm.org/main/2012/review-articles/treatment-of-acute-deep-venous-thrombosis-dvt-accpchest-guidelines/

    I am using the Suffusion theme, v 3.8.1. There is no support thread on this issue there.

    Thanks!
    Matt

    http://wordpress.org/extend/plugins/jetpack/

  2. José Luís
    Member
    Posted 1 year ago #

    Same thing here: http://www.jlcarneiro.com
    Wordpress 3.4.2 and Jetpack 1.7. Child theme based on Twentyeleven.

    As an workaroung, I deactivated Jetpack Comments.

    Any news on this problem?

  3. exberry
    Member
    Posted 1 year ago #

    Similar problem. Commenting on my posts locked up. Even in Admin mode, I could not add a comment. Traced it to JetPack. Deactivated JetPack to make comments work again.

    Scary ... could not access the place in JetPack to stop the modification of the comment function. So had to bail out of the whole Pack.

  4. José Luís
    Member
    Posted 1 year ago #

    @exberry, if I were you, I'd reactivate Jetpack, go to its page on the admin interface, locate Jetpack Comments, click on "Details" (or "more info", my interface is in pt_BR) and, when the panel shows the details the afore mentioned button will change to "deactivate" (or something like this).

  5. exberry
    Member
    Posted 1 year ago #

    One problem with a plugin that includes several other plugins is when there is no readily accessible master menu. A master menu is necessary to one can select which sub-plugins are active. Without this, one problem plugin can bring down the whole set of plugins.

  6. José Luís
    Member
    Posted 1 year ago #

    @exberry, click on Jetpack on the navigation bar (on the left in the admin interface).

  7. exberry
    Member
    Posted 1 year ago #

    Hi Jose,

    I tried what you suggested. It does not help. Anytime I network activate JetPack, it changes the comment box on all my blogs such that there is no way anyone can post a comment.

    I have the JetPack comment boxes unchecked and this does not turn off its action on the comments.

    Bottom Line: Until this is fixed, I cannot use JetPack.

    Again, I suggest adding an overall menu that sets or unsets each of the components of JetPack.

  8. exberry
    Member
    Posted 1 year ago #

    Actually, you already have the overall screen for JetPack. All you need to do is to add a checkbox on each component.

  9. a1exus
    Member
    Posted 1 year ago #

    Error 403

    We're sorry, but we could not fulfill your request for /wp-comments-post.php?for=jetpack on this server.

    You do not have permission to access this server. Data may not be posted from offsite forms.

    Your technical support key is: XXXX-XXXX-XXXX-XXXX

    You can use this key to fix this problem yourself.

    If you are unable to fix the problem yourself, please contact wordpress at XXX.XXX and be sure to provide the technical support key shown above.

  10. José Luís
    Member
    Posted 1 year ago #

    Thanks to @a1exus post, I remembered I once implemented .htaccess protection of wp-comments.php to avoid spamming.

    When I commented out that protection (in the .htaccess file), my Jetpack Comments restarted working fine.

    If you have you have implemented the same kind of protection and you have experience editing .htacess, this could be a working solution.

    WARNING: wrong changes in .htacess will CRASH you site!

  11. a1exus
    Member
    Posted 1 year ago #

    for comment protection i use: askimet, i dont think it does anything to .htaccess so there is really not much to remove other then stuff wordpress itself wrote down into that file

  12. José Luís
    Member
    Posted 1 year ago #

    @a1exus, I was referring to the current problem with Jetpack Comments, it shows an error message somewhat similar to the one you quoted.

    I found out that, in my case, it was due to some lines I included in my .htaccess file to avoid spamming.

    So, my earlier suggestion was about changing .htaccess to fix Jetpack Comments behavior. Nothing to do with Akismet.

  13. a1exus
    Member
    Posted 1 year ago #

    I guess I should just create my own thread and not take over someone else ... sorry

  14. José Luís
    Member
    Posted 1 year ago #

    @a1exus, no problem! Actually, it was YOUR post that nudged me in the right direction:

    [...] You do not have permission to access this server. Data may not be posted from offsite forms. [...]

    Sorry I could not help you as you helped me! ;-)

  15. Tim Moore
    Moderator
    Plugin Author

    Posted 1 year ago #

    a1exus: you use a plugin called Bad Behaviour; there is an option you need to check to allow offsite form submissions. That should clear up this issue.

    To the OP: you are missing or blocking access to the /wp-comments-post.php file.

  16. nigelparrydotnet
    Member
    Posted 1 year ago #

    This 404 Jetpack Comments error only happens for me when Jetpack is connected to WordPress.com. If it is not, the 404 disappears, suggesting some coding error with a relative URL in the last update of the plugin, which was when this broke for me.

  17. kgagne
    Member
    Posted 1 year ago #

    Thanks to this thread, I was able to fix this problem by removing this code from .htaccess:

    RewriteCond %{HTTP_REFERER} "!^http://www.example.com/.*$" [NC]
    RewriteCond %{REQUEST_URI} ".*wp-comments-post.php$"

    Thanks!

  18. mydogischelsea
    Member
    Posted 1 year ago #

    Ah! I was having the same issue as a1exus. Thank you, Tim! It was my Bad Behavior plugin causing the problem.

  19. ronermarcelo
    Member
    Posted 11 months ago #

    I was having same issue and Tim showed the way to fix this problem. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic