WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
Comments, Facebook login hangs on 'connecting' in IE10/ (13 posts)

  1. Arnoud
    Member
    Posted 1 year ago #

    I've activated and configured the Jetpack Comments plugin for my website. Works very nice in Chrome & Firefox. However in Internet Explorer 10 (on Windows 8 Pro RTM) it won't connect to facebook.
    It just hangs on "Connecting".

    Any ideas on how I can fix this?

    Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)

    http://wordpress.org/extend/plugins/jetpack/

  2. Arnoud
    Member
    Posted 1 year ago #

    I've discovered that when you change the DEFAULT Internet Options | Privacy setting of Internet Explorer from "Medium" to "Accept all cookies" it works.

    However that isn't preferable as many visitors of my website won't know where to find that option and second, the plugin is supposed to work with default browser settings in my opionion.

    IE9 has the same issue by the way.

  3. Tim Moore
    Moderator
    Plugin Author

    Posted 1 year ago #

    We are aware of the issue and we are investigating methods to handle this. Thanks for the report.

  4. birdamon
    Member
    Posted 1 year ago #

    Do you fix it for IE?

  5. Tim Moore
    Moderator
    Plugin Author

    Posted 1 year ago #

    The only fix is to change the Internet Options as Arnoud mentions above. If IE is hanging, that means it is not accepting the cookies that are needed to use the comment form.

  6. eshymko
    Member
    Posted 1 year ago #

    Very damaging error in my opinion.
    16% of people still use Internet Explorer and my subjective guess is that 99% of them don't know how - or won't want to - change their privacy settings to accept ALL cookies, simply to post a comment.

    Which means I can't use this feature as is, and I don't see how anyone can. It doesn't even give an error, it just hangs. Which means people will probably close the site and goodbye potential customer.

    If it can't be fixed, then provide a warning/error or disable the feature for IE users.
    I will implement something for my own site, since I can't just dismiss 16% of all people.

  7. joelssk
    Member
    Posted 1 year ago #

    Has their been any solution to this as of now?

  8. Tim Moore
    Moderator
    Plugin Author

    Posted 1 year ago #

    @joelssk: the solution at present is to change the Third Party Cookies settings in IE.

  9. joelssk
    Member
    Posted 1 year ago #

    Damn, will there be an actual fix for this sometime soon? the guy above does have a point and id really love to use this.

  10. joelssk
    Member
    Posted 1 year ago #

    i have this whole facebook awd system and jetpack eliminates it as long as this works properly I'm really excited about it so please let me know! thanks!

  11. DigiGee
    Member
    Posted 1 year ago #

    I added this option to my website and found out that I've got the same problem with Chrome (version 24.0.1312.57 m)

    So I hope this will be fixed soon!

  12. DigiGee
    Member
    Posted 1 year ago #

    The problem is not only with facebook, I've got the same with WordPress and Twitter :(

  13. 082net
    Member
    Posted 1 year ago #

    {@Tim
    Jetpack Team Lead} We are aware of the issue and we are investigating methods to handle this. Thanks for the report.

    That posted 7 months ago, and the problem still exists :-(

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic