WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
Comments (8 posts)

  1. GetLaunching
    Member
    Posted 1 year ago #

    My comments keep getting disabled after Jetpack is activated. They work for a short time, but the post comment button does nothing after a while. Deactivating jetpack fixes this issue every time without fail. Same issue on two very different websites of mine.

    http://wordpress.org/extend/plugins/jetpack/

  2. getwildphoto
    Member
    Posted 1 year ago #

    I was just about to make a similar post, my Jetpack comments have never actually worked. When I activate them and click 'configure' it takes me to the discussion settings which doesn't really show anything about jetpack other than two check boxes at the bottom. The ultimate problem is when I enable jetpacks comments the comment box appears at the bottom of the post/page as it should but it doesn't actually do anything. You can type a response but when you click 'post reply' nothing happens. I've recently disabled Jetpack comments and just use the default comments which is kind of a bummer.

    Only plugins I have installed are: Jetpack v1.7 and Akismet version 2.5.6 I disabled all other plugins in an attempt to remedy the situation but it hasn't made any difference.

    I'm running wordpress 3.4.1 on a non-wordpress.com blog, hosted by Hostgator.com running DeepFocus theme by Elegant themes.

    Not trying to promote other things here, just wanted to be thorough in my explanation in hopes someone could help me get the comments feature to work. :)

  3. Tim Moore
    Moderator
    Plugin Author

    Posted 1 year ago #

    Do you both have Javascript disabled or blocked somehow in your browsers?

  4. getwildphoto
    Member
    Posted 1 year ago #

    I personally do not, and have used multiple browsers. Also the issue is for all users not just me, when I activate the jetpack comments no one can post a comment.

  5. thecoolestguy
    Member
    Posted 1 year ago #

    Same EXACT issue (and solution) for me. Works great for a period of time and then stops working for EVERYONE. De/reactivating seems to fix it. Maybe it's a namespace issue? I definitely have all my javascript enabled without limitation/blocking...

  6. Tim Moore
    Moderator
    Plugin Author

    Posted 1 year ago #

    Is this still an issue with Jetpack 1.8.3?

  7. thatwastaxing
    Member
    Posted 1 year ago #

    Hi. Just tested this as well and it doesn't seem to work on my 3.4.2 self-hosted with Oxygen theme.

    Too bad because that's all I wanted from Jetpack.

  8. Michael
    Member
    Posted 1 year ago #

    My blog network has the exact same problem. I have Jetpack Comments active on about a hundred blogs on my network. The "Post Comments" button is no longer active when using Google Chrome 22. I am using Jetpack 1.9.2 and WordPress 3.4.2.

    I am able to post comments on the same site in Firefox 16 if I use the NoScript addon to block scripts from wp.com. As soon as I enable scripts from wp.com, the expand/collapse behavior of the comment box works again, and the "Post Comment" button is inactive just like it is in Chrome.

    To complicate things further, the same comment form works perfectly in Safari 6.0.2.

    Disconnecting the site's Jetpack from WordPress.com allowed the comments form to work in Google Chrome; however, the "Post Comments" button was still disabled in Firefox.

    Https vs. http does not seem to be a factor. Both fail.

    The first time this was reported by a user, I disconnected Jetpack from WordPress.com, then reconnected it. I was able to post comments again on that user's site. However, the user reported the same problem a few days later, and I confirmed the "Post Comments" button was again not active, so I just disabled Jetpack Comments on her site and went with the default WordPress comments. I would prefer not to have to do this on a hundred sites.

    BTW, this is likely a completely different issue, but the expand feature of the comments box is seen as a clickjacking attempt by the Firefox NoScript addon. ("NoScript intercepted a mouse or keyboard interaction with a partially hidden element. Click on the image below to cycle between the obstructed and clear version.") I have to uncheck the "Keep this element locked (recommended) button" and OK to allow the comment form to expand.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags