WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] 1.3.2 broke JetPack (40 posts)

  1. shrtstck
    Member
    Posted 2 years ago #

    Getting an error hidden up top by the WP admin bar, but when I try to access JetPack settings via wp-admin/admin.php?page=jetpack I now get:

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in (redacted)/wp-content/plugins/jetpack/jetpack.php on line 1207

    Warning: Invalid argument supplied for foreach() in (redacted)/wp-admin/includes/plugin.php on line 1384

    Warning: Invalid argument supplied for foreach() in (redacted)/wp-admin/includes/plugin.php on line 1384

    You do not have sufficient permissions to access this page.

    http://wordpress.org/extend/plugins/jetpack/

  2. troelschristensen
    Member
    Posted 2 years ago #

    @shrtstck Getting the same error at myt server after the upgrade.

    Please fix soon!! Thx for a great product.

  3. shrtstck
    Member
    Posted 2 years ago #

    If there is additional info I can provide to help dev expedite this let me know.

  4. Sam Margulies
    Member
    Posted 2 years ago #

    I am also getting a fatal error.

  5. RadicalWacko
    Member
    Posted 2 years ago #

    I am getting the same error as well.

  6. xaotikdesigns
    Member
    Posted 2 years ago #

    I've got the same thing here

  7. xaotikdesigns
    Member
    Posted 2 years ago #

    Just to add, I've disabled all other plugins, and I still have the same issues.

  8. kathyforer
    Member
    Posted 2 years ago #

    broken here too.

  9. rebabaskett
    Member
    Posted 2 years ago #

    Mine was too. I downloaded the plugin from the site (not updater in wordpress) and uploaded it using FTP and activated it back and no error.

    Reba

    UPDATE - after activating with wordpress.com I got the same error.

  10. JonManness
    Member
    Posted 2 years ago #

    Just about the same error in my dashboard:

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in [redacted]/wp-content/plugins/jetpack/jetpack.php on line 1207

    Warning: Invalid argument supplied for foreach() in [redacted]/wp-admin/includes/plugin.php on line 1439

  11. charloub
    Member
    Posted 2 years ago #

    Just thought I would add on to this list - getting the same error message. Wonder how long we will have to wait for a patch

  12. troelschristensen
    Member
    Posted 2 years ago #

    Anytime soon, i believe. They made the 1.3.2 version after an error message 2 hours ago. Quick response time. :)

  13. KentUser
    Member
    Posted 2 years ago #

    Had to disable the plugin - which (frankly) is rather terrible at the best of times.
    And what's all this FTP nonsense?

  14. ScalIT
    Member
    Posted 2 years ago #

    I, too, am getting the same error.

  15. London Accountant
    Member
    Posted 2 years ago #

    Yes me too. Had to deactivate the plugin.

  16. wiliam.betol
    Member
    Posted 2 years ago #

    I had the same error on one of my WP site, but the second one is working fine (same update though..) Had to deactivate the plugin on the buggy site...

  17. supernovia
    Member
    Posted 2 years ago #

    I'm not seeing it here -- which Jetpack options are you all using?

  18. Michael Adams (mdawaffe)
    Member
    Plugin Author

    Posted 2 years ago #

    We're working on a fix now. Thanks for your patience.

  19. troelschristensen
    Member
    Posted 2 years ago #

    @supernovia - When i reinstall, i should be the initial/start options, right? Can't change anything before i've connected with wordpress.org. So no options!

  20. troelschristensen
    Member
    Posted 2 years ago #

    @Michael Adams - Great! Thanks for the response.

  21. shrtstck
    Member
    Posted 2 years ago #

    Everything is working fine on my site and JetPack is still capturing hits to pages for stats so I am not deactivating, it seems the only issues I can tell are the error messages on the dashboard.

    I agree JetPack is super flaky but unfortunately it drives my "Most Popular Posts" widget, which is a good one to have

  22. shrtstck
    Member
    Posted 2 years ago #

    @Michael - THX! Like I said if there is any info I can provide to assist don't hesitate to ask. Trying to be helpful here and not a whiner ;)

  23. troelschristensen
    Member
    Posted 2 years ago #

    Everything working on my site again now. Updated to 1.3.3 via FTP.
    Thanx, Michael!!

  24. MrTomDaly
    Member
    Posted 2 years ago #

    I got an error that an arrey was not an arrey...

  25. Michael Adams (mdawaffe)
    Member
    Plugin Author

    Posted 2 years ago #

    The reason these bugs exist is because we're trying to do make the Stats page (what most want people look at) what you see when you click on the Jetpack+Stats top level menu.

    There's a bunch of edge cases, though, so we have to be "clever" in how we do it.

    Apparently, we haven't found all the edge cases because we don't yet know all the things to test for. We've been releasing like mad to try and fix the bugs you report, but it looks like this experiment is at best half-baked, so we'll probably revert to the old behavior: When you click the Jetpack top level menu, you'll see Jetpack, not stats.

    Stay tuned.

  26. oriste
    Member
    Posted 2 years ago #

    I got the warnings after I updated to the 1.3.2 version. I disabled the plugin. Now I see there is a 1.3.3 update but I don't get an auto-update message in the wordpress admin backend.

  27. shrtstck
    Member
    Posted 2 years ago #

    All good now, thanks for the quick response!

  28. MrTomDaly
    Member
    Posted 2 years ago #

    1.3.3 worked for me!
    checked "update" without the auto-update message - it failed (it said it was up to date)...Then it found the new update. Installed and then refreshed the screen. Lokks okay to me.

  29. oriste
    Member
    Posted 2 years ago #

    Inspired by @MrTomDaly I forced an update and got the same sequence of reaction, first failed, then offered auto-update. All's well that ends well. Kudos to the JetPack team for prompt reaction.

  30. charloub
    Member
    Posted 2 years ago #

    JetPack - amazing response! Thank you

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags