WordPress.org

Ready to get started?Download WordPress

Forums

jcwp scroll to top
[resolved] 2 Bugs: Centering Problem & Jerky animation in Chrome (7 posts)

  1. janubande007
    Member
    Posted 1 year ago #

    Hello Jaspreet. Great plugin, good work. I have noticed 2 problems however:

    1. Easing type - easeInOutExpo: I've setup this type of easing, the start of the easing is 'jerky' in my Google Chrome browser on Windows 7, I don't see the same issue in FireFox & IE. Can this this be fixed?

    2. Centering Problem: The fixed element that holds the scroll to top link configured to stay at the bottom of the browser in the 'Center' is 'approximately' in the center not 'exactly' in the center. And I figured that is probably because the left position is calculated based upon the width of the browser, so the element starts at center rather than be in the Center. This also has a problem when the browser window is resized. If the size is decreased, the button/link moves to the right & does not display if the browser is resized to less than 1/2 the original size or it may move to the left if the browser is increased in size. So this algorithm shouldn't be the way to center an element. Instead an element or <div> holding the scroll button/link should have {display:block; margin-left:auto; margin-right:auto; position:relative; } and then be placed inside another <div> with {position: fixed; bottom: 0; left: 0; width: 100%;} that spans the entire width of the browser and placed at the bottom of the browser which will then cause the <div> element inside it to be properly centered. This way it will handle changes in browser sizes also & will always appear 'exactly' in the center. Make sure to test in IE7 & IE8 also that the centering works.

    Can you post a reply after fixing these issues?

    Thanks in Advance.

    J.

    http://wordpress.org/extend/plugins/jcwp-scroll-to-top/

  2. Jaspreet Chahal
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Janubande,

    Thanks for your feedback mate.

    1. I can't reproduce the problem you have in Chrome for jerkiness. How long is your page content. The borrowed library is jQuery-UI for all the easing options. Did you try any other easing type.

    2. Centering problem: I will look into that very soon. Thanks for letting me know.

    I will reply again once I get to this plugin for a revision. I can't see that happening in next few days but I will try to fix it whenever I get a chance in between.

    Cheers man!
    Jas

  3. Jaspreet Chahal
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Janubande,

    I have fixed centring and resize issues as I was able to reproduce them.
    Please give it a go in version 3. Reopen this case in case you still see this problem. I like your solution but I did it the Javascript way.

    Cheers!

  4. janubande007
    Member
    Posted 1 year ago #

    Hello Jaspreet. Thanks for the quick fix.

    I updated to version 3 and infact the centering is now 'broken' (always appears on bottom left) when the option for Container Width is "auto" (as I have it) but otherwise it works. Can you fix that too?

    Regarding jerkyness in Chrome you need to have a page about 3 screens long and give a long animation time like at least 2000 or 3000 ms and then you will notice it at the start it jerks in Chrome (with easing type: ease InOutExpo) when you view it side-by-side to compare it with IE or FF.

  5. Jaspreet Chahal
    Member
    Plugin Author

    Posted 1 year ago #

    oops! you are right with width set up to auto. I will give it another revision when I get a chance. Till that time you can define width in pixels.

    With jerkiness however I can't reproduce it. Sorry mate. But I will give it another shot during next testing circle. It could be because of my crazy hardware but I am not sure. I will try it on a low end machine too.

    Regards
    Jaspreet Chahal

  6. janubande007
    Member
    Posted 1 year ago #

    I moved my jcwp stt btn to bottom right, but glad you are going to fix, as I may someday need to have centering with auto width.

    Here's the link to my site http://FilmographyStudio.com (under construction). Maybe that will help you debug the jerkyness in Chrome. I have good hardware too (Quad Core), but for me it jerks at the start of animation in Chrome.

  7. janubande007
    Member
    Posted 1 year ago #

    Hi JC. Were you able to notice the jerkyness in chrome? Try it out here - http://filmographystudio.com/blog

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.