WordPress.org

Ready to get started?Download WordPress

Forums

IP.Board Comments
htaccess - post url not working (2 posts)

  1. Jinkler
    Member
    Posted 1 year ago #

    Hi,

    I'm using this with WP 3.3.2 and IPB 3.3.1.

    IPB was set to use FURLS (Redirect to new friendly URL format set to yes, URL type was PATH INFO and "Use .htaccess mod_rewrite" was set to yes. WP was set to use default permalinks. Everything was fine, worked perfectly.

    Now, I wanted to change my WP permalinks to 'postname'. So I select that, add the code into my htaccess file, and thats where the problems begin.

    If I create a post, the link on the post wants to take me to:
    http://www.xxxxxxxxxx.co.uk/community/post.php/topic/42-test-1/

    But when I visit the forums, the actual URL of that topic is:
    http://www.xxxxxxxxx.co.uk/community/index.php/topic/42-test-1/

    The difference being post.php and index.php

    How do I resolve this?

    Thanks

    http://wordpress.org/extend/plugins/ipb-comments-for-wordpress/

  2. Beer
    Member
    Plugin Author

    Posted 1 year ago #

    You probably are, but make sure you're using the latest IPB Comments plugin. The index.php vs post.php issue reminds me of a previous version, but also with the IPB Admin Control Panel (AdminCP) settings for friendly urls.

    Verifying mine: Settings / Search Engine Optimization (Friendly URL Settings)

    Redirect to new friendly URL format: Yes
    URL type: Query String
    Use .htaccess mod_rewrite: Yes
    Incorrect Permalink Handling: Do Nothing

    I'll try to change my WP permalinks to see if anything happens and get back to you. Let me know if you arrive at a solution before.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic